The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. garak0410's Avatar
    I successfully installed the 10166 build on my Lumia ICON and here are my thoughts and experiences with it...

    After a straight upgrade, I encountered the pesky LOADING for the start screen...would take 2-3 minutes to bring up start screen and even then, after a few reboots, the screen wasn't very responsive. So started the CAMERA all so I could attempt to get into the settings, which it did let me and then I did a hard reset on the phone for a clean install of 10166 with NO RESTORE FROM BACKUP and set up as new phone. After that, things improved dramatically.

    Everything seems to run quite well and for the most part, fast, on the Lumia ICON. I have encountered no show stoppers but here are a few things of note (and not all are specific to the ICON)

    Outlook live tile doesn't seem to work.
    Many live tile abilities of apps like Windows Central and NextGen reader don't seem to work. At least the "counter" on Windows Central isn't working for me.
    Cortana doesn't seem to be my default text message/voice to text with my Uconnect in my Jeep. (and man, I miss it already)
    The Photos app seems quirky. Sometimes doesn't immediately show recently taken pictures.
    Device Hub is missing (and really needed for my DT-903 charging pad so I can adjust the "light" times...
    Wireless charging with the DT-903 deems to be at a snails pace.
    Batter life seems a little worse. A "little"...
    Podcast App still crashes (closes) as much as it did on 8.1.
    Zedge will not save ringtones.

    Overall, I would say this is good enough for a daily driver as long as you can continue to grow with it.
    07-13-2015 09:01 AM
  2. Tim Stone's Avatar
    Thanks for starting this thread. Before I do an update to 10166, to be my "daily driver" I need to know the following:

    Basic phone - Is it receiving and placing calls correctly and consistently
    Messaging - Is it properly handling text messages including text grouping
    Wi-Fi - Is the wi fi connection working correctly and consistently
    Bluetooth - Is Bluetooth solid ( mainly for a headset connection )
    Microsoft Band - Will it now track and work with a Microsoft Band including Cortana functionality.
    Email Can email accounts be added, and is the People app working consistently.
    Battery - Can we get a normal workday of battery usage on a charge ?

    Your observations on these would be greatly appreciated.
    07-13-2015 09:46 AM
  3. garak0410's Avatar
    Thanks for starting this thread. Before I do an update to 10166, to be my "daily driver" I need to know the following:

    •Basic phone - Is it receiving and placing calls correctly and consistently
    •Messaging - Is it properly handling text messages including text grouping
    •Wi-Fi - Is the wi fi connection working correctly and consistently
    •Bluetooth - Is Bluetooth solid ( mainly for a headset connection )
    •Microsoft Band - Will it now track and work with a Microsoft Band including Cortana functionality.
    •Email Can email accounts be added, and is the People app working consistently.
    •Battery - Can we get a normal workday of battery usage on a charge ?

    Your observations on these would be greatly appreciated.
    Sure thing Tim...

    Basic Phone/Messaging - Making calls and text messaging seems to be fine. It is taking some time for my backed up text messages to reappear but they are slowly populating. Group text seems OK too.

    Wi-Fi - No Wi-Fi issues for me as of yet.

    Bluetooth - Every Bluetooth device has connected without a hitch. From my Nokia 360 speakers to my Microsoft Band to my Uconnect in my car. The only problem I've had is that Cortana doesn't work via Uconnect as it did under 8.1

    Microsoft Band - Microsoft Band works just fine for me. Microsoft Health works great and I do get my emails and texts. I do miss the CLEAR MY BAND app as I cannot get it installed. I still have disconnect issues via Bluetooth connection via the Band as I did under 8.1...and I am on my second Band.

    E-Mail - Quirky under the new Outlook client. I was able to connect my Outlook and Office 365/Exchange accounts but email just seems quirky. I do get my emails but no live tile updates. I do get notification on my BAND. When you try to manually sync email, I get messages that it isn't working (SOMETHING WENT WRONG message) but I get that a lot on my Windows 10 PC install too and I still get the emails.

    Battery - Today is my first test with it as a daily driver at work. Pulled off charger at 9:30 and minimum use, down to 90% at 11AM. I would say there is a little more drain under 10 but not showstopping as of yet.

    Hope that helps...
    07-13-2015 11:14 AM
  4. ITMaster68's Avatar
    thanks. I had a similar experience with my icon, except I did restore from backup after a hard reset. It took a while for apps to install in the background.. but once they did, its been fine since.. battery life is not great.. though its not much different from 8.1.1// Phone is now 20 months old so battery could be nearing the end of its life.. just waiting for new flagship from Verizon..
    I'm having an issue where in previous build149.. het Cortana wouldn't train at all.. I really liked the feature.. I dealt without having it.. then I upgraded to 166 and before I did hard reset, I was able to bypass loading screen issue by pulling down notifcations and getting to all settings.. I decided to hi hey Cortana settings and it said voice activation was not enabled in my phone.. wtf.. so I did the hard reset and hey Cortana doesn't even show up under extras anymore or if I search for it...do you have hey Cortana after hard reset on your icon?
    07-13-2015 11:50 AM
  5. Tim Stone's Avatar
    Thanks for the comments. I'll be watching for others also.
    I have a 928 also and it looks cleaner on this version. The Icon carries my business line, so I wanted to be sure calling and Bluetooth are working fine. Text messaging is also important. All other apps are secondary ... but the People app is important because it IDs the caller.

    I think I will let it update after normal business hours. I can always revert back easily. I have an O365 Exchange setup so it is very easy to move around quickly.

    I'll be watching for other comments.
    07-13-2015 12:00 PM
  6. CX1's Avatar
    Not finding 10166 as anything but a headache.

    • Most apps crash a lot. Mail, Music, Messaging, etc, etc..
    • Visual voicemail doesn't work. FYI if you uninstall VV and try to reload it is not available for the device.
    • People hub completely sucks now. It is a phonebook, not a hub.
    07-13-2015 12:44 PM
  7. garak0410's Avatar
    I did get Device Hub to work but it took some work...I'll post a separate post on it...
    07-13-2015 12:46 PM
  8. Tim Stone's Avatar
    Do any of you use Visual Voicemail ( Verizon ) ? Someone else posted that it doesn't work with 10166, and cannot be installed ( says it is not compatible with the device ). That is a good feature for me ...
    07-13-2015 12:49 PM
  9. bhulabhatka's Avatar
    My Lumia Icon works well after the upgrade.. I saw a battery life improvement... Make sure that you turn off the background processes for apps you do not care for. My only issue are the two apps stuck in the update mode that does not seem to update and keep getting the error message. They are Nokia Account and Transfer my data.... I DID NOT do a hard reset (did a soft reset only)
    07-13-2015 06:53 PM
  10. Tim Stone's Avatar
    I did the upgrade with no special considerations. I already had minimal apps on the phone.

    The upgrade did go through. The one feature that clearly does not work is Verizon Visual Voice Mail. I'm thinking that may not get fixed ... so I may need to turn off the service.

    It appears that the standard apps will install and run OK ...
    07-13-2015 07:22 PM
  11. Lumious's Avatar
    Thanks for starting this thread. Before I do an update to 10166, to be my "daily driver" I need to know the following:

    •Basic phone - Is it receiving and placing calls correctly and consistently
    •Messaging - Is it properly handling text messages including text grouping
    •Wi-Fi - Is the wi fi connection working correctly and consistently
    •Bluetooth - Is Bluetooth solid ( mainly for a headset connection )
    •Microsoft Band - Will it now track and work with a Microsoft Band including Cortana functionality.
    •Email Can email accounts be added, and is the People app working consistently.
    •Battery - Can we get a normal workday of battery usage on a charge ?

    Your observations on these would be greatly appreciated.
    10166 feels just like a complete OS Windows 10 with some bugs here and there. Everything is smooth and fluid and runs quickly. I am having trouble connecting to my Bluetooth in the BMW, it says tap to pair and when I do that it says unable to connect and just goes back to "tap to pair" 8.1 worked fine but this is not working. It's interesting how some people have no problems with Bluetooth connectivity. And onedrive uploads slow or misses files. Batter life is fine. MMS and SMS work fine. Texting works fine, haven't tried group text.
    07-14-2015 09:54 AM
  12. Al4video's Avatar
    garak0410.............nice report. When you say Zedge won't store your ring tones? Could you explain?
    I use RPC Ringtones and I just copied them manually to the ringtone folder and all is fine.
    07-14-2015 10:18 AM
  13. garak0410's Avatar
    garak0410.............nice report. When you say Zedge won't store your ring tones? Could you explain?
    I use RPC Ringtones and I just copied them manually to the ringtone folder and all is fine.
    I primarily use ZEDGE for ringtones...when you try to download a ringtone from Zedge, it just says FAILED TO EXECUTE COMMAND and it will not save a downloaded ringtone...let me try copying over some RPC ringtones manually and see if it works...will try tonight...
    07-14-2015 10:36 AM
  14. MikeSo's Avatar
    Thanks for this thread. I have 10166 on my Lumia 635, and it is definitely the most stable version yet. I'm tempted to go ahead and put it on my Icon too... it really is a great OS (notwithstanding all the current bugs). The apps crash a lot though on my 635, seems like that is an issue in the Icon too so that might keep me waiting for the next one.

    I was very skeptical towards W10M. I gotta say though, Microsoft has a winner on their hands here (if people use it is another matter...).
    07-14-2015 10:43 AM
  15. Tim Stone's Avatar
    After a day of "letting the phone adjust" to 10166, my Icon is working sufficiently to keep me "in touch". As previously noted, Verizon Visual Voicemail is not working with the supplied voicemail app. However, the phone places and receives calls, and basic text messaging is fine. That is the key for me. It also handles emails ( secondary need ). Hey Cortana "Is not available for your phone" but, like voicemail, it worked fine in 8.1.

    My phone resides on an upright charger so battery life is not an issue. However, it clearly is not "great" ...and Store app updates / installs clearly make the phone very hot.

    Having experienced the graphics of previous builds, it's nice to now see a Start Screen with sharp, clear, tiles like we had in 8.1. It's fun to see the different configuration we can get with tile sizes and locations.

    I am using it with a Bluetooth headset. ( Plantronics PLT-55 ). It paired easily, and it responds to voice commands. It now alerts me to text messages and will read it, or ignore. ( At least it asks me if I want to do that ... but when I said Read It there was no response ... could have been a fluke ). Call quality is good both ways.

    Overall, this is a good "base" and works well for me. Where we go from here, time will tell !
    07-14-2015 11:54 AM
  16. DavidinCT's Avatar
    I have been running 10166 on my Verizon ICON now for 3 days. The Visual Voice mail program seems to work, I loaded it and it's showing my VM and seems to sync fine. I don't have any new messages but, I tested some saved messages and they play back fine. For people with issues, uninstall and reinstall, maybe that will fix it ?

    Blu-tooth seems to be working here very well, I have my Pebble watch connected, When email comes in, I get a popup on my watch right away, it really blows that I cant do any other apps with it due to a bug in 10166 (see below)

    My problems, Not sure if they are just ICON related or just Windows 10 in general.
    1. Using Cortana to reply to texts does not work. I will get a Notification that someone sent a text and after it prompts for a reply, it just crashes, leaving a lock screen with just the picture nothing more (soft reset didn't fix)
    2. Applications can be spotty at best, a few apps would just open then close right now, try them 3-4 times, they open up.
    3. Hey Cortana does not work (says unsupported on my phone that DOES support it).
    4. The Pebble notifications app WORKS but, when you bring the list of Apps, It hangs with "Loading Applist" 10166 must of changed how the app list is displayed. Application will need to be updated or all you will get is email notifications on your watch. **BIG DEAL FOR ME**
    5. Camera button is spotty, If I try to use it "SOMETIMES" it will work, normally I have seen 3-4 times, then it finally works, starting Camera from the start menu starts first time with no problems.
    6. Medium size tiles for email, show nothing but the account name, even though new emails come in but the live tile does not update (Exchange, Hotmail and office 365 email accounts). It works SOMETIMES, spotty at best and not dependable.
    7. Data connection just drops randomly, was connected one moment then No apps would get internet (feedback app seems to be working though)
    8. The Verizon logon on startup does not take a full screen.
    9. The new Xbox Games app, Has a option for "My Games" This only shows 3-5 games, I have about 35 Xbox live games and about 10 non-xbox live games installed, updating it or restarting it has no change here.
    10. Setting an alarm (using the Alarm & Clock app) does not show the alarm ICON on the lock screen (as in past versions of Windows Phone)
    11. When an alarm goes off, it does prompt for SNOOZE or off but, after about 10 seconds the screen shuts off, needing to power the phone on to hit snooze.
    12. On the Notifications pull down, time to time (seen this 2 times on day one) will show all boxes blinking, not showing status, going manually in the settings allows you to change this but, a soft reboot resolves it for a while(power off and back on resolved it).
    13 Battery draining is happening, in 8.1 I can list all the apps and games that CAN run in the background, WIndows 10 Phone only allows you to adjust this for SELECT apps. There must be app or 2 causing lots back ground drain but, I am unable to find a setting to disable it.
    14 Loading screen are still common, I think this is the default screen when something crashes and it tries to restart it.
    15. Attempting to add a Ring tone to a Contact pops up needing an App from the store.

    Battery seems funky, like battery size is not registered correctly, The other day, I was at 60%, I dropped it on the wireless charger and with in 20 min, it was at 100%. This is impossible over QI. A full charge takes about 2 hours, so this should of taken at least an hour. Noted this a few times.

    A few stable issues with some apps crashing but, over all very good. Easy as fast as 8.1 and crashing seems limited to apps, not the OS in the whole. And Verizon MMS works fine in this build, this was the deal killer for me in 10149.

    I'm keeping it for the time being, stable enough for day to day use so far, unless I run into a deal killer issue.

    I was very skeptical towards W10M. I gotta say though, Microsoft has a winner on their hands here (if people use it is another matter...).
    I was the same way, meth, ok, on the earlier builds that crashed ever 30 seconds. I am starting to like it, I think once the bugs are out of the email client, I think I am going to love it. When I went back to 8.1 I kind of missed that feature alone (10149).

    There is a lot of perks and updates across the device, even the Xbox app looks pretty good, too bad it's slow as crap and does not display all my games.

    I look forward to seeing where they go with this and how stable it ends up being. It would be nice of Universal apps fixes the major app problem on WP, if it does, then it for sure would be a fair item against Android and iOS...

    Something time will tell for sure...
    Last edited by DavidinCT; 07-14-2015 at 01:36 PM.
    MikeSo likes this.
    07-14-2015 01:23 PM
  17. Arsynic's Avatar
    Yep. It is critical that you refresh and do not restore from backup. I spent most of the night reinstalling apps--which all work great so far and it was worth it.

    Prior to doing a refresh, I had a Loading... screen after the update and it didn't even go to the start screen. Managed to get into the action center and get to settings and immediately bombed it to hell. It's like night and day.
    07-14-2015 01:32 PM
  18. DavidinCT's Avatar
    Yep. It is critical that you refresh and do not restore from backup. I spent most of the night reinstalling apps--which all work great so far and it was worth it.

    Prior to doing a refresh, I had a Loading... screen after the update and it didn't even go to the start screen. Managed to get into the action center and get to settings and immediately bombed it to hell. It's like night and day.
    I backedup m phone (using the crappy backup app in 8.1), Nuked my 8.1 install, Installed all apps and configured everything, THEN I did a upgrade to 10166, No more problems than others...

    The upgrade process seems to work in this build pretty well...
    07-14-2015 01:48 PM
  19. Tim Stone's Avatar
    I'm puzzled:

    1) We have several reports of Visual Voicemail not working ( and I'm one of those ) and yet David has it working fine. That puzzles me. I can't get it to sync, and I can't find the app listed in the store to re-load. It was working on 8.1.

    2) My phone was on 8.1 with a minimum of apps. I simply ran the Upgrade, and did NOT do a refresh. So far all the essential items are working fine ( except VM ) so I hate to refresh it and have other issues arise. I never saw problems with the upgrade when I ran it yesterday.

    3) Hey Cortana is definitely not working. It provides a message that Voice Activation is not supported on this device ( it is ... it worked before on the Icon ).

    If anyone has ideas on the Visual VoiceMail I'd love to hear them.
    07-14-2015 02:05 PM
  20. garak0410's Avatar
    Yep. It is critical that you refresh and do not restore from backup. I spent most of the night reinstalling apps--which all work great so far and it was worth it.

    Prior to doing a refresh, I had a Loading... screen after the update and it didn't even go to the start screen. Managed to get into the action center and get to settings and immediately bombed it to hell. It's like night and day.
    Yep...had the same PROBLEM with LOADING..and yeah,. with each new build, I may do a refresh each time...just something I'll live with until I get my Flagship (PLEASE Verizon, get one!!!)....​
    07-14-2015 02:08 PM
  21. antonius138's Avatar
    I too am having almost all of the same issues that everyone else is having...10166 is by far the best build so far, the previous ones were not even worth it and I rolled back usually after a day or so and I am on day 3 or 4 is it? with this build.

    Cortana will not work with pretty much any app at this point, "Hey Cortana" is a known missing feature that I think Gabe commented on, and I sorely miss it with my Microsoft Band for replies etc. My biggest complaint is with the store...now that the old Store is gone and only universal apps are available my list of "not supported on this device" apps is longer than what I actually have installed. And the other big defect is the apps in the new store are not as current as the apps on the old store an example is Microsoft Health... the version in the new store doesn't have the Golf tile and I was hoping to use that this weekend. Microsoft Hyperlapse Mobile is another app I use quite a bit and is on the not available list. I am hoping that the merge between stores happens quickly and more apps on the not available on this device list grows or lots of people will bail or go back to 8.1 as I might if I want use the golf tile this weekend on my Band.

    A.

    Things that are much better or that are finally working is sending pictures with MMS, being able to search and click on addresses and having them come up in the map app or copy and paste addresses and getting directions is finally working. Overall stability is so much better than previous builds but not quite on par with 8.1 Update 1.
    MikeSo likes this.
    07-14-2015 04:49 PM
  22. Oliverspin's Avatar
    Not finding 10166 as anything but a headache.

    • Most apps crash a lot. Mail, Music, Messaging, etc, etc..
    • Visual voicemail doesn't work. FYI if you uninstall VV and try to reload it is not available for the device.
    • People hub completely sucks now. It is a phonebook, not a hub.
    1. Those apps on my Icon do not crash a lot. Practically never, can't remember the last time they did.
    2. VV for me didn't install right either, but who needs it?
    3. People hub looks great to me and I don't have any problems with it. It still is a hub, don't know what you're talking about.
    07-15-2015 01:39 AM
  23. Hong Yun-seong's Avatar
    Hi! Please let me know if you were able to find a fix for this... I also get my ringtones from Zedge, and noticed that problem on buil 10049
    07-15-2015 03:05 AM
  24. bobo1510's Avatar
    Hi Guys...Please Help!

    Can you post your APN or Cellular settings for getting MMS to work on Verizon? I am on build 10166 and it is still failing?

    Thanks a million!
    07-24-2015 09:47 AM

Similar Threads

  1. Build 10166, Cortana and Uconnect
    By garak0410 in forum Windows 10 Mobile Insider Preview
    Replies: 2
    Last Post: 07-20-2015, 03:49 PM
  2. Why can't my Lumia 640 sync the Outlook Calendar?
    By GavS in forum Windows Phone 8.1
    Replies: 1
    Last Post: 07-14-2015, 08:19 AM
  3. Why aren't apps getting updated on my Lumia 720 through WiFi?
    By WPCentral Question in forum Nokia Lumia 720
    Replies: 1
    Last Post: 07-13-2015, 12:17 PM
  4. Wifi is not connecting to my Lumia 1020 and not setting ip address. What do I do?
    By Windows Central Question in forum Nokia Lumia 1020
    Replies: 1
    Last Post: 07-13-2015, 11:27 AM
  5. Developer mode in windows 10 build 10166
    By ajaya p in forum Windows 10 Mobile Insider Preview
    Replies: 0
    Last Post: 07-13-2015, 08:43 AM
LINK TO POST COPIED TO CLIPBOARD