1. omagic82's Avatar
    The longer I leave build 10166 on my 1520 the worse it gets. MS has a lot of work to do still with Windows 10 Mobile. This build is much better than those that preceded it, but that's not really saying much. The Store app has been terrible from the start. It's slow, has trouble updating apps and itself and now crashes when I try and open it. Every time. I tried a soft reset and that doesn't help. Opening an app link from the web tries to open the app also and it crashes. Aside from that, the Photos app is slow and terrible, especially when attaching pictures to email and messaging. The 1520 screen becomes unresponsive pretty often at the end of phone calls and when unlocking it, prompting me to soft reset a few times a day. The Alarms app just doesn't sound the alarm some mornings. Live tiles are inconsistent and some don't work at all. Don't get me started on Groove Music. It skips past half of my songs and won't play them. It's a reborn Xbox Music app. You'd think MS would have stumbled on a music app that worked after this long. The Edge browser is also terrible. It's slow, renders some sites horribly and doesn't register taps much of the time. It's also inconsistent at changing back and forth between portrait and landscape on some sites (YouTube.com is particularly bad).

    I have to keep reminding myself it's still a beta. I did this to myself. I could still be using 8.1. I have hope a much better build is around the corner, especially with desktop Windows nearly finished. I'm hoping MS gets this thing right on phones. This is probably their last shot at mobile.
    07-20-2015 03:29 PM
  2. Jazmac's Avatar
    I can't say I agree. I have a 1520 running 10166 and it has been pretty much outstanding for a preview build. Looking through your list, I don't have any of the issues you're having trouble with but I think I know what causes them. In short, your install took some risks and so, much of it doesn't work.
    dmierzwa likes this.
    07-20-2015 04:05 PM
  3. mmcpher's Avatar
    Did you do a hard reset after install? I ask because my experience with 166 on my 1520 isn't nearly as bad as yours has been. As with most Builds, there is a tendency for it to bog down slightly after a few weeks. That's why its great when there are frequent new builds. I have had intermittent issues with keeping multiple outlook account respecting each other's boundaries, but mostly this build works well enough to be my daily driver. The Edge browser is a big improvement over the prior browsers, at least on my phone.

    I forgot to add: more than previous Builds, a lot of the main apps have been updated once or more since 10166 came out. Maybe some of your issues are related to that,
    07-20-2015 04:09 PM
  4. Sundaravadivel M's Avatar
    Almost all the above issues im facing in my lumia 525. Especially MS removed BETa from the store. it crasing lot when im trying to install any app.
    07-21-2015 02:17 AM
  5. dmierzwa's Avatar
    I'm running 10166 on my L 1520 and am not experiencing any issues noted above. Overall, it's been a great upgrade so far. I can say this build is finally good enough for day to day use by far.
    07-21-2015 11:28 AM
  6. pw38's Avatar
    I have to agree with the OP. It might work well for some but it's very inconsistent. Not even taking into consideration the continuing sensitivity issues from the 1520 and the constant non-responsiveness of the screen just about every part of the preview build for me is either broken or half working. Here's just a sampling of what I deal with on a day to day basis:

    • The screen becomes non-responsive
    • Start screen is stuck in a continuous loading loop
    • The Messaging app just stops working for days at a time
    • The store crashes pretty consistently
    • The store won't download updates or install apps
    • The phone dialer will randomly decide to hang calls up
    • Cortana will become unresponsive
    • Cortana search will activate and won't close
    • If you try to uninstall an app the phone will hang
    • Reformatting the SD card will not remove apps from the app list and will not allow you to re-install them
    • Website links on the start menu won't open right and will make the phone unresponsive
    • Pinning apps in a folder will make the phone unresponsive
    • After removing a live tile from the start screen the phone will hang or the start screen will go into a loading loop
    • Trying to close an app by holding the back button down will not allow you to close apps or will close them all.
    • Edge becomes non-responsive after opening links from within websites
    • Edge will randomly close tabs
    • The phone will restart itself at random times throughout the day


    That's just a few of the issues I am having with 10166. I even did a hard reset after installing and the situation remains the same. I'm probably going to downgrade to 8.1 if possible because while I knew what I was getting into with beta software this is a bit absurd considering how much more responsive the desktop preview versions have been.
    [/LIST]
    07-21-2015 11:37 AM
  7. omagic82's Avatar
    Yep, I have done a hard reset twice after install. My issues persist.
    07-21-2015 01:34 PM
  8. Basket Basket's Avatar
    I have similar bug with alarm on Lumia 520 10166 after hard reset. If phone not sleeping then alarm sounds. But, if phone in sleep(dark screen) then alarm without sounds.
    07-22-2015 01:18 PM
  9. Jazmac's Avatar
    I have to agree with the OP. It might work well for some but it's very inconsistent. Not even taking into consideration the continuing sensitivity issues from the 1520 and the constant non-responsiveness of the screen just about every part of the preview build for me is either broken or half working. Here's just a sampling of what I deal with on a day to day basis:

    • The screen becomes non-responsive
    • Start screen is stuck in a continuous loading loop
    • The Messaging app just stops working for days at a time
    • The store crashes pretty consistently
    • The store won't download updates or install apps
    • The phone dialer will randomly decide to hang calls up
    • Cortana will become unresponsive
    • Cortana search will activate and won't close
    • If you try to uninstall an app the phone will hang
    • Reformatting the SD card will not remove apps from the app list and will not allow you to re-install them
    • Website links on the start menu won't open right and will make the phone unresponsive
    • Pinning apps in a folder will make the phone unresponsive
    • After removing a live tile from the start screen the phone will hang or the start screen will go into a loading loop
    • Trying to close an app by holding the back button down will not allow you to close apps or will close them all.
    • Edge becomes non-responsive after opening links from within websites
    • Edge will randomly close tabs
    • The phone will restart itself at random times throughout the day


    That's just a few of the issues I am having with 10166. I even did a hard reset after installing and the situation remains the same. I'm probably going to downgrade to 8.1 if possible because while I knew what I was getting into with beta software this is a bit absurd considering how much more responsive the desktop preview versions have been.[/LIST]
    Good idea. I've said it before, if you do this installation correctly, your issues should be minimal. Rushing to use it before the configuration is complete is asking for headaches. 8.1 is probably a better move for you. You gave it a shot but man, its beautiful even with the few quirks I've bumped into, namely an occasional store crash.
    07-22-2015 09:53 PM
  10. Mohamed Ahmed Nader's Avatar
    The longer I leave build 10166 on my 1520 the worse it gets. MS has a lot of work to do still with Windows 10 Mobile. This build is much better than those that preceded it, but that's not really saying much. The Store app has been terrible from the start. It's slow, has trouble updating apps and itself and now crashes when I try and open it. Every time. I tried a soft reset and that doesn't help. Opening an app link from the web tries to open the app also and it crashes. Aside from that, the Photos app is slow and terrible, especially when attaching pictures to email and messaging. The 1520 screen becomes unresponsive pretty often at the end of phone calls and when unlocking it, prompting me to soft reset a few times a day. The Alarms app just doesn't sound the alarm some mornings. Live tiles are inconsistent and some don't work at all. Don't get me started on Groove Music. It skips past half of my songs and won't play them. It's a reborn Xbox Music app. You'd think MS would have stumbled on a music app that worked after this long. The Edge browser is also terrible. It's slow, renders some sites horribly and doesn't register taps much of the time. It's also inconsistent at changing back and forth between portrait and landscape on some sites (YouTube.com is particularly bad)..
    Basically u summed it up. I'll just add a couple more.

    - No zooming ability in edge on mobile version websites while the font is super small e.g. YouTube with its new reddish lollipop look
    - voice dictation most of the time crashes the phone 4 times out of 7 "yes I count"
    - Apps are now disappearing from the app list although I can open them from the store :$
    - Camera button doesn't open the camera when locked just vibrates then brings me to the lock screen
    - Try to open the photo gallery from the camera app and it crashes "the app not the phone"
    - Outlook mail confuses my multiple accounts with each other

    Still needs a lot of work. But in the end. Hat's off to Microsoft for giving us a glimpse of what will soon be the iPhone killer and the real android competitor
    07-22-2015 10:43 PM
  11. Carlos002's Avatar
    The longer I leave build 10166 on my 1520 the worse it gets. MS has a lot of work to do still with Windows 10 Mobile. This build is much better than those that preceded it, but that's not really saying much. The Store app has been terrible from the start. It's slow, has trouble updating apps and itself and now crashes when I try and open it. Every time. I tried a soft reset and that doesn't help. Opening an app link from the web tries to open the app also and it crashes. Aside from that, the Photos app is slow and terrible, especially when attaching pictures to email and messaging. The 1520 screen becomes unresponsive pretty often at the end of phone calls and when unlocking it, prompting me to soft reset a few times a day. The Alarms app just doesn't sound the alarm some mornings. Live tiles are inconsistent and some don't work at all. Don't get me started on Groove Music. It skips past half of my songs and won't play them. It's a reborn Xbox Music app. You'd think MS would have stumbled on a music app that worked after this long. The Edge browser is also terrible. It's slow, renders some sites horribly and doesn't register taps much of the time. It's also inconsistent at changing back and forth between portrait and landscape on some sites (YouTube.com is particularly bad).

    I have to keep reminding myself it's still a beta. I did this to myself. I could still be using 8.1. I have hope a much better build is around the corner, especially with desktop Windows nearly finished. I'm hoping MS gets this thing right on phones. This is probably their last shot at mobile.
    Sorry if this sound hard dude!
    But remember this a Beta Software.
    If you don't like it just yet because of the Issues it has then get back to 8.1.
    I said that the first tine I installed 10 on my Icon! I said I didn't care about! My phone does faces some issues but I can live with that!
    I'm just saying: Be patient! And wait some more! This is a Beta OS! Remember what they say ..... Not in your main phone! Well maybe you and I didn't care that! But then be patient and reasonable!
    My keyboard is slow! The store crashes and some many other issues! What I do! Give feedback once a week!
    I'm patient!
    Just be calm dude! If you can not live with thta! Go back to 8.1 and wait a bit longer!
    07-22-2015 11:08 PM
  12. Firipu's Avatar
    Don't have many problems on my 1520 with w10. Except for the store (which is totally f`#%ed up) everything works quite well.
    Jazmac likes this.
    07-22-2015 11:52 PM

Similar Threads

  1. Replies: 6
    Last Post: 08-04-2015, 06:18 AM
  2. Replies: 3
    Last Post: 07-21-2015, 12:42 PM
  3. Why is my volume buttons either not working or working on its own?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 07-20-2015, 10:52 PM
  4. Replies: 1
    Last Post: 07-20-2015, 03:46 PM
  5. Why isn't Office 365 working on my Lumia 640?
    By Rose640 in forum Microsoft Office
    Replies: 1
    Last Post: 07-20-2015, 02:58 PM
LINK TO POST COPIED TO CLIPBOARD