Tried to install skype beta and the store says that I must install win10...I have the latest build

Printable View