The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. ravikumar7740's Avatar
    Have someone installed the latest insider preview build 10536 on their Lumia 640? Any major device specific bugs which can be the show stopper for use in a daily driver? Is it as fast as 8.1 ? Please tell people as I plan to install this build in my 640.
    09-14-2015 09:03 PM
  2. realwarder's Avatar
    Performance looks good at first. But this is on a test phone so cannot comment on daily driver status.
    ravikumar7740 likes this.
    09-14-2015 09:56 PM
  3. manus31's Avatar
    Have been using build 10512 on 640 for the past few weeks and performamce has been great.Am installing build 10536 now which can only be better.Shall comment later
    ravikumar7740 likes this.
    09-14-2015 10:10 PM
  4. GoWP's Avatar
    Have been using build 10512 on 640 for the past few weeks and performamce has been great.Am installing build 10536 now which can only be better.Shall comment later
    Is it a little faster compared to 8.1, and how is the battery usage? Please, share your experience after you test the latest build :)
    09-15-2015 07:44 AM
  5. manus31's Avatar
    I Would say performance is getting better with each build.10536 isn't as smooth as 8.1 on my 640.Buts its getting closer and certainly doesn't lag.cant comment on battery life just yet,but last build was good,usually full 24 hrs.Mind you I turn off a lot of background apps and don't use glance.Its a nice build so far on my 640.No noticeable bugs,but messaging was missing when I first installed which caused me some problems.Overall I say it's worth the jump from 8.1
    09-15-2015 08:16 AM
  6. shan678's Avatar
    pretty good actually! but not as fluid as 8.1,
    no heating issues so far. the default messeging app is still there. Actually i updated to build 10536 from 8.1 , which ended up in blank loading start screen.then i hardreset it, then everything back to normal
    09-15-2015 09:56 AM
  7. Sedp23's Avatar
    My only problem with this build is the battery drains noticeable faster on this build. I'll give the battery a few more days before judgement hopefully it gets better but right now it's noticeable Drain. But I can deal with it until he next build honestly. I don't think I could go back to 8.1 after using 10 for so long
    09-16-2015 07:56 PM
  8. potter007's Avatar
    Am using Win10 TP for the first time on Lumia 640..did a hard reset before installing this build.... Update download is fast but to install it took about 2 hours.... Overall performance is good... Though there are some issues. Am using on it daily driver and no problems so far...
    09-16-2015 08:06 PM
  9. FancyFreddy's Avatar
    Any chance you can comment on how to add an account/calendar with caldav?

    I know icloud works, but, the icloud "hack" no longer works after the 8.1.1 update I got a while back.

    My company only has imap and caldav for mobile users. I cringe a the delay of using memotoo these days as a caldav relay for exchange
    09-17-2015 12:53 PM
  10. falcon304's Avatar
    I'm seeing loading screens EVERYWHERE. Like, even for basic core apps such as the dialer, people hub, and messaging. Anyone else?
    09-28-2015 01:52 PM
  11. SaltCityBoy's Avatar
    Most of things is working great. No problems with battery, last 2 days easily.
    09-28-2015 05:40 PM
  12. WinSammie's Avatar
    Updated to 10536 2 days ago, from 8.1.2. First tried without a hard reset, but to get rid of loading time after switching on did hard reset. No effect on loading time, still >10 minutes. But after that not many problems, some apps don't update in store, some apps have several seconds resume time, very well usable for daily driver!
    Update:
    There's no way to control glance, not even via sysapp pusher.
    Battery use not stable, sometimes it gets hot, OK after restart.
    Data sense does not count my cellular data use, only Wifi.
    The loading time after switch on has become much shorter now!
    Last edited by WinSammie; 10-06-2015 at 12:04 PM.
    10-04-2015 02:54 PM
  13. Ole Christensen's Avatar
    I have installed build 10536. First there where no problems - now there are a lot. FYI all pictures and apps are installed on my SD-Card. When I click on Pictures or the app Soundhound nothing happens. It just returns to home page. I moved Soundhound from SD Card to Telephone but still no improvement! I am disappointed about all this as the previous build did not have that kind of problems.
    10-06-2015 04:38 AM
  14. Ole Christensen's Avatar
    I have installed build 10536. First there where no problems - now there are a lot. FYI all pictures and apps are installed on my SD-Card. When I click on Pictures or the app Soundhound nothing happens. It just returns to home page. I moved Soundhound from SD Card to Telephone but still no improvement! I am disappointed about all this as the previous build did not have that kind of problems.
    I made a reset to factory twice and now I can see the photos. However now there is no SMS service! How can I get that back?
    10-15-2015 12:54 AM
  15. Ole Christensen's Avatar
    Now I made a hard reset through Windows Recovery Tool downgrade to 8.1. Then updated to build 10549 and after another restart everything seems to work fine.
    I made a reset to factory twice and now I can see the photos. However now there is no SMS service! How can I get that back?
    10-16-2015 12:35 AM
  16. Glad Bernard's Avatar
    Is T-Mobile Wi-Fi calling working on this build ?
    10-16-2015 10:05 AM

Similar Threads

  1. Dualing Cameras - HTC One M9 vs. Lumia Icon
    By gernerttl in forum Nokia Lumia Icon
    Replies: 6
    Last Post: 11-09-2015, 06:41 PM
  2. Lumia 1520.3 "The Unicorn"
    By James8561 in forum Marketplace Archive
    Replies: 9
    Last Post: 10-16-2015, 11:07 PM
  3. So How Is Build 10536?
    By bo_woods in forum Windows 10 Mobile Insider Preview
    Replies: 25
    Last Post: 09-15-2015, 04:38 AM
  4. How do you burn a CD or DVD in Windows 10?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 09-15-2015, 12:12 AM
  5. Yes, your phone should get Windows 10 mobile builds 10514 and 101536
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-14-2015, 06:20 PM
LINK TO POST COPIED TO CLIPBOARD