1. Sunstorming's Avatar
    Hello everyone,

    Last night I, for the first time, installed a preview of Windows 10 on my Lumia 1520. It's version 10536... and here's the good and the bad.

    GOOD:
    Since my phone has never had a TP on it, I was on Windows 8.1 Update. The files downloaded quickly and the phone rebooted. Enter the gears of destruction... they spun for at least 40 minutes. When the phone rebooted, there was a long minute or two minute black screen pause where it just sat there. Then it booted to the start screen, asked for my PIN and away we went. Yay!

    BAD:
    No start screen. A screen that said Loading... kept appearing and reappearing with a black background. Since this was an update, and Microsoft cannot figure out the voodoo involved in a working update as opposed to a complete "format and reinstall" (some things never change) ... I hit the hard reset, knowing that my 200+ games / apps / stupid downloaded crap I don't use would take eons to download (or at least hours).

    GOOD:
    Upon the reboot, I now had a fresh install which worked, and worked pretty well. As the phone desperately tried to update all of my stupid stuff (I restored from backup on initial boot, and always will, CAUSE THAT IS WHAT THEY ARE FOR), I wanted to check the progress.

    BAD:
    The "Store" (or as I call it, 2nd level of Dante's Inferno) refused to show what it was downloading, however given that I only have 4 cores running at 2200MHz, I understood it not being able to update (sarcasm detector on I hope to those who are reading) a simple list. So I went off to explore the rest of the OS.

    The email is a joke. Seriously... I hate the friggin email client. It's not easy to use, the fonts suck, and I don't like a unified inbox or whatever its called to make it like the desktop.

    Edge does not allow Swype-like keyboard. Very very stupid move and I asked they fix it. Edge itself seems quick enough tho, and its fine.

    Since I have custom ringtones of songs that remind me of people calling (example: My boss calls or emails, and you get the song in Star Wars Revenge of the Sith where Vader is killing kids and basically everyone that looks at him) I figured I would try to set them up.

    All my ringtones were gone. No trace on the phone, no trace in OneDrive, no trace in the SDcard. This prompted me to have even more fun trying to find out where they went. They have survived from a Lumia 822 to a 929 (Icon) to a 1520 to a 640LTE to a 830 .. you get the idea. Nope, gone.

    Having sensed extreme annoyance, anger and sighing (shoulda known better, its a beta) I looked around more on the Webscreen modem page about ringtones and windows 10. Windows 10 doesn't (yet) have custom ringtones. GAH!!!

    GOOD:
    Lumia Recovery tool back to 8.1. Only took a few minutes, and then this morning I set up the phone like it was last night. And my ringtones are back. This is a good mystery for CSI or Columbo or ScoobyDoo ... if you can get ahold of any of those people let me know so I may hire them.

    Verdict: Windows 10 works better than the last version I tested. Just not better than Win 8.1 and it has some definite show stoppers still there. I will probably lay off trying to test any more beta OS on this phone. release will be in a few months and that's fine with me.

    P.S. The OS asks for a lot of feedback. I told them in all of it to GET RID OF THOSE STUPID F'N CIRCLES in the People hub. It looks terrible and wastes tons of space to boot. Also fire the guy or girl or alien that thought of it, and their boss for approving it.
    theefman likes this.
    09-15-2015 08:53 AM
  2. michail71's Avatar
    They put all the work into those stupid circles and ripped out everything in the people app in the process. If they put back what was taken out I wouldn't mind so much seeing those circles dance around. But they mock me with their dancing.
    09-15-2015 09:09 AM
  3. Teo Bartulovic's Avatar
    All my ringtones were gone. No trace on the phone, no trace in OneDrive, no trace in the SDcard. This prompted me to have even more fun trying to find out where they went. They have survived from a Lumia 822 to a 929 (Icon) to a 1520 to a 640LTE to a 830 .. you get the idea. Nope, gone.
    It worked just fine on previous build...

    P.S. The OS asks for a lot of feedback. I told them in all of it to GET RID OF THOSE STUPID F'N CIRCLES in the People hub. It looks terrible and wastes tons of space to boot. Also fire the guy or girl or alien that thought of it, and their boss for approving it.
    Hahaha, you are not alone believe me :D
    09-15-2015 10:18 AM
  4. michail71's Avatar
    I'm not sure if google or apple were the first to use round circles. My first experience was with google circles so that's what I think every time I see it.

    I was researching contact apps on android and it seems like many of the popular 3rd party alternatives seem to stick to the square.
    09-15-2015 01:09 PM

Similar Threads

  1. Lumia 640xl - 4g access in India
    By Mahesh MK in forum Microsoft Lumia 640 XL
    Replies: 6
    Last Post: 11-29-2015, 03:23 AM
  2. Getting error 0x800705b4 while trying to install build 10536 on L520! What should I do?
    By Pallav Chakraborty in forum Windows 10 Mobile Insider Preview
    Replies: 47
    Last Post: 10-05-2015, 10:27 PM
  3. lumia 925 stuck at bulid 10166
    By Francisc Cristian in forum Windows 10 Mobile Insider Preview
    Replies: 16
    Last Post: 09-17-2015, 02:15 AM
  4. Build 10536 No text message app
    By Kirstein Gourlay in forum Windows 10 Mobile Insider Preview
    Replies: 1
    Last Post: 09-15-2015, 08:19 AM
  5. Update on power down?
    By WPenvy in forum Windows 10 Mobile Insider Preview
    Replies: 0
    Last Post: 09-15-2015, 07:58 AM
LINK TO POST COPIED TO CLIPBOARD