1. jdballard's Avatar
    Anyone had success adding an Office 365 account in build 10536? I know it's been an issue in prior builds and it still looks to be an issue based on what I see. Just wondering if others have had any luck, and if so, how?
    09-15-2015 12:26 PM
  2. wizbit's Avatar
    Do you use the Mobile Device Managment (MDM) part of Office 365?
    09-15-2015 03:57 PM
  3. jdballard's Avatar
    Do you use the Mobile Device Managment (MDM) part of Office 365?
    Not 100% sure. I'll check with our IT admin. I don't have access to the admin part of our O365. Is there something that needs to be enabled?
    09-15-2015 04:06 PM
  4. wizbit's Avatar
    Does it ask you to enroll the phone? If not, where is it stumbling?
    09-15-2015 04:25 PM
  5. jdballard's Avatar
    Does it ask you to enroll the phone? If not, where is it stumbling?
    If I go to All Settings-->Accounts-->Work Access and select "connect" and enter my email address it searches. I get prompted with "Make sure you have a celluar data or Wi-Fi connection then try again..." (I am connected via Wi-Fi.) For the server I enter "outlook.office365.com" (also tried "office365.com" as well) and I get the same message - it never seems to find it.

    Alternatively, I've also tried All Settings-->Accounts-->Add a work or school account and enter my email address. After I enter my email address and leave the email address field, I get a message "Taking you to the sign in page for your organization" (our ADFS page). I then get an error "An error occurred. Contact your administrator for more information." Error details include an activity ID guid (all zeroes), the relying party (Microsoft Office 365 Identity Platform), the time, and user agent string.

    I actually am not sure which method I should be using, but neither one works.

    Not sure if the above info will help you out, but I appreciate you taking the time to try and help me out.
    09-15-2015 04:59 PM
  6. wizbit's Avatar
    This is what I know. The enrollment process doesn't seem to work in any build so far. When I say it doesn't work, it goes through the process of adding the phone (and I can see it on the admin page and shows compliant) but none of the Office apps (Outlook, Word, Excel, OneDrive) will see it as being enrolled. I even get to a point that it asks me to enroll and to find an app in the store to do it. But it's supposed to be built in!

    How I got it to work is that I added my account to the exceptions group on the Office 365 admin page, so enrollment was not required. Then I went to All Setting, Accounts, Your Account, Other accounts you use, Workplace or school account. Add your details there. Then, when you add your email account to Outlook, the details should already be there. You just have to select it.

    Let me know how you get on.
    Mikel Elorza likes this.
    09-15-2015 06:17 PM
  7. jdballard's Avatar
    Let me know how you get on.
    Will do! I've asked our O365 admin about it. I imagine I'll hear back about it shortly and I'll let you know.
    09-15-2015 07:11 PM
  8. Mikel Elorza's Avatar
    It works! I had the same issue on build 10549, i was completly locked in the enrollment process (the device looking up on the market for something that is supposedly built in) THANKS!
    10-15-2015 09:37 AM
  9. wizbit's Avatar
    Just to let you know that build 10572 improves on enrolling devices onto Office 365, but the apps still don't recognise that the phone is enrolled and still tries to download something. So it's still broken.
    10-22-2015 03:31 PM
  10. jdballard's Avatar
    I double checked and we do not have device enrollment, so I couldn't add an exception. I got my account added via dumb luck. Here's what I did.


    • I tapped Settings-->Accounts-->Your Email and Accounts-->Add an Account
    • I selected Exchange, Office 365 which brings up this screen:
      wp_ss_20151022_0007.png
    • I entered my company email address and hit next and got the message "We are looking for your account settings" for a few seconds then it brought up the following screens. The first one only flashed briefly before redirecting to the second screen - not enough time to enter a password:

      wp_ss_20151022_0004.png wp_ss_20151022_0011.png wp_ss_20151015_0001.png
    • Here's where the dumb luck came in. On the "Let's get you signed in" screen shot above (the screen that flashed momentarily before showing the "taking you to the sign-in page for your organization"), see where it has the empty password box and the "I forgot my password" link? I apparently accidentally tapped that link. That then redirected me to a page that says "Let's reset your password" (not shown).
    • From there (the "Let's reset your password page"), I hit cancel. That took me back the screen with my email address and password where I could actually enter my password. I entered it and my account was added!


    So, the key was to hit the "I forgot my password" link (which I did by accident) on the screen that pops up briefly so it will take you to the reset page where you can hit cancel and finally get back to the page where you can enter your password. Just to test that's what I did, after my account was successfully added the first time, I removed the account and tried it again. It took me about 10 tries before I was able to hit the "I forgot my password" link and have it take me to the reset page, but I finally did an it added it again.

    A bit convoluted, but hopefully the screen shots and description will help someone else.
    10-22-2015 04:09 PM

Similar Threads

  1. Still no Mobile Hotspot on Build 10536, how can I get it working?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-02-2015, 09:48 PM
  2. Music on lumia 520
    By harshdeep gupta in forum Windows Phone 8.1
    Replies: 8
    Last Post: 09-20-2015, 12:41 PM
  3. Where is the messaging app in the updated Windows 10 mobile build 10536.?
    By charish putta in forum Windows 10 Mobile Insider Preview
    Replies: 10
    Last Post: 09-15-2015, 05:41 PM
  4. after updating to 10536 nd tresetting, messaging app is missing.
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 09-15-2015, 02:52 PM
  5. Out This Week on Xbox One: Forza Motorsport 6, Destiny: The Taken King, and more!
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-15-2015, 12:11 PM
LINK TO POST COPIED TO CLIPBOARD