1. rider2040's Avatar
    Up until today, I thought that WP10 was heading in the right direction. I had been using the tech preview on my 640 as my daily driver. Then I installed the newest build, 10536, did a hard reset of my phone and I have regretted it ever since. Is anyone else seeing 10536 as a huge step BACKWARDS in terms of stability and speed?
    09-19-2015 12:37 AM
  2. moonshine63's Avatar
    Don't worry my 920 was terrible for the first few days then after that it came good not perfect but it started working nearly properly and the battery life in creased by about 500%
    09-19-2015 12:47 AM
  3. rider2040's Avatar
    I hope you're right. I am so close to doing another hard reset because the current situation just isn't acceptable.
    09-19-2015 01:04 AM
  4. moonshine63's Avatar
    Yes mine still sometimes still has the resuming bug and it lags a little with some apps but is now very usable.
    09-19-2015 01:16 AM
  5. moonshine63's Avatar
    I don't know weather it was coincidence or not but when they fixed the language and a peach bug when I finally had all of them set correctly and restarted the the phone numerous times because that's what you have to do it started working properly
    09-19-2015 01:18 AM
  6. anon(9226130)'s Avatar
    It's ok on my Lumia 520.
    09-19-2015 01:21 AM
  7. rider2040's Avatar
    So I did another hard reset and things have improved. I still have some weird start screen animations and the WC app is still almist unusable.

    My biggest annoyance however is a new bug where the onscreen navigation buttons are now displayed on top of my lock screen.
    09-19-2015 11:27 AM
  8. tut1234's Avatar
    You might want to go into the store and look for any updates. My phone was slow and there were 17 updates waiting and trying to download in the background. I always do a soft reset after downloading a lot of apps. Just a thought. My 520 was OK, but is acting funny today.

    Posted via the Windows Central App for Android
    09-19-2015 12:45 PM

Similar Threads

  1. Lumia 920 - Download MMS with data turned off
    By Auggybendoggy in forum Nokia Lumia 920
    Replies: 2
    Last Post: 09-19-2015, 07:32 PM
  2. Outlook mail app is not working in my Lumia 520(win 10 mobile build 10537)
    By Anantha RamaKrishnan in forum Windows 10 Mobile Insider Preview
    Replies: 1
    Last Post: 09-18-2015, 11:34 PM
  3. Microsoft Photos app for Windows 10 and Mobile grabs Album creation option!
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-18-2015, 10:42 PM
  4. How do I change the brightness on my Surface Pro 3?
    By Windows Central Question in forum Microsoft Surface Pro 3
    Replies: 0
    Last Post: 09-18-2015, 10:27 PM
  5. Lumia 1520, I Cant' upgreade window 8 to 8.1.
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 09-18-2015, 09:07 PM
LINK TO POST COPIED TO CLIPBOARD