1. tabraoui's Avatar
    I have a Lumia 820 and I installed almost all the previous builds but had to roll back to 8.1
    It was always a major reason (not just a delay or a couple of apps that don't work). The phone was unusable.
    Even with the last build (10512), my phone worked for 3-4 days then, it started to hang continuously.

    Anyway... I installed 10536 the moment it was out (3 weeks ago) and I have to say, it's still working smoothly.
    There are a few things, of course... but nothing major.

    I can't predict if it'll work for you or not... But for me (someone who was having a hard time with windows 10) it did.

    Hope it helps.
    gpobernardo likes this.
    09-28-2015 02:17 AM
  2. Paul1266's Avatar
    Its been the most stable for me by a long way but I'm still not using it on my daily driver. Too many slow transitions being the main reason. Most things seem to work well...just without that 'snappiness'. It has been fascinating observing the progress.
    tabraoui likes this.
    09-28-2015 03:13 AM

Similar Threads

  1. Replies: 1
    Last Post: 01-22-2016, 04:48 PM
  2. What do you think about surface branded phone
    By heickelrrx in forum Upcoming & Rumored Phones
    Replies: 3
    Last Post: 10-06-2015, 08:11 AM
  3. Would YOU pay to get developers?? (fantasy)
    By mayconvert in forum The "Off Topic" Lounge
    Replies: 4
    Last Post: 09-28-2015, 01:10 AM
  4. How do I install Quicktime for Windows 10?
    By Windows Central Question in forum Applications
    Replies: 2
    Last Post: 09-28-2015, 12:39 AM
  5. Does build 10536 runs smoothly on lumia 525 ?
    By Zerald in forum Ask a Question
    Replies: 0
    Last Post: 09-27-2015, 08:38 PM
LINK TO POST COPIED TO CLIPBOARD