The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
12-26-2015 10:37 PM
974 ... 3334353637 ...
tools
  1. Paul Blake's Avatar
    Definitely the best build so far. My Lumia 1020's battery life seems almost as good as when on 8.1, and the apps and performance seem much more polished.
    Couple of issues bugging this release for me - Mail/Calendar/Messaging apps incorrectly reporting unread messages occasionally, or just not refreshing.
    When listening to FM Radio and a call comes through, the audio stays on radio even after answering the call. Can't hear the caller.

    Getting there finally Microsoft ! (better late than never)
    10-26-2015 01:42 PM
  2. jkelek's Avatar
    On my ICON, I noticed that Lumia Camera doesn't record video...at all...even after another reset. It just beeps like it is but never records.
    video records fine with Microsoft camera on my Icon. unless you mistyped as far as I know lumia camera will install from the store but when you launch it you get a message to quit the program and it won't let you launch it stating it has been retired and to use Microsoft camera (which is preloaded with win10mobile). the only problem I notice for sure with the camera is the sharpness/resolution is much worse with 10 than it was with 8.1. not sure what the reason is though but would love to find out.
    10-26-2015 01:44 PM
  3. JORDAN YACINE's Avatar
    really maybe is the bad build ever, i have a lot of bug in my lumia 820, i roll back to 8.1 for the moment.
    10-26-2015 02:51 PM
  4. Roger Deep's Avatar
    Same issues with me too.

    Anyway, the best so far for sure. It still cannot import contacts and history on my Honda Connect, but any Android device will work properly.
    Battery usage is greatly improved, having sometimes an horizontal line, which if amazing.
    I still have and issue with ringer. Most of the time won't increase volume and it show's the volume on 2, for example. Then I realize it's on zero and I have to set it again and many times I cannot put sound on the ringer. But if is on mute, it will show the mute sign.
    Gone are the settings menu always failing and apps that would not install.
    Can't wait for this next one and keep on reporting those nasty bugs.
    10-26-2015 02:56 PM
  5. Roger Deep's Avatar
    Oh the most important app I have on my Lumia 830 is Lumia Camera. I mean, I had. Because it is no longer available and was replaced by Camera.

    Camera had improved a lot in picture speed and I've been using it with patience. Not yet like Lumia Camera but it's much better than the Camera on previous builds.

    I hope to see Camera improvements in speed and quality of picture in this next one.
    10-26-2015 03:00 PM
  6. Michael Dontigney's Avatar
    Turned off all background apps... still getting hot and draining the battery of my 1520 so... back to 8.1 but this version will be missed for it's speed... It shows so much promise for the final build... it's almost there!
    10-26-2015 03:35 PM
  7. chasvs's Avatar
    Loving this build but looking forward the the one due out this week! Get a bit of a pause before unlock once in awhile but over all I'm really pleased with this latest iteration!
    10-26-2015 03:42 PM
  8. Dueydoodah's Avatar
    It's running well on my 920. The battery runs cool and much longer than at any time since I left 8.1, although it does get wonky with certain apps. It still does not run all day without a charge. It's snappy most of the time, running so much better than the last build. Can't get camera to open by holding down camera button - it requires I use the app to get there. Still get some loading and resuming messages but it could be just because of the age of my phone. I get them mostly when I have 5 or more screens open. Still get some apps that won't show icon on tile. I use it as my driver and it worked well during a week-long trip. Only sweated the battery life once.
    10-26-2015 04:51 PM
  9. Jay Fettig's Avatar
    Just finished my Icon's post-upgrade hard reset. I'm gonna go with my backup from this afternoon, haven't needed to start from scratch yet (knock wood). It seemed a little zippier before the hard reset, but we'll see...

    ETA: Touch Screen was non-responsive, requiring two hard resets to get past the language selection screen....
    Question for you .. I have the Icon and on all of the Mobile 10 builds my Hey Cortana feature says something like your device does not support this feature .. When I switch back to 8.1 it comes back .. Any ideas???
    10-26-2015 05:21 PM
  10. Jay Fettig's Avatar
    I've installed 10572 on my Icon 929 .. As with all other Mobile 10 builds, my Hey Cortana doesn't work. .. Says that my device doesn't support that feature .. When I restore 8.1 it works just fine .. Any work around feature??
    10-26-2015 05:27 PM
  11. Ben Schmidt1's Avatar
    I've installed 10572 on my Icon 929 .. As with all other Mobile 10 builds, my Hey Cortana doesn't work. .. Says that my device doesn't support that feature .. When I restore 8.1 it works just fine .. Any work around feature??
    Not until the next update.
    10-26-2015 05:33 PM
  12. peachy001's Avatar
    Just ditched it and rolled back to 8.1. My 920 got on relatively well with it, but wouldn't email properly. Camera was terrible. I don't like the phone/dialer. Had some issues with messages too, said I was using the wrong number. Edge was poor, and it required regular resets. But the battery was similar to 8.1. It has come on immensely in the last month.
    10-26-2015 05:44 PM
  13. Jay Fettig's Avatar
    Do you mean 10575 should have it?
    10-26-2015 06:44 PM
  14. FHilario's Avatar
    - I still have the 'Loading...' issue after start / reboot my Lumia 830 (it takes several minutes do finally show the start screen. I thought it was related to my Start screen full of tiles and groups, but I cleared screen, put some tiles back, and same. I also have some minor issue when rolling to more than 1 page start screen (the tiles and groups don't update immediately. I think it is related to the tiles rendering and/or transparency.

    - Store is just a bit faster now, but I'm having some delay about apps ... when I uninstall some app, and go to Store, it is still registered as 'installed' ... only a restart fixes that.

    - I noticed some apps don't get backup automatically restored (alarm, message, onenote, and others).

    - I still can't get Edge links with thumbnails to pin at start screen (only Egde icon appears for all), and Office doesn't allow pin individual files at start screen anymore (only the launchers). But i am get used to that, as the apps were 'redesigned'. Speaking on app redesign, I also can't choose only one email account to be notified on lock screen. It considers all Outlook accounts there.

    On this new build, Im giving more feedbacks than previous one. But in general, I feel glad with the evolution (and, btw, I use it on my daily-work-use phone)

    BR
    10-26-2015 08:24 PM
  15. rav4kar's Avatar
    It's better than you past builds and it's runing good on my NL521 and my NL1020 is waiting for Build#10575.
    10-26-2015 08:32 PM
  16. vijay shekar's Avatar
    am unable to use facebook it is not opening
    unable to download whatsapp in my L720
    10-26-2015 11:38 PM
  17. mjyumping's Avatar
    Gabe has a newer build than 10575 coming
    Chintan Gohel likes this.
    10-27-2015 12:04 AM
  18. Ranjith_M's Avatar
    hi all,
    the new build 10572 is working fine for me, but my sd card is not detecting by phone after 2 days of upgrading... is there any one having this issue? how to resolve this one?
    10-27-2015 12:16 AM
  19. TECH O FUNs's Avatar
    i am using it on my lumia 430 and its running super smooth and perfect for regular use. Its the best build till date.
    10-27-2015 01:13 AM
  20. nareshkumarcool's Avatar
    My reply will seems to be funny but I fell it looks buggy but catching up speed with updates.but still I rolled back to windows phone.and 10572 built removed force 3g only option under sim setting which I very required bcoz in India u will see frequent changing between 2g and 3g .and wrost condition is when u downloading a movie.connection seems to pause while changing from 2g to 3g or vice versa.waiting for the 10575 built
    10-27-2015 01:13 AM
  21. mnsiw's Avatar
    Gabe has a newer build than 10575 coming
    Yeah, but he's sleeping, so wait for him to wake-up and push the button :-D
    10-27-2015 01:29 AM
  22. Jatin Kapoor1's Avatar
    Not sure why whatsapp is making my phone to crash :(
    10-27-2015 01:37 AM
  23. Gegabyte's Avatar
    Nooooooooooooooooooooooooooooooooo.
    I wannnnnnnnt it , buut,buut my f*** computer can't install windows phone recovery tool!!!!!!!!!!!!!!!!!!!!!!
    Even tried virtual machine, but it isn't recognize my Lumia 535. Help me!!!!!!!!!!!!!!!!!!!!!!!
    Please.
    10-27-2015 02:05 AM
  24. shadow118's Avatar
    Having quite a few werid glitches.
    - Sometimes the screen would just go black, like if you turned it off, but then it comes back after a second, this happens at random, usually when I'm in some kind of app.
    - When listening to music it sometimes pauses the song like it's buffering, again happens at random, if it does, it's at the beginning of the song and a few times (thats local music, never had this happen in previous builds or in wp8.1, so I doubt it's the SD cards fault)
    - When I type 'B' in search, it just crashes, tried other letters, seemed to be fine, if i pressed b and some other letter quickly, also seemed to be ok, but if I then deleted that other letter, then it crashed.
    - In edge sometimes when writingi in the address bar, the text is white, so you can't see what you're typing
    - In settings, can't open settings for motion data or glance (I think I could open glance before resetting the phone in the same build, but I'm not sure)
    - Can't update Moiton data (or motion sense, IDK) in the store, always gives an error
    - In the quick toggles there is something missing after resetting. Before, there were 16 icons, now (after reseting, same build) there are 15
    - Some apps won't launch and just stay in the splash screen. Apps like 6tin, Twitter, Blue Skies, Lumia selfie, Lumia Creative studio. Tried reinstalling them to local storage, on 6tag started working, the rest still don't work. This was one of the main reasons why I reset the phone.

    On a bit more positive side, the Groove music plays my files (apart from the bug mentioned above, but that doesn't happen that often). In the previous build Groove would give an error on almost all of my songs
    And in general it does feel more snappy and the battery life seems ok

    EDIT: Forgot to mention, I have a Lumia 830
    Last edited by shadow118; 10-27-2015 at 03:43 AM.
    10-27-2015 02:28 AM
  25. Abhigyan Arora's Avatar
    Hilariously below decent. Phone's not getting hot or anything. But the drain is quick. The phone runs for 6-7 hours before it hits the battery saver mode (with decent usage. Couple of calls, email, messaging and lots of WhatsApp).
    10-27-2015 02:40 AM
974 ... 3334353637 ...

Similar Threads

  1. Replies: 9
    Last Post: 12-07-2015, 01:53 PM
  2. Here's what's been fixed and what's still broken in Windows 10 Mobile build 10572
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 10-23-2015, 02:15 PM
  3. How do I download apps?
    By Windows Central Question in forum Applications
    Replies: 1
    Last Post: 10-20-2015, 06:52 PM
  4. Current build stability
    By idokamaroq in forum Windows 10 Insider Preview
    Replies: 2
    Last Post: 10-20-2015, 06:39 PM
  5. Here's what's new and improved in Windows 10 Mobile build 10572
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-20-2015, 05:11 PM
LINK TO POST COPIED TO CLIPBOARD