1. roystreet's Avatar
    Hello,
    I just installed windows 10 mobile on my 1520 today. I put the latest available as a fast insider. It installed great! Apps were working, it found all of the apps I had on the SD card & didn't have to reinstall most of them. Later on, when I rebooted my phone, suddenly several apps stated they were located on my SD card & it needed to be reinserted or downloaded from the store. Now, remember, I was just using these apps before I restarted the phone... So, this is strange. So I removed the card and put it back in. Still no fix. I had all of my apps stored on the SD card. But some of my apps run just fine, yet it states there is no SD card when you look at storage. My photos, which are on the SD card show up in photos. So, it partly sees the card, but doesn't in other areas? I have one app, pocket explorer, which can see files on the SD card, so it's there.

    Any thoughts on this?
    10-24-2015 01:19 AM
  2. rhapdog's Avatar
    Everyone I know seems to have had this exact same problem. Mind you, I'm not saying everyone who installs the build gets the problem, just that it seems like everyone I know has had it. It's all part of "living on the edge" and helping Microsoft test their product before final launch.

    You'll find that with the apps on the SD card you will be unable to uninstall and reinstall. The problem comes in some sort of encryption error where Windows 10 seems to have lost the key to decode the encrypted apps folder. At least that's the best I reason I am able to come up with.

    There are a couple solutions for this issue that I am aware of. Pick the one that works best for you.

    1. Hard Reset the phone without a backup, then reinstall all your apps from scratch.
    2. Remove the card and use a PC to copy all your photos/music and other stuff off the card, format it, and copy the photos/music back again. Reinsert the card and it will work. You will then need to uninstall and reinstall all the offending apps. This was less time consuming for me than a hard reset, and was the option I chose.

    Note that I have not personally tried the Hard Reset and I will not guarantee that it works. Others I have spoken to say this is what they did and it worked for them just fine.

    Best of luck.
    10-24-2015 06:13 AM
  3. nicoleta manuela's Avatar
    Hello, i seem to have the same problem here. I did the second option but nothing...
    Now is there anything else i can do? I don't really want to hard reset the phone :)
    10-27-2015 03:33 PM
  4. Maurizio Troso's Avatar
    Hello, i seem to have the same problem here. I did the second option but nothing...
    Now is there anything else i can do? I don't really want to hard reset the phone :)
    I had for days the same iussue but everything seemed going ok, but after a looooong hard reset and about 48 hours of using and stabilizing , everything has gone in the right place. Standing by build 75....
    10-27-2015 03:49 PM
  5. nicoleta manuela's Avatar
    I had for days the same iussue but everything seemed going ok, but after a looooong hard reset and about 48 hours of using and stabilizing , everything has gone in the right place. Standing by build 75....
    Sooo, i guess i don't have other option but reset my phone...well that's it, i can't ignore this anymore ...
    10-27-2015 05:43 PM
  6. midnightfrolic's Avatar
    I've reverted back to 8.1 and installed Win10 preview several times. Each time, I had to install all my apps again, even when I chose to restore from backup. My music on the SD card were fine. It was the apps and maps that had to be reinstalled. But luckily, it seems, the apps overwrote the old ones so it didn't take up twice the amount of storage on the SD card.
    10-27-2015 08:45 PM
  7. rhapdog's Avatar
    Two things that I will recommend on this particular build are as follows:

    1. Don't have any apps on the SD card when you upgrade. Move them all to phone storage for the upgrade, or temporarily uninstall them.
    2. Instead of doing #1, just wait for the next build, which should be later this week.
    midnightfrolic likes this.
    10-28-2015 09:00 AM
  8. nicoleta manuela's Avatar
    So i did reset my phone so now, everything is ok.. the sd card is there finally so i dont have any issues for now.
    I recommend to de the reset step though :)
    10-28-2015 01:35 PM

Similar Threads

  1. WTB: "a fast 4128GB card by a well-known manufacturer"
    By BarryII in forum Marketplace Archive
    Replies: 12
    Last Post: 10-25-2015, 10:22 AM
  2. Updating to next mobile build 10575 or higher
    By jisto1215 in forum Windows 10 Mobile Insider Preview
    Replies: 14
    Last Post: 10-24-2015, 11:32 PM
  3. What Game Apps Do You Want On Windows Phone?
    By JoyfullJuneBug in forum General Phone Discussion
    Replies: 1
    Last Post: 10-24-2015, 12:47 AM
  4. Replies: 0
    Last Post: 10-24-2015, 12:06 AM
  5. Why won't my Nokia Lumia 635 phone stay on and update?
    By Windows Central Question in forum Nokia Lumia 635
    Replies: 0
    Last Post: 10-23-2015, 11:04 PM
LINK TO POST COPIED TO CLIPBOARD