1. mkenyon2's Avatar
    I have set up Remote Desktop on my phone before, and I know it can connect to my Windows 10 PC. My tablet can. I checked my settings. It can talk to my PC, (I always get a 'can't trust certificate' message), but it will not accept my password.

    On both my tablet and my phone I am using my Live account. I can connect on my tablet, but not the phone.

    I am using a local/internal IP address (192.168.0.xxx) on both. However, I have also set up my home network to allow an external connection. Both connections work from my tablet, neither from my phone.
    11-01-2015 08:26 AM
  2. Demian Mioc's Avatar
    It won't connect if you are using mobile internet, only connects on Home network using Wi-Fi. It connects just fine on 8.1 phone, but on 10 mobile TP only trough Wi-Fi connection same as Pc and other devices. I'd recommend Team viewer as alternative, but it's not available in Windows 10 Store, it'll come after official release.
    11-01-2015 09:37 AM
  3. mkenyon2's Avatar
    It won't connect if you are using mobile internet, only connects on Home network using Wi-Fi. It connects just fine on 8.1 phone, but on 10 mobile TP only trough Wi-Fi connection same as Pc and other devices. I'd recommend Team viewer as alternative, but it's not available in Windows 10 Store, it'll come after official release.
    Yes, I'm on my home WiFi, but can't connect.
    What do you mean by TP in 'but on 10 mobile TP only trough Wi-Fi connection same as Pc'?
    11-01-2015 10:06 AM
  4. Demian Mioc's Avatar
    TP = technical preview, in Windows 10 mobile Technical Preview.
    If you are on home Wi-Fi, go to Phone, Remote Desktop app, click add, select Desktop, under Pc name type your Pc name found in This Pc, properties, or type ipv4 address followed by a backslash and the user name you want to use. In credentials add your email address and password which logs you in your Pc, check if email and password are correct, otherwise they give error and you cannot connect :D. No need to go to advanced settings, leave them as default.
    If that doesn't work, go to Control Panel, Network and Sharing Center, Advanced sharing settings. There are 3 categories: Private, Guest or Public and All Networks. Check your settings there, allow connection for your Connection profile. Turn everything there on, and see if that works for your phone Remote Desktop.
    If your other devices work, hmm go to firewall connections and see there Remote Desktop, allow all connections for that, but be careful in case it still won't work to disable them again.
    mkenyon2 likes this.
    11-01-2015 01:22 PM

Similar Threads

  1. Living images. What on earth is this
    By ebk333 in forum Applications
    Replies: 19
    Last Post: 11-03-2015, 03:30 PM
  2. How can I delete Chrome on Windows 10?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-01-2015, 11:07 AM
  3. SD card seen cant save pics to sd WIN10 lumina 640
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 11-01-2015, 08:17 AM
  4. Read Only Message on deleted contact's text?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 11-01-2015, 04:05 AM
  5. my famile satup
    By 1 sk in forum Windows Phone 8.1
    Replies: 1
    Last Post: 11-01-2015, 03:59 AM
LINK TO POST COPIED TO CLIPBOARD