1. Generalheed's Avatar
    I just installed Windows 10 Mobile 10581 on my brand new Lumia Icon. Everything works great except that when I try opening Edge, the splash image appears then it crashes before the browser even opens. I've tried restarting my phone a couple times but I still can't get the browser to open. I've had to rely on 3rd party browsers in the meantime. Has anyone else had this issue or know of a solution to getting it to work?
    11-08-2015 03:17 PM
  2. ttsoldier's Avatar
    Hard reset.
    11-08-2015 06:24 PM
  3. Generalheed's Avatar
    Hard reset.
    What do you mean by hard reset? If you mean holding the power and volume down buttons to restart the phone, I've tried that too. But Edge and now the Maps app won't start up still. Everything else is fine.
    11-08-2015 07:51 PM
  4. midnightfrolic's Avatar
    try the DISM fix and run the "sfc /scannow" command line in admin CMD prompt. Or reinstall Edge.
    DISM
    DISM - Repair Windows 10 Image - Windows 10 Forums


    SFC
    https://support.microsoft.com/en-us/kb/929833

    Reinstall Edge
    http://forums.windowscentral.com/ask...e-browser.html
    11-08-2015 09:08 PM
  5. Generalheed's Avatar
    try the DISM fix and run the "sfc /scannow" command line in admin CMD prompt. Or reinstall Edge.
    DISM
    DISM - Repair Windows 10 Image - Windows 10 Forums


    SFC
    https://support.microsoft.com/en-us/kb/929833

    Reinstall Edge
    http://forums.windowscentral.com/ask...e-browser.html
    Those links are for the desktop version of Windows 10. I'm talking about Windows 10 Mobile on my Nokia Lumia Icon. I am unable to access the command prompt or uninstall edge on my phone.
    11-08-2015 09:34 PM
  6. ttsoldier's Avatar
    What do you mean by hard reset? If you mean holding the power and volume down buttons to restart the phone, I've tried that too. But Edge and now the Maps app won't start up still. Everything else is fine.
    No I mean going into Settings. About. Reset Phone.

    Make sure your data is backed up, You will lose what is on the phone.
    11-09-2015 02:13 AM
  7. illegaloperation's Avatar
    Same problem here with Edge on my Lumia 920.
    11-09-2015 08:30 AM
  8. illegaloperation's Avatar
    No I mean going into Settings. About. Reset Phone.

    Make sure your data is backed up, You will lose what is on the phone.
    How do you backup the phone?
    11-09-2015 08:32 AM
  9. Generalheed's Avatar
    No I mean going into Settings. About. Reset Phone.

    Make sure your data is backed up, You will lose what is on the phone.
    Is there really no other solution?
    11-09-2015 10:41 AM
  10. ttsoldier's Avatar
    Is there really no other solution?
    To my knowledge, no. This is the risk you take by joining the insider preview.

    May be someone may have another solution. However, it is unlikely.

    Best of luck to you
    11-09-2015 09:08 PM
  11. Maurizio Troso's Avatar
    Hard reset is the only way
    11-10-2015 02:39 AM

Similar Threads

  1. Band 2 Dead after 7 days! Won't Turn on! How can I fix it?
    By senrabwh in forum Microsoft Band & Band 2
    Replies: 8
    Last Post: 11-18-2015, 12:53 PM
  2. Why does McAfee Web Advisor not work in Windows Edge?
    By Windows Central Question in forum Edge
    Replies: 2
    Last Post: 11-14-2015, 10:32 AM
  3. Why does my start menu not open?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-08-2015, 04:19 PM
  4. Why Won't My Windows Store Start App Downloads?
    By jayk82 in forum Microsoft Surface Pro 4
    Replies: 3
    Last Post: 11-08-2015, 11:57 AM
  5. Edge efficiency
    By Dush Ku in forum Edge
    Replies: 1
    Last Post: 11-06-2015, 01:59 PM
LINK TO POST COPIED TO CLIPBOARD