1. manus31's Avatar
    I upgraded from 10581 last night and so far performance has been great.The upgrade process kept all my apps and even login details for them.

    I usually do a hard reset on each build,but didn't on 10581 to keep my storage settings.

    Im thinking on doing a hard reset tonight but am worried because on a recent build I did one and lost stuff like glance.

    Do we really need a hard reset ?

    I Know many will say yes based on old information,but my experiences seem to suggest that as long as you start on 8.1 and upgrade from there,you tend to hold on to all your settings like glance etc, and performance is perfectly good
    11-19-2015 07:27 AM
  2. anguilla1980's Avatar
    I'd say yes. Just do a full back up to restore after. Very painless.

    I went from 8.1 to 10586 on my 640 dual sim, then made a backup, then hard reset. That way my backup would be fully W10 compatible.
    11-19-2015 08:09 AM
  3. manus31's Avatar
    I'd say yes. Just do a full back up to restore after. Very painless.

    I went from 8.1 to 10586 on my 640 dual sim, then made a backup, then hard reset. That way my backup would be fully W10 compatible.
    Did you notice any difference in performance after your clean install or did you lose anything like glance,or touch ?
    11-19-2015 09:44 AM
  4. anguilla1980's Avatar
    Did you notice any difference in performance after your clean install or did you lose anything like glance,or touch ?
    I noticed the icons in the start menu for Groove Music and MSN Weather aren't blank now and are working again. Speed feels the same. Glance and touch are there but updates for them are failing.

    I'm sure a hard reset fixes many things we don't easily notice. I've been using WP for 13 years now and ALWAYS do a hard reset after an OS/firmware update. It just has always gone without saying that you do it. Up to you tho.
    manus31 and gpobernardo like this.
    11-19-2015 09:47 AM
  5. MikeSo's Avatar
    I didn't do a hard reset on either 10581 or 10586. I don't now if that caused any problems, but if it did, it's not in the area of battery life, performance or stability. The 10586 upgrade was incredibly fast, I guess they didn't do that much between those builds.
    gpobernardo likes this.
    11-19-2015 10:13 AM
  6. beachedwhale42's Avatar
    I did a hard reset on 10586 because I did one on 10581, which caused the reboot loop bug. Performance is fine, seems like mostly minor improvements and bug fixes (except the Messaging + Skype battery drain issue).
    gpobernardo likes this.
    11-19-2015 10:16 AM
  7. Maurizio Troso's Avatar
    first hours of testing, 86 is quite worse than smooth 81 on my 520, even with and hard reset.
    Random apps close on startup, or crash the phone never happened before (except the well know Messages app bug)
    Slower than previous build,
    11-19-2015 10:53 AM
  8. mkenyon2's Avatar
    I had to revert to 8.0 to get 10581, but didn't have to do anything other than update to get to 10586. (I remember my first 586 processor, wow was that fast!)

    I haven't had many problems. That being said, I did notice one app was in a state of 'Pending' last night. This AM it's working. I'm also having issues with Pandora, but that app was updated with a bunch of changes, so not sure it's the build or Pandora.

    One app I have that plays podcasts from a specific site was not giving me audio, but after rebooting the phone, its working again.

    So far, no hard reset (or soft reset) and doing good.

    Lumia 920 (AT&T branded)
    11-19-2015 11:01 AM
  9. gpobernardo's Avatar
    I didn't perform a hard reset from 10581 to 10586 (neither did I from 8.1 to 10581). So far I'm not encountering any issues; in fact I'm noting a lot of performance improvements, as noted in the official "fixes" in this version. The "Loading" and "Resuming" lags are noticeably reduced now (haven't seen one since the installation). No more random restarts, too. As for battery live, that will take more time for a more concrete set of findings.
    11-19-2015 12:01 PM
  10. Allen Rhodes's Avatar
    I updated straight from 81 to 86. Now I have almost 2 dozen core apps/settings that error when trying to update. Prior to that I had 3. Was trying to fix the 3, created 7fold more. So if it's working, leave it be. IMO. Obviously this is still not public ready, but they are getting it regardless. YAY :/ Nothing like update issues to get more people to the OS, or to stay on it.
    11-20-2015 07:09 AM
  11. scolab's Avatar
    I updated my Icon from 8.1 to 10586 and everything seems to work perfectly. Had to update Word and Excel upon first opening, but seems that everything else updated on their own. So far, battery seems about the same as with 8.1.
    11-20-2015 07:24 AM

Similar Threads

  1. How can I fix a usb connection issue in build 10581 after factory reset?
    By Windows Central Question in forum Nokia Lumia 930
    Replies: 11
    Last Post: 12-21-2015, 07:15 PM
  2. Lumia 435 on 8.1 is faster than my 930 on 10586
    By Jag Mann in forum Windows 10 Mobile Insider Preview
    Replies: 9
    Last Post: 11-22-2015, 07:07 PM
  3. 10586.11 + nokia 1020 = brick (stuck at nokia logo)
    By markm75 in forum Windows 10 Mobile
    Replies: 6
    Last Post: 11-19-2015, 07:54 AM
  4. How do I reset start the menu tiles in Windows 10?
    By Windows Central Question in forum Windows 10
    Replies: 0
    Last Post: 11-19-2015, 06:59 AM
  5. After updating version 10586
    By Nilesh Jagnade in forum Windows 10
    Replies: 0
    Last Post: 11-19-2015, 06:13 AM
LINK TO POST COPIED TO CLIPBOARD