The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. lewiedude's Avatar
    I am Fast Ring and was running .71. All was good, really quite good, until tried to change a setting under Phone. Now the dang thing is completely bricked and my SP3 won't give me a positive "connection" when pluggin it is utilizing the Recovery Tool.

    Any thoughts? I am completely aghast that this happened! Please help. Oh, and the Volume Down+Power key press doesn't work either. UGH!
    02-02-2016 09:26 AM
  2. damonator98's Avatar
    Does phone even boot up ? Does it at least show nokia logo ?
    02-02-2016 09:33 AM
  3. lewiedude's Avatar
    Not one thing. Bricked as bricked can be.
    02-02-2016 09:36 AM
  4. damonator98's Avatar
    Dang it, my was only showing nokia logo and the powering off. I used NSU retail to fix it. Have you tried it ? There's no hope, but still, maybe miracle will happen. :D It doesn't even vibrate ? :OO
    02-02-2016 09:38 AM
  5. lewiedude's Avatar
    Nothing. What is NSU?
    02-02-2016 09:44 AM
  6. lewiedude's Avatar
    Also, now my Qi wireless charging plate is lighting up...it wasn't before. I really don't want to replace it as I am not terribly enthused about where W10M is going, marketwise.
    02-02-2016 09:51 AM
  7. damonator98's Avatar
    Nokia Software Updater for retail
    02-02-2016 09:52 AM
  8. damonator98's Avatar
    Me too. I've 920 also and I'm waiting to see what will happen :) Since your phone does "nothing" at all I suppose it's time to wave farewell... What I would do is try caharging, or removing battery for some time, but it's hopeless in your situation.
    02-02-2016 09:56 AM
  9. EspHack's Avatar
    lumias tend to die that way naturally, some times they just power on after some hours, some they just never live again, quite frustrating really, try using a really powerful charger, the battery meter could've been showing false numbers, last thing would be to open it and try to charge the battery directly
    02-02-2016 09:57 AM
  10. Jeff Erson's Avatar
    Any other 920 users having this problem? Mine's a 920, and using it as my daily driver. Does .71 bricks 920? Can others confirm this? I should just cancel my update then.
    02-02-2016 09:58 AM
  11. lewiedude's Avatar
    OK. Thanks. I will plug it in and keep it going for a while. I will have to pick up a L640 go phone as I want to limit my investment in W10M. I am really upset with MSFT and WM at this point. This has nothing to do with my current situation.
    02-02-2016 10:01 AM
  12. damonator98's Avatar
    It one hell of a bumpy ride with wp/wm. :D Good luck.
    02-02-2016 10:15 AM
  13. Maurizio Troso's Avatar
    Have you tried the key hard reset sequence???
    02-02-2016 10:43 AM
  14. lewiedude's Avatar
    I did not try the key hard reset sequence, but have done so in the past with all of these fast ring builds.

    But, I want to announce that I left it in the Qi charging plate because at least I was getting the little white light on the side of the plate confirming that the battery was charging. And, the phone sprang to life announcing 30% battery. It took 4 hours on the plate to get it there! So, the faulty battery thing mentioned above mist have been the problem. Or, it was because I picked up a 640 go phone from Best Buy and my 920 didn't like that! Oh well, I will give the new on to the Mrs. as her 925 has been acting up.

    Thanks for the advice on making sire I was at least charging it!
    02-02-2016 03:22 PM
  15. gwinegarden's Avatar
    Mine is cruising along quite nicely on .71
    02-02-2016 06:17 PM
  16. gwinegarden's Avatar
    I did not try the key hard reset sequence, but have done so in the past with all of these fast ring builds.

    But, I want to announce that I left it in the Qi charging plate because at least I was getting the little white light on the side of the plate confirming that the battery was charging. And, the phone sprang to life announcing 30% battery. It took 4 hours on the plate to get it there! So, the faulty battery thing mentioned above mist have been the problem. Or, it was because I picked up a 640 go phone from Best Buy and my 920 didn't like that! Oh well, I will give the new on to the Mrs. as her 925 has been acting up.

    Thanks for the advice on making sire I was at least charging it!
    After the update, it started eating my battery like crazy. I did 2 or 3 soft resets and powered it off for a while and it settled down. Perhaps you had a similar issue.
    02-02-2016 06:20 PM
  17. Maurizio Troso's Avatar
    After the update, it started eating my battery like crazy. I did 2 or 3 soft resets and powered it off for a while and it settled down. Perhaps you had a similar issue.
    It needs to update and sync all core apps, and all background apps are set to on again by default. Check it and let the phone stabilyze 2 days

    EDIT: I discovered Video Skype is always logged in and unable to set off in background apps, and drains a lot using Messages + Skype
    Log in app, settings, log out, confirm
    Last edited by Maurizio Troso; 02-03-2016 at 06:42 AM.
    02-03-2016 02:41 AM

Similar Threads

  1. How to manually sync Google calendar Windows Phone 10
    By WPCentral Question in forum Windows 10 Mobile
    Replies: 9
    Last Post: 08-28-2017, 09:37 PM
  2. Replies: 4
    Last Post: 02-22-2016, 12:48 AM
  3. Why Windows Phone isn't dead
    By paulm187 in forum Windows 10 Mobile
    Replies: 12
    Last Post: 02-09-2016, 04:27 AM
  4. Why there is NO CitiBank App for Windows Phone. ??
    By Rajesh MM in forum Windows Apps
    Replies: 3
    Last Post: 02-02-2016, 08:11 AM
  5. How to manage proxy setting?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 02-02-2016, 08:05 AM
LINK TO POST COPIED TO CLIPBOARD