1. SpideyCoco's Avatar
    I came across something really interesting when discussing security on different OSs with friends.

    I entered to the Devices page in my account via PC and it turns out my Lumia 735 won't show up at all. However, if I go to the same page on my phone, it shows up (with IMEI number and all) but when I wan't to go to the different options it shows that The page could not be found.

    Am I the only one running through this? If W10M doesn't have Find my phone working properly yet I think it could be a big issue.

    Cheers!

    EDIT: Nah, now it's not even showing when going to the Devices page on my phone
    02-02-2016 11:09 PM
  2. anon(5326758)'s Avatar
    Find my phone working for me, sees both W10M and Win 8.1 phones.
    02-03-2016 12:24 AM
  3. Maurizio Troso's Avatar
    It works perfectly, go in settings and check "Find more often"
    02-03-2016 02:38 AM

Similar Threads

  1. Replies: 3
    Last Post: 02-29-2016, 02:21 PM
  2. Why is my Nokia 1020 suddenly no able to access Yahoo mail using the built in icon?
    By Windows Central Question in forum Nokia Lumia 1020
    Replies: 1
    Last Post: 02-05-2016, 12:45 AM
  3. How can I open apps on my Surface Pro 3?
    By Windows Central Question in forum Microsoft Surface Pro 3
    Replies: 2
    Last Post: 02-04-2016, 08:28 PM
  4. How do I change my username in forum?
    By PLC1945 in forum Site Feedback & Help
    Replies: 1
    Last Post: 02-02-2016, 08:38 PM
LINK TO POST COPIED TO CLIPBOARD