05-26-2016 05:46 AM
32 12
tools
  1. Paisley Pirate's Avatar
    Looks like I'm not the only one - this thing (Lumia 640) is hot and eating up battery faster than my old Blackberry Z10 on 10.1.1... (EEK!)

    Looks like I need to back it up a step and sit tight until they get it cured.
    Gunbust3r likes this.
    05-23-2016 09:05 PM
  2. Maurizio Troso's Avatar
    Someone try to switch temporary Ring to Production and reboot, and check if something change. It should stop telemetry and testing code (I guess)

    I cannot test on my 650, I haven't any iussue till now
    05-24-2016 02:13 AM
  3. mikepalma's Avatar
    Someone try to switch temporary Ring to Production and reboot, and check if something change. It should stop telemetry and testing code (I guess)

    I cannot test on my 650, I haven't any iussue till now
    I tried Production on 950XL, stopping telemetry,NFC etc. Battery life still miserable 5 hours at best. MS doesn't care about us the now .7% of smartphone customers.
    05-24-2016 02:20 AM
  4. Maurizio Troso's Avatar
    I tried Production on 950XL, stopping telemetry,NFC etc. Battery life still miserable 5 hours at best. MS doesn't care about us the now .7% of smartphone customers.
    Sincerely, after decades of working on huge variety of desktops, I cannot explain such differences btwn same identical devices, despite apps ecc.
    A lot of 950 users are satisfied, there's another two with light sensor malfunction, someone with battery drain. BOH!

    PS: yesterday I tried the new Microsoft Healt without Band. It killed 50% battery in 2 hours!!!!
    05-24-2016 02:32 AM
  5. seldzar's Avatar
    I had some serious drain happen over the weekend. Sometimes it was "lockscreen" or "Start" or "MSHealth" reporting the most usage.

    I had turned off Cortana access from the lock screen and suddenly I still had over 50% after 18hrs of off charge time. The next day it went back to weird spikes. However, everytime I noticed the battery draining/heat build up, I just did a soft reset. This often resolved the issue but it doesn't mean that it resolved it permanmently as I did have to do that at least 3 times one day.

    When those rogue processes are not going off and eating the battery, I get phenominal life (1-2% p/hr). Like right now: almost 8hrs off charge and I'm still at 87%.

    I still have some minor issues with tiles not updating (MS Health) or store notifications (2 updates today with no notification) Skype stopped notifiying me until I did a soft reset at one point.

    Edit: 950XL Build 14342
    05-24-2016 01:42 PM
  6. Maurizio Troso's Avatar
    Out the 0004 minor build update, seems fixes the draining. Check it out!
    05-26-2016 02:02 AM
  7. sso-li's Avatar
    Have the same issue. While reinstalling all apps, using the screen, have the ms band connected and in addition just having connectivity with about bar (for both cellular and wifi), I had draining batteries, even I was attached the power. When I stopped using it and just let it install all things, battery took 2,5 hours to load 20% :-(
    It is most likely related to the cellular connection. Because during the last days i didn't enter the SIM Pin and at least it feels like the battery drains slower..
    just having a look if i already got the new patch to fix it.

    And I was so Happy the first 30 Minutes after the Update, as Cortana has it finally arrived to Switzerland, regardless that it uses the the Germany German and not ooffer content for my country...

    by the way, the screenshot of an earlier post, where infos about the phone are shown within the browser - how can i get this? or how is this "tool" called, so I can find it out by myself? thx.
    05-26-2016 05:46 AM
32 12

Similar Threads

  1. Cortana Killing My Battery
    By wizbit in forum Windows 10 Mobile Insider Preview
    Replies: 9
    Last Post: 05-22-2016, 04:12 PM
  2. Build 14342, why isn't it downloading on my Lumia 532?
    By fearful_claw02 in forum Windows 10 Mobile Insider Preview
    Replies: 4
    Last Post: 05-20-2016, 03:24 AM
  3. Why am I unable to rollback to 8.1 from Windows Mobile 10.0.14342.1001?
    By Windows Central Question in forum Windows 10 Mobile
    Replies: 2
    Last Post: 05-18-2016, 04:06 PM
  4. How to fix a stuck Windows logo during the Windows 10 Mobile build 14342 install
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-17-2016, 10:11 AM
LINK TO POST COPIED TO CLIPBOARD