1. slyronit's Avatar
    Well, the Windows Insider blog post which has the list of issues for build 14364 says

    "We are investigating data issues with some Dual-SIM devices where cellular data doesn’t work correctly with a second SIM."

    I assumed this meant data will not work when the phone is configured to use the second SIM for data, but actually, data doesn't work in any case as long as there are 2 SIMs in the phone. Even turning off one SIM doesn't fix the problem, one of the SIMs needs to be physically out of the phone.

    Has anyone found any workaround for this, other than removing one of the SIMs?

    Too bad, I had to roll back, as everything else about the build seemed top notch (I have skipped the last 5 Fast ring builds).

    The bad thing is, the same bug was present in the first few Redstone builds, too, though not documented.

    The good thing is, MS knows of it, hope they fix it soon.
    Last edited by slyronit; 06-16-2016 at 08:27 AM. Reason: Fixed some formartting
    06-16-2016 08:23 AM
  2. Dusan Randj's Avatar
    I have same problem on 640 XL Dual Sim. Sometimes data doesn't work, sometimes it does work. Soft and hard resets doesn't help. Sometimes after freezing I do soft reset and after powering on I do shut down and it works. Sometimes it shows that it needs to restart and update setting and after that it works. But mostly it doesn't... getting annoying, it didn't make problems for me until last two builds.
    06-16-2016 05:22 PM
  3. zei20t's Avatar
    im looking forward to updating to this once they solve this problem

    its probably the only reason i havent yet. but reports are looking good for all other functions and speed etc.
    06-16-2016 07:44 PM
  4. andyqkw's Avatar
    Well, the Windows Insider blog post which has the list of issues for build 14364 says

    "We are investigating data issues with some Dual-SIM devices where cellular data doesnt work correctly with a second SIM."

    I assumed this meant data will not work when the phone is configured to use the second SIM for data, but actually, data doesn't work in any case as long as there are 2 SIMs in the phone. Even turning off one SIM doesn't fix the problem, one of the SIMs needs to be physically out of the phone.

    Has anyone found any workaround for this, other than removing one of the SIMs?

    Too bad, I had to roll back, as everything else about the build seemed top notch (I have skipped the last 5 Fast ring builds).

    The bad thing is, the same bug was present in the first few Redstone builds, too, though not documented.

    The good thing is, MS knows of it, hope they fix it soon.
    This has been the case since the very 1st Redstone build, not just recent (2 as mentioned by MS) builds.

    Workaround

    1. Boot up phone with just 1 SIM, phone will work normally as it is meant to be...
    2. Shut down phone,
    3. Pop in 2nd SIM card and power on phone, 90% chance that device will work correctly with both SIM inserted.
    4. If it doesn't work, repeat step 1 ~ 3
    06-16-2016 09:20 PM
  5. Nagesh Boppana's Avatar
    Looks like this is a know issue. It is even mentioned in latest build 14367 release notes.
    Maurizio Troso likes this.
    06-16-2016 10:18 PM
  6. slyronit's Avatar
    Thanks guys, I am travelling for another week, so don't really have patience for all these workarounds and need Dual SIM specifically because of the travel thing. Hope they fix it soon, or can upgrade when I get back next week and ditch the second sim.
    06-17-2016 04:40 AM
  7. nikosxri's Avatar
    Give feedback to them:

    feedback-hub:?contextid=104&feedbackid=5da4871c-29af-41d6-88b7-e3a200ec851a&form=2&src=2

    to force them for a fix...
    06-17-2016 05:51 AM
  8. nikosxri's Avatar
    clipboard01.jpg

    They are trying...
    06-17-2016 06:01 AM
  9. slyronit's Avatar
    Give feedback to them:

    feedback-hub:?contextid=104&feedbackid=5da4871c-29af-41d6-88b7-e3a200ec851a&form=2&src=2

    to force them for a fix...
    Did, many builds ago. Either ways, it seems they are working on a fix and should be fixed soon. I was just looking for any possible workarounds, not complaining.
    06-17-2016 08:49 AM
  10. zei20t's Avatar
    Thanks guys, I am travelling for another week, so don't really have patience for all these workarounds and need Dual SIM specifically because of the travel thing. Hope they fix it soon, or can upgrade when I get back next week and ditch the second sim.
    or just install the production build which is working fine...........
    06-17-2016 05:51 PM
  11. Stergios Tozas's Avatar
    or just install the production build which is working fine...........
    Same problem. Lumia 950 DS suddenly mobile data not working on build 14393.5, fast ring insider. It had no problems, just all of a sudden a few hours ago stopped working, can't fix it. Only wifi is working.
    08-03-2016 05:02 PM
  12. Maurizio Troso's Avatar
    Same problem. Lumia 950 DS suddenly mobile data not working on build 14393.5, fast ring insider. It had no problems, just all of a sudden a few hours ago stopped working, can't fix it. Only wifi is working.
    You lost APN settings, check inside and ask your carrier for
    Stergios Tozas likes this.
    08-04-2016 02:22 AM

Similar Threads

  1. Wifi and Store issues on 420 build
    By NightOrchid in forum Microsoft Lumia 950 XL
    Replies: 2
    Last Post: 06-18-2016, 12:44 AM
  2. Just a hissing on playback and caller can't hear the Lumia 535, how can I fix this?
    By Windows Central Question in forum Microsoft Lumia 535
    Replies: 1
    Last Post: 06-16-2016, 04:31 PM
  3. Replies: 2
    Last Post: 06-16-2016, 09:08 AM
  4. Unleash your goofy side with Instant Photo for Windows 10
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-16-2016, 08:11 AM
  5. Using MS Project (on office 365) on Lumia 950XL
    By aniseedvan in forum Windows 10 Mobile
    Replies: 1
    Last Post: 06-16-2016, 07:16 AM
LINK TO POST COPIED TO CLIPBOARD