1. redmisfitx's Avatar
    I am on the latest version of the Release Ring, My Data Usage label for cellular shows as "Maritim" anybody else with this?

    wp_ss_20170216_0002.jpg
    02-16-2017 02:34 PM
  2. Guytronic's Avatar
    Were you on a network somewhere other than home?
    02-16-2017 03:10 PM
  3. tgp's Avatar
    I have no idea why it is happening, but I recall reading about this awhile ago. I think it has to do with AT&T roaming or something.
    02-16-2017 03:19 PM
  4. Joe920's Avatar
    Yeah there was another not particularly helpful thread about it. :)
    02-17-2017 07:30 AM
  5. Rusty James's Avatar
    No one has any idea about maritim. I talked to at&t. Searched everywhere for info. My best guess is a sting ray. That is how we are spied on. Apparently there is no privacy.
    03-14-2017 06:53 PM
  6. redmisfitx's Avatar
    Thanks for the replies guys, I have another Lumia, a 640 also on AT&T and it shows AT&T for Cellular. Definitely weird lol.
    03-20-2017 02:40 PM

Similar Threads

  1. Printing shipping labels from eBay.
    By poit57 in forum Edge
    Replies: 0
    Last Post: 02-16-2017, 01:26 PM
  2. Phone losing signal after switching on mobile data
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 02-16-2017, 07:23 AM
  3. Alcatel Idol 4s Windows mobile data issues
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 02-15-2017, 06:56 PM
  4. Outlook 2003 will not send emails although the test email shows no faults
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-13-2017, 01:17 PM
  5. Microsoft shows off HoloLens Spectator View rig
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-13-2017, 12:20 PM
LINK TO POST COPIED TO CLIPBOARD