06-18-2017 09:13 PM
63 123
tools
  1. meattray's Avatar
    Yeah everything running fine on my 1520 as well. I did a complete reset due to the fiasco last week so it's getting an honest test.
    06-09-2017 02:56 PM
  2. anon(9603734)'s Avatar
    I no longer use my 950 as my daily driver, having moved to Android a couple of months ago courtesy of mum giving me her S7 Edge. (For free! I did offer her money but she refused.)

    From time to time I switch my 950 on just to keep up with updates/progress.

    Updated to this build a short while ago. Dare I say it, it seems faster(!)

    Previous builds, the Settings > Notifications and Actions page took ages (10+ seconds) to become responsive. Now it's much quicker. Facebook also loads up from having been fully closed in over half the time it used to; 3 seconds now compared to 8 or so seconds previously. (I've uninstalled Facebook Messenger, so don't know whether that's had a bearing in the load up speed as Facebook's no longer 'connected' to that app.)

    Seems a decent build to me in the use I've had so far.

    Sent from mTalk
    06-09-2017 03:00 PM
  3. zocster's Avatar
    I'm happy with the improvements so far anyway. Having to factory reset every other build is ok. Even my iPhone is begging for it now, after over a year of beta ..

    Sent from mTalk on 950XL
    06-09-2017 04:15 PM
  4. Mark Kaplan's Avatar
    No issues to report HP Elite X3 US.
    06-09-2017 10:51 PM
  5. mtf1380's Avatar
    @Mark Kaplan, do your SD connection issues appear to have been repaired?
    06-10-2017 08:07 AM
  6. Rupert Holmes's Avatar
    Cortana is draining my battery. Cortana complains that she cannot get the bandwidth, or the internet is not working, or that I need to wait for an update. She is just not working, she hears but cannot do. 950XL.
    06-10-2017 11:12 AM
  7. Mark Kaplan's Avatar
    @Mark Kaplan, do your SD connection issues appear to have been repaired?
    I didn't want to jinx myself but so far no disconnects. I still have NFC turned off.
    mtf1380 likes this.
    06-10-2017 12:46 PM
  8. anon(9603734)'s Avatar
    I spoke too early about Facebook, it's back to taking 8+ seconds to open 😔
    06-10-2017 01:11 PM
  9. Omonja's Avatar
    More fixes are welcome
    06-10-2017 02:03 PM
  10. Ektalog's Avatar
    Had a late cup of espresso at midnight and decided "oh, what the heck, let's just do it!". Went to build 15222 (from 15215) in my L1020 (briefly impersonating a 950, just for the update) overnight.

    -- So far no nasties after a few hours of testing.
    -- Anywhere from minor to notable pleasant surprises in speed of some apps.

    So far I am very happy with the build. We'll see how it goes with regular use...
    06-10-2017 04:26 PM
  11. Kerry2112's Avatar
    My Store live tile is completely dead. Nothing I can do to get it working.

    950XL DS
    06-10-2017 09:35 PM
  12. Jaripi's Avatar
    I spoke too early about Facebook, it's back to taking 8+ seconds to open

    Yeah, you did :) ... even FB and Messenger might be working better on background (reopening app from background is fast more often, but still not always). Anyway, this build feels very good.
    06-11-2017 12:53 AM
  13. TgeekB's Avatar
    My Store live tile is completely dead. Nothing I can do to get it working.

    950XL DS
    Did you try repinning it or won't it open at all?

    Sent from mTalk on my SP4
    06-11-2017 07:31 AM
  14. zocster's Avatar
    My Store live tile is completely dead. Nothing I can do to get it working.

    950XL DS
    When I first loaded this, it's ok, but in last 36 hours it's been completely dead too, I think it's a hit and miss, it will show up when it wants to.
    Kerry2112 likes this.
    06-11-2017 11:54 AM
  15. Kerry2112's Avatar
    Did you try repinning it or won't it open at all?

    Sent from mTalk on my SP4
    Yes, tried that and everything else I can think of. No dice.
    06-11-2017 10:32 PM
  16. mtf1380's Avatar
    @Kerry2112, I just check my Store's live tile function (I don't have live tile on for most things...store being one), and my Store's live tile not working either.
    Kerry2112 likes this.
    06-12-2017 08:21 AM
  17. okizen's Avatar
    My L950XLDS keeps restarting sporadically after this update whether I'm using an app or not.
    06-13-2017 08:39 AM
  18. Kerry2112's Avatar
    @Kerry2112, I just check my Store's live tile function (I don't have live tile on for most things...store being one), and my Store's live tile not working either.
    Yeah, I upvoted and commented on feedback this time. I've never had the Store live tile working consistently well, but this is the first build where it absolutely won't function at all. Unlike you, I like an active Start screen!
    mtf1380 likes this.
    06-13-2017 10:59 AM
  19. mtf1380's Avatar
    Unlike you, I like an active Start screen!
    Yeah, I get confused easily
    06-13-2017 11:26 AM
  20. Kerry2112's Avatar
    There's a new build from yesterday (15223)? Anyone install it yet? (I've been on my Nexus 6P this week so I didn't see any notifications about it.)
    06-14-2017 08:18 AM
  21. raycpl's Avatar
    Just got it several hours ago.
    Honestly don't notice anything different, besides the heat. .. nothing out unusual !!

    ... !!
    06-14-2017 08:23 AM
  22. Mark Kaplan's Avatar
    Installing 15223. HP Elite X3 US.
    06-14-2017 09:08 AM
  23. Mark Kaplan's Avatar
    • We fixed an issue where only the first VPN profile was being displayed in the VPN settings page via Settings > Network & wireless > VPN.
    • We fixed an issue where a meeting Time Zone was garbled in Chinese or Japanese.
    • Based on Insider feedback, we have changed “Phone Update” to “Windows Update” under Settings > Update & security.


      Known issues for Mobile
    • In some cases, the WeChat app may crash on launch.
    06-14-2017 09:10 AM
  24. Mark Kaplan's Avatar
    Rather than a new thread, maybe the admin can just update the title and initial post content? Way too many threads....
    06-14-2017 10:31 AM
  25. mtf1380's Avatar
    There's a new build from yesterday (15223)? Anyone install it yet? (I've been on my Nexus 6P this week so I didn't see any notifications about it.)
    Downloaded it last night, took it out for a run (literally) this morning - my running app, Groove and Bluetooth, all played well together:). What's app works fine. 950XL seems lighting fast on this (15222), and last (15215) builds.
    Kerry2112 likes this.
    06-14-2017 11:07 AM
63 123

Similar Threads

  1. Microsoft Mobile Rumors
    By scionluna in forum Ask Dan!
    Replies: 15
    Last Post: 08-04-2017, 02:03 PM
  2. Windows won't load second monitor
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-09-2017, 01:57 AM
  3. Replies: 0
    Last Post: 06-08-2017, 04:36 PM
  4. Replies: 1
    Last Post: 06-08-2017, 02:28 PM
  5. How to stop Windows 10 from showing the welcome screen after feature updates
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-08-2017, 02:10 PM
LINK TO POST COPIED TO CLIPBOARD