1. WHSdad's Avatar
    I have a lumia 1520 with windows 10. The edge browser loads about 3/4 of the way then stops for about a minute before it loads all the way. Any ideas what is causing this?
    12-28-2015 05:34 PM
  2. vinscg's Avatar
    does the same on my 830 .
    12-28-2015 05:44 PM
  3. WHSdad's Avatar
    I did notice today that if I delete my history it loads really quick. Then the next time I open it, it is slow again until I delete my history
    12-29-2015 03:59 PM
  4. nareshkumarcool's Avatar
    it taking some time to show full page,may be processing something cause to slow down a little thus showing black page for few seconds
    12-30-2015 06:13 AM
  5. WHSdad's Avatar
    The page isn't blank. It is the actual website just really small. You are unable to do anything until it finally loads the page fully. Once I can get one page to load I can go into settings and clear browsing history and everything loads really fast after that. Once I close edge and go back to it later it is back to hanging while loading the page. Very frustrating when using links on twitter. Each link takes forever to view.
    12-31-2015 05:34 AM
  6. WHSdad's Avatar
    does the same on my 830 .
    I think I have the answer for you. I thought when you closed the browser it closed all tabs. not the case. I had tons of tabs open. Closed them all and it works fine now.
    01-02-2016 05:42 AM

Similar Threads

  1. Microsoft Edge Tab Previews
    By alqwerty in forum Edge
    Replies: 1
    Last Post: 06-16-2016, 11:47 AM
  2. Microsoft REALLY wants me to keep using Edge
    By Generalheed in forum Edge
    Replies: 1
    Last Post: 12-28-2015, 08:07 PM
  3. Replies: 1
    Last Post: 12-28-2015, 01:50 PM
  4. How do I load Cortana into Windows 10?
    By john cronin1 in forum Cortana
    Replies: 0
    Last Post: 12-27-2015, 05:27 PM
  5. why has microsoft edge stopped working
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 12-27-2015, 09:39 AM
LINK TO POST COPIED TO CLIPBOARD