The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. speccy's Avatar
    My L930 is configured with my Microsoft account as normal, but when I log into my Microsoft account, it shows my PC's as devices but not my phone. There is a section where it says "add a device", but when you click this, it gives instructions for some devices, but for phones it would seem it should already be there if the phone is properly configured with a Microsoft account.

    Has anyone got this feature working with Win10M? If so, what could I be missing? I'm running the latest build of Win10M.

    Thanks.
    01-25-2016 08:58 AM
  2. PPCFreak's Avatar
    mine has not worked since I moved to W10M.
    01-25-2016 10:11 AM
  3. speccy's Avatar
    This makes me quite nervous, I've never lost a phone before, but just last year my wife left her's at a restaurant, and when she called said restaurant, they said it wasn't there and hadn't been handed in. Used "find my phone" while I was the other side of the country and was able to tell my wife via a land-line it was at the restaurant still. She went in and made a fuss, then they sheepishly handed it over - thieves...almost.
    01-25-2016 01:54 PM
  4. Rugish Dapeca's Avatar
    Seems to be working just fine for my 640 LTE. I have both options enabled in the settings.

    • Save my device's location periodically so it's easier to find, even if location is off.
    • Save my device's location more frequently.
    01-25-2016 06:45 PM
  5. gwinegarden's Avatar
    Seems to be working just fine for my 640 LTE. I have both options enabled in the settings.

    • Save my device's location periodically so it's easier to find, even if location is off.
    • Save my device's location more frequently.
    The settings are there on my phone, but the phone does not appears on https://account.microsoft.com/devices
    01-26-2016 07:57 AM
  6. speccy's Avatar
    The settings are there on my phone, but the phone does not appears on https://account.microsoft.com/devices
    Same here.
    01-26-2016 09:11 AM
  7. Aurelink's Avatar
    Seems to be working for me. I see my 950XL, last position saved just 3h ago.
    01-26-2016 10:12 AM
  8. PPCFreak's Avatar
    I was having same issues with Find My Phone with W10M on L928 yesterday.
    I just checked my Windows Insider and found that I was not in any Ring for some reason (guessing after the last Windows Insider update).
    I put my L928 back into Fast Ring and rebooted.
    I can now use and see my L928 on https://account.microsoft.com/devices AND the date and time line up exactly to when I rebooted AFTER putting it back into Fast Ring.
    Not sure if it has to do with the device reboot and/or being in a RING or not.
    I will follow up tomorrow and check it out again and see if it stays available on Find My Phone or not.

    EDIT: And I just tested RING and LOCK from the website and both work as designed. can not test ERASE as I dont care to loose all my data at this time.
    Last edited by PPCFreak; 01-26-2016 at 01:55 PM. Reason: See EDIT
    01-26-2016 01:48 PM
  9. gwinegarden's Avatar
    BINGO! Thanks!
    01-26-2016 03:12 PM
  10. speccy's Avatar
    Thanks PPCFreak, you're a star. That was the solution for me too.
    01-26-2016 03:43 PM

Similar Threads

  1. Issues with camera and video files, can I get some help?
    By mnixon84 in forum Microsoft Surface Pro 4
    Replies: 2
    Last Post: 02-17-2016, 04:23 AM
  2. Many of my contacts keep being erased for no apparent reason, how can I stop this?
    By Windows Central Question in forum Microsoft Lumia 640
    Replies: 2
    Last Post: 01-26-2016, 01:21 PM
  3. Find my phone not working.
    By Ixia in forum Ask a Question
    Replies: 3
    Last Post: 01-26-2016, 08:49 AM
  4. Where is my music gone after upgrading to Windows 10?
    By Windows Central Question in forum Windows 10
    Replies: 6
    Last Post: 01-25-2016, 05:24 PM
  5. Replies: 0
    Last Post: 01-25-2016, 07:37 AM
LINK TO POST COPIED TO CLIPBOARD