The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
01-06-2017 07:23 AM
39 12
tools
  1. Maurizio Troso's Avatar
    Grazie Maurizio, I'll chek if i can find sth like that on mine later on, I'll keep you posted.... But that doesn't explain why only my W10 phone is like that, 2 Android phones connect without problem...
    I know, when happened to me I got simultaneously 2 notebooks and one Android phone normally connected >.<
    04-06-2016 04:16 AM
  2. Stephen Wellwood's Avatar
    I have the same problem with no internet. I can connect fine if I manually set the IP, gateway, and DNS. but only my 920 has a static IP in W10M. I found a static IP app that works sometimes for my 950xl. I have reset the router several times and now everything in my house has a static IP just because my 950XL has no internet when connected.
    04-07-2016 05:56 PM
  3. simoncu's Avatar
    Update : it's been a few weeks now that the phenomenon stopped. It has been at least 4 updates on the phone as well. Maybe this explains that ....
    07-07-2016 07:04 AM
  4. phelme's Avatar
    This started happening to my 950 XL a couple builds ago on the Fast Ring. Beyond annoying. Can't connect to ANY WiFi access point unless the phone is powered cycled, then it'll connect fine. Until... after some indeterminate amount of time asleep, you wake up the phone and whatever access point you try to connect to will be declared as having "No Internet Access" again. :-/

    I'm guessing this is some DHCP problem in WM. Why Microsoft doesn't allow one to set the IP manually based on WiFi SSID I'm not sure. The interesting thing is some router interaction is happening, because you can see that the DNS is set correctly in the network info, even though the Gateway is 0.0.0.0 and the IP is self assigned (169.x.x.x).

    Tried setting up a dedicated IP based on the MAC address of the phone but made no difference. Also tried using the "Static IP" app in the store. Doesn't appear to work, so I imagine there was a change from Windows Phone 8.x to Windows Mobile 10.

    Cellular data is unaffected by this bug.

    EDIT: Apparently it's a known problem that MS is looking into.
    Last edited by phelme; 07-07-2016 at 01:18 PM.
    07-07-2016 01:01 PM
  5. baddog2's Avatar
    Same problem. Device Lumia 640 LTE. Message: No data connection. In settings try to open data connection but again message No data connection.
    Turn off phone
    Restart phone
    All OK.
    07-08-2016 02:11 AM
  6. Karthik Coimbatore's Avatar
    Hi Friend,
    I had the same problem and its solved now. Delete the wifi Network from ur mobile (in wifi off position - Manage), reset your router and try connecting again.
    Follow the below link for details.
    https://support.microsoft.com/en-us/...nection-issues

    Its really working..
    Maurizio Troso likes this.
    08-24-2016 03:36 AM
  7. Karthik Coimbatore's Avatar
    I am sorry guys, the next day (Today) it don't work, I tried everything..
    OMG Feeling irritate..
    08-25-2016 01:38 AM
  8. Girish Kumar8's Avatar
    Same problem with
    L 540.its update or down date
    08-25-2016 03:08 AM
  9. Maurizio Troso's Avatar
    Same problem with
    L 540.its update or down date
    Reboot both phone and router
    08-25-2016 03:36 AM
  10. Moez Juventus's Avatar
    If you have a signal repeater other than the router, turn it off for a while letting only the router on. It worked for me!
    08-25-2016 03:58 AM
  11. Jefegu's Avatar
    That's not a solution. I can't reset the routers in the tube network, at work, or gym....
    It is a problem that happens recently quite often (too much often to be realistic, cause more than 2 times a day is not stupid thing) and only restarting phone solves it.
    10-18-2016 03:27 AM
  12. prakash m2's Avatar
    Hi friend,
    I also had the same problem,but solved now.first go to settings,network & wireless,wifi,static ip,configure network settings manually turn it off then connect with wifi and hotspot....
    11-03-2016 11:45 AM
  13. Girish Kumar8's Avatar
    Still have same problem
    11-29-2016 05:12 AM
  14. akggkp1998's Avatar
    It won't even connect to my phone hotspot however. Like it connects but says no internet. Idk what to do
    don't worry friends i got solution of this problem which is also happen with me. first you open setting> Wi-Fi> static IP and then turn off configure network setting manually. you got it if battery saver is on then turn off if necessary
    I'm very happy to get solution because i think to perform soft reset which is cause to lose all usr data and apps games. ok thanks.
    01-06-2017 07:23 AM
39 12

Similar Threads

  1. Replies: 1
    Last Post: 03-05-2016, 08:19 PM
  2. SP4 - Advice for someone new to the brand - Yay or Nay?
    By Great deal in forum Microsoft Surface Pro 4
    Replies: 24
    Last Post: 03-03-2016, 06:25 AM
  3. App not installing on Lumia 730
    By Anish Sankhe in forum Windows 10 Mobile
    Replies: 9
    Last Post: 02-12-2016, 02:42 AM
  4. Amazon has released its own Windows 10 and Xbox One game engine for free
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-09-2016, 07:50 AM
LINK TO POST COPIED TO CLIPBOARD