1. zeke009's Avatar
    Anyone using a Plantronics Legend (PLT_Legend) headset with a Windows 10 Mobile 10586.164? I just rolled back from the Redstone release on my 950 and my headset will not connect at all no matter what I do. I've restarted everything a few times, no luck.<sarcasm> Heck, I even restarted my TiVo DVR for good measure and that didn't help! </sarcasm>

    Anyone else using one of these and recently paired it? It worked previously on day one when I got the 950, but since the rollback this evening this is just a no-go.
    03-22-2016 12:32 AM
  2. ginginha's Avatar
    I realized this is several months after the OP, but I just upgraded my 830 to W10M over the weekend and my Legend can no longer connect. It worked perfectly on 8.1. Were you able to find a fix?
    08-01-2016 11:06 AM
  3. PGrey's Avatar
    I use a Plantronics PLT_M165, a much cheaper Plantronics headset (I've used their stuff for a very long time, since the plug-in days, maybe mid-90's, all good stuff!).
    Mine was "finicky" with the RS final preview, I had to try maybe 2-3 times, and it finally paired.
    08-01-2016 12:38 PM
  4. zeke009's Avatar
    I ended deleting the profile from my phone and RTFM'ing the manual on the headset because it had been so long, I pressed the wrong button to pair it. It has been awesome ever since.
    08-01-2016 06:55 PM

Similar Threads

  1. Productivity apps: camera and pdf comments
    By Wakk in forum Windows 10
    Replies: 2
    Last Post: 04-17-2016, 08:00 AM
  2. Photo Editing W10m
    By belodion in forum Nokia Lumia 930
    Replies: 7
    Last Post: 03-25-2016, 03:02 PM
  3. Windows 10 Update Released for Lumia 540 and 10 Devices
    By Sankar Raman in forum Microsoft Lumia 540
    Replies: 2
    Last Post: 03-22-2016, 12:44 AM
  4. Microsoft Photos for Windows 10 Mobile grabs Print and Living Image menu support
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 03-21-2016, 03:42 PM
LINK TO POST COPIED TO CLIPBOARD