06-03-2016 10:51 AM
83 1234
tools
  1. WesleySmalls's Avatar
    I'm having a 735 as well, running the latest insider build but I have none of the issues you have described. Sure, there are the occassional hick-ups but performance has been very consistent.
    05-30-2016 03:24 PM
  2. Adjaero Pascal's Avatar
    sorry but always have it at the back of your mind that you're using (testing) incomplete software prone to behaving like that. I have a 640 and a nexus 5X and both are running beta software with issues left right and center. The only way I keep my sanity and not throw my phone against the wall is that I know am using beta software and have accepted the fact that things can go wrong, I just try to find solutions (give feedback) and hope things get better with the next builds
    05-30-2016 03:46 PM
  3. TechFreak1's Avatar
    I didn't mean for my thread to be taken literally. What I meant is that after time goes on it seems to get very sluggish.

    No, I didn't restore from a backup.
    fair enough :) and I see
    05-30-2016 04:08 PM
  4. alhadro's Avatar
    I have noticed the same thing. Some builds that seem fantastic on first install seem to just go downhill after a while.. Sudden restarts seem to increase in frequency, hanging apps, things like that become more consistent. (Lumia 735). If the issue is the phone's low end specs, I'm not sure why it would perform so fantastic for up to a week. Almost seems as if some sort of memory leak that isn't really remedied with a restart.
    aXross likes this.
    05-30-2016 05:36 PM
  5. Marconis4's Avatar
    I have noticed the same thing. Some builds that seem fantastic on first install seem to just go downhill after a while.. Sudden restarts seem to increase in frequency, hanging apps, things like that become more consistent. (Lumia 735). If the issue is the phone's low end specs, I'm not sure why it would perform so fantastic for up to a week. Almost seems as if some sort of memory leak that isn't really remedied with a restart.
    Right -- this is why I don't feel it has anything to do with low end specs, because it does very well in the beginning of the new build. I've swapped my SIM back since I really hate using iOS in terms of UI, but I'm sure the issues will return.
    05-30-2016 06:19 PM
  6. Changaizee's Avatar
    You said you are on latest Production build, but what you described happens with Fast ring RS builds, i face issue with the 14342 on my L1520 which were not there when i installed the build first, like phone app has been crashing on me more often now, messaging sometimes shows this just a moment screen for a few sec thou, but again im okay with his as these are fast ring build, didnt have no issue with the 10586 builds and those are the production builds, for me they were bug free but feature less, so i have compromised performance for features. hoping that the 14352 resolve the issues. if you are looking for a bug free build, go to the 10586 builds they are best and IMO are better than 8.1.
    05-30-2016 07:18 PM
  7. Marconis4's Avatar
    You said you are on latest Production build, but what you described happens with Fast ring RS builds, i face issue with the 14342 on my L1520 which were not there when i installed the build first, like phone app has been crashing on me more often now, messaging sometimes shows this just a moment screen for a few sec thou, but again im okay with his as these are fast ring build, didnt have no issue with the 10586 builds and those are the production builds, for me they were bug free but feature less, so i have compromised performance for features. hoping that the 14352 resolve the issues. if you are looking for a bug free build, go to the 10586 builds they are best and IMO are better than 8.1.
    Is 10586.318 not the latest production build?
    05-30-2016 08:17 PM
  8. pratok69's Avatar
    I am now using a Lumia 640, was using a 925. I too have noticed degradation in performance sometimes weeks after a new build. I am referring to fast ring and production ring builds. I believe applications could be the cause. For an OS to be stable/ optimal, it and the applications must "harmonize".
    I am only guessing and have no software experience other than end user. Perhaps an application has been updated or needs updated, Facebook certainly seemed to cause problems when installed....Though I am fairly certain I noticed the shelf life effect you are referring to.
    Even though it is Windows as a Service I am hoping we will reach a stable build and hold for a period and apps can be optimized and devices can be optimized. For now it seems we are in a state of change which I view as a positive. We will get there, keep up the good work.
    And I will remain " a windows fan with fingers crossed".
    05-30-2016 09:36 PM
  9. redserpent7's Avatar
    I did notice that a couple of builds ago, but since the last update, mine is (10.0.10586.318), it seems everything is in order as I did not have any issues. Previously my phone would randomly restart at least twice a day, lots of app crashes and lots of screen flickering when using edge. Now all is stable.
    libra89 likes this.
    05-31-2016 12:57 AM
  10. BBurke33609's Avatar
    I think that you've run into the actual circumstance that creates the situation. The insiders have become the actual the QA dept for the most part.
    05-31-2016 02:06 AM
  11. Joedels's Avatar
    As much as I like Windows 10 Mobile, I'm experiencing the same issues.

    I'm currently using a Lumia 550. At the beginning of each build I flash, the device lags and stutters like crazy. It's just not a pretty sight.

    After a few days, the update seems to have settled a little bit and the device is actually usuable, although lags and stutter never really disappear.

    After a few weeks however, things go south and the device runs just like when I flashed the new build. It lags even when sliding down the notification center. It lags when browsing around the UI. It's a pitty really, because this device was 'meant' for Windows 10 Mobile, so specs shouldn't really matter.
    05-31-2016 02:43 AM
  12. justonlumia's Avatar
    The longpress back now takes 2-3 seconds with only 1 app open on L640
    05-31-2016 03:25 AM
  13. RPF75's Avatar
    I get a lot of the same issues on my 735 that you note....add quiet hours working whenever it wants to the list.
    05-31-2016 07:43 AM
  14. sheldon cohn's Avatar
    I agree the builds takes time to actually test everything, we seem to find new bugs in the software that used to work in the previous build. It's depressing when new builds come out and some of our phones don't receive them. Low phones or not, which is a shot in the arm for Microsoft, specially when the low end has been having problems with it's build and it doesn't seem to be getting fixed. Several times I wanted to show friends the phone and it's software, and several times the phone wouldn't perform what was needed.
    This isn't a good selling point for the phone.
    05-31-2016 08:49 AM
  15. greedo_greedy's Avatar
    prior to build .318 it seemed stable enough but I must say that I did experience two instances where w10m went slightly out of whack but I wouldn't call it show stopping.

    Still it prompted me to at least power cycle the phone.

    The two things I experienced are where the photos would show blanks and the people app as well would show blanks.
    libra89 likes this.
    05-31-2016 08:50 AM
  16. speccy's Avatar
    The problem is that we've been spoiled and have become accustomed to insider builds improving with each release, so much so that we started to look forward to them. But recently, it's been the opposite, with each new build issues would arise that weren't there before hence the feeling of things going backwards rather than forwards. I guess it's not really fair on our/my part to not expect these issues with beta software, but because MS seemed to have got a handle on things over the last few months, we came to expect it to get better going forwards, not worse.
    05-31-2016 10:05 AM
  17. bradwestness's Avatar
    As we get near to the Anniversary Update the builds should start getting more solid and less buggy again, but yeah, after each major release they're gonna be shaky again for a while as the team starts doing more new feature work and changes rather than just fine tuning for an approaching public release. Maybe move to the slow ring?

    It could also just be that your phone's storage is getting filled up as time goes on if you have a lot of pictures, apps, music, etc. on the device. It's not going to perform as well if the disc is nearly full.
    05-31-2016 10:18 AM
  18. Darren Vitarana's Avatar
    it's probably because the devs and qa's dont really care; maybe they probably don't use windows mobile personally, and/or they don't feel like they're working towards anything. in product management you have to give purpose to your product and the team will be brought into the vision along with the 'why' as to what they are doing and stay motivated.

    current signals are that mobile is not a priority and MS don't care about their own mobile platform. no new devices in are sight, no consumer device to be passionate about either (mobiles are really the good gadgets arent they?). the heady heights of 10% usage (eg eu5) are long gone and nadella and co basically let it rot away.

    that being the case who'd be bothered to do a good job?
    aXross likes this.
    05-31-2016 10:24 AM
  19. trha's Avatar
    I used W10M on my 925 for about 5 - 6 months before moving on to 950 XL. I have none of the annoying issues you have mentioned. There are still some minor performance issues but things work most of the time.
    05-31-2016 10:41 AM
  20. Lloyd_S's Avatar
    I experience issues every two weeks as well and went back to Android for a week. Hated the Android experience and things like the phone overheating or opening apps while in my pocket (even with a security screen unlock code). I have reinstalled 10586.318 two times because issues would become so bad after two weeks I couldn't use the phone. I'm tired of reinstalling, but I really don't like the other OS choices out there.
    05-31-2016 10:50 AM
  21. TheFerrango's Avatar
    I too have had this impression. although things have been pretty stable lately (since .318) with my L925.
    Then again, I basically given up. I'm torn between rolling back to 8.1 and having voice commands hopefully work again, but lose the new (mostly) working apps, or stay with 10, with the new updated apps but with Cortana crashing most of the times I try to use her.
    05-31-2016 10:54 AM
  22. speccy's Avatar
    As we get near to the Anniversary Update the builds should start getting more solid and less buggy again, but yeah, after each major release they're gonna be shaky again for a while as the team starts doing more new feature work and changes rather than just fine tuning for an approaching public release. Maybe move to the slow ring?

    It could also just be that your phone's storage is getting filled up as time goes on if you have a lot of pictures, apps, music, etc. on the device. It's not going to perform as well if the disc is nearly full.
    In my case, it's not full storage, I don't use an SD card, and the built-in 32GB is less than half used currently. A good tip still though which may help others.
    05-31-2016 11:28 AM
  23. Jcmg62's Avatar
    Agreed. My 950 goes mental sometimes. Just randomly switches off. Have to soft reset at least 5 times a week to overcome issues. Have had to do really annoying hard resets twice over the past couple of months, which is bloody annoying
    05-31-2016 11:36 AM
  24. Shane Richardson1's Avatar
    I get this same thing with the Icon. It generally is great for almost a week then it just goes crazy. Glad it's not just me!
    05-31-2016 12:27 PM
  25. Muessig's Avatar
    I'm just going to leave this here as it pretty much applies.

    http://forums.windowscentral.com/win...ml#post3464520
    libra89 likes this.
    05-31-2016 03:18 PM
83 1234

Similar Threads

  1. Is it possible to change the order of Vector Watchfaces?
    By Sargon Aelther in forum Smartwatches
    Replies: 7
    Last Post: 08-10-2016, 09:53 PM
  2. Who is in charge of favourites on Edge
    By Bobvfr in forum Edge
    Replies: 3
    Last Post: 05-30-2016, 05:09 AM
  3. W10M Mail forwarding problem, how can I fix this?
    By simspa in forum Windows 10 Mobile
    Replies: 1
    Last Post: 05-29-2016, 01:59 PM
  4. Can't find the new, official Share.it app in the Windows Phone store?
    By Windows Central Question in forum Applications
    Replies: 1
    Last Post: 05-29-2016, 10:10 AM
  5. Microsoft Band 2's $75 discount price of $175 gets extended until July 9
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-29-2016, 09:11 AM
LINK TO POST COPIED TO CLIPBOARD