The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
03-31-2017 10:04 PM
31 12
tools
  1. TOHSL's Avatar
    It seems that ever since the so-called Anniversary Update last week, all the emails I sent out from my phone are only having my email address in the From field. My sender name is not showing. I checked my settings and the sender name I set for my various accounts is still there. I have re-saved the settings, but my outgoing mails are still being sent without my sender name in the From field.

    Anyone else has this problem, and any idea what's happening? I have searched online to no avail for the solution.

    Outlook Mail 17.6965.41052.0
    Software: Windows 10 Mobile
    Version: 1607
    OS build: 10.0.14393.67
    08-30-2016 05:33 AM
  2. JD 96's Avatar
    1. Open the app
    2. Tap the three dots on the bottom right
    3. Choose "Settings"
    4. Choose "Signature"
    5. Make sure the "Use an email signature" is On
    6. Set your signature in the box below
    08-30-2016 09:43 AM
  3. mv007's Avatar
    @JD 96: setting email signature does not fix this issue

    I have the same problem ... bought a new Lumia 650, set-up several IMAP email accounts, all with real sender's name configured. When sending emails from any of my email accounts, they all have 'xxx@yyy.com' in the From field instead of sender's name.

    I've checked that the (same) real sender's name is configured for all accounts:
    Going to Settings > Email & app accounts > clicking on any email accounts + Manage > Change mailbox sync settings:
    'Send your messages using this name' is populated with sender's name, not email address.

    When I try to create a new email message (by clicking + in the Outlook Email app and choosing the account I want to send it from), a new message screen comes up with From: populated by the email address, not the name!

    After I send it, messages arrive with From: still populated just by the email address. This looks very unprofessional.

    Such a basic thing, why does this not work? Any ideas on how to fix this?
    Are there other settings which influence whether the real sender's name or the email address is used in the From field?

    I've tried deleting and recreating all email accounts, updating the Outlook Mail app, still the same problem.

    Thanks for all suggestions!

    -
    Outlook Mail version 17.7167.40818.0
    Windows 10 Mobile
    Version: 1607
    OS build: 10.0.14393.189

    Lumia 650 Dual SIM
    Firmware revision number: 01078.00037.16082.41002
    Hardware revision number: 3.0.6.0
    10-08-2016 01:45 PM
  4. Maurizio Troso's Avatar
    Did you l,inked correctrly your outlook accounts in People app? Each contact might get 2 or 3 separate entries, they need to be linked manually
    10-09-2016 03:55 AM
  5. mv007's Avatar
    @Maurizio I've tried to link all contact entries in People app with my name on (using the link chain icon at the bottom the contact and clicking on all suggested other contacts with my name, is that what you've meant?), restart the phone, unlink again, none of this made any difference at all.

    I've not tried resetting the phone yet, hoping there is a easier solution to this problem.

    Any other suggestions?
    10-09-2016 09:22 AM
  6. mv007's Avatar
    Update on progress (or the lack of):

    I have upgraded W10 Mobile OS to the latest release, tried a hard reset, even tried with the latest Insider preview, but the problem persists.

    This is what I've tried:

    1. Settings > System > About > Reset your phone (and erase my SD card)
    This took a while, then I was presented with what looked like a factory reset phone... but it isn’t since it keeps the last version of the OS installed (OS build: 10.0.14393.321), not the one which came with the phone.

    2. Did the initial config, configuring Wifi, but skipped everything else I could, NOT connecting to my outlook.com account.

    3. I could not use the Outlook Mail straight away since it said I had to upgrade first, so I've updated the app (together with many other apps automatically selected for an update).

    4. Then I've configured just ONE email account (IMAP4), using Choose an account > Advanced Setup > Internet Email), and set the senders name to my name, as “FirstName Surname”, Email address as “my@email.com” (using these just as examples, on the phone I’ve put in my real name and my real working email account).

    5. Once the account was successfully set-up, clicked on ‘Ready to go’, inbox got synced, email messages downloaded ok.

    6. Then I’ve tried sending an email with just this one email account configured.
    - when composing the message, From: field has my email address not my real name (ok, that's the same as on Desktop W10 Mail app, not a major problem, just strange / different from every other email client I’ve used)
    - when the email message is delivered (I am looking at it using desktop Ms Outlook 2013 client), the From: field still shows only my email address (this is different from the Desktop W10 Mail app, where on delivery, the From: field shows the real name)

    The two apps I was comparing were:
    - mobile: Outlook Mail version 17.7369.40738.0
    - desktop: Mail version 17.7369.40731.0 (so a bit older than the mobile app)

    I’ve checked the email headers on the two test messages (one sent from my mobile another from the desktop app) and I can see that From fields are different:
    - mobile originated message has (no real name)
    From: my@email.com
    - desktop app originated message has (real name and email in <> brackets, as expected)
    From: "FirstName Surname" <my@email.com>

    So I can be definitely certain that it is not my email server causing this issue, since it works with the W10 Desktop Mail app (as well as Ms Outlook 2013) from the desktop.

    7. Then I’ve tried adding myself as the only contact in the People app with my name the same as the sender name and the same email address as the one configured in the email account settings. There is only 1 contact in the People app (the one I’ve just created) and this does not sync with outlook.com or other contact sources.
    No change, same bad result. On receipt the real name is missing from the From: field in the message header.

    8. Then I’ve repeated the above process while getting the ‘Fast’ Insider preview OS build (10.0.14946.1000) which has the same Outlook Mail app (17.7369.40738.0). No change, same bad result.

    -
    My conclusions is that this is a bug with the latest Outlook Mail app on W10 or some underlying email account management functions in W10 Mobile.

    It is insane that such a basic feature, as sending the real sender’s name, does not work! I am starting to understand why people are abandoning W10 mobile…

    I have two more questions:

    Q1. Does anyone know where the email account settings are stored on the phone?

    I am thinking Registry entries, hidden files or folders, local database... perhaps this could be hacked into working somehow. I've tried looking around the Registry with the Interop Tools but could not find anything relevant.

    Q2. Is there a way how I can go back to an earlier version of the Outlook Mail app and/or OS on my W10 phone?

    If you got this working somehow on your phone, please let me know how.

    Thank you!
    Last edited by mv007; 10-15-2016 at 05:46 PM.
    jalmos likes this.
    10-15-2016 01:48 PM
  7. jalmos's Avatar
    Hi,

    I have Lumia 830 upgraded to Win 10 1607, 10.0.14393.321 and have the same problem. I use Gmail as my primary private email account and first noticed the problem with it. However, it seems to be so that with my company exchange account or with Microsoft Outlook account this problem doesn't exist.

    Yes, as I write the email it first shows only email address but during sending it converts to my sender name. But with Gmail it doesn't work.

    Could it be one again a specific Gmail "feature" or have you actually noticed this problem with other service providers as well?
    11-07-2016 11:20 AM
  8. theshowman's Avatar
    This is not specific to GMail - it also happens with yahoo email accounts.
    I reported this issue back in April/May through the feedback hub and there hasn't yet been a resolution.
    There is most likely a huge number of people having this issue, but they just don't know it as they don't look at the emails they've sent themselves.

    It is a real disappointed and as someone said, something that looks very unprofessional.
    11-22-2016 01:18 PM
  9. johnny77777's Avatar
    Any resolution to this? Also having this issue on both Windows 10 Mobile AND Windows 10 on my laptop. I've tried my gmail account and my former university account. Same problem with both. Display name does not show, only shows email address.

    When I attempt sending from Outlook.com, I don't have the problem. So there's clearly a problem with the Mail app itself in both Windows 10 and Windows 10 Mobile.
    01-12-2017 01:08 PM
  10. wgrs's Avatar
    Same problem here. I gave up on this, they can't even fix such a simple bug. 10 years ago, nobody would deliver a email app that faulty. Just live with it, their software is stuck in 1985.
    01-12-2017 05:11 PM
  11. Sam Nome's Avatar
    The same problem here with me on 2 Lumia devices running Windows 10 Mobile.

    I noticed this in August 2016 only and am shocked (after reading this thread) that this bug apparently exists even much longer and nobody from Microsoft cares, until today.

    As many others said. This is very unprofessional from Microsoft. Such an email-client is useless especially for business purposes. What should a recipient think when he receives an email from me (his business partner) without a senders name?

    I also gave up on this issue already. They (MS) can't (or don't want to) even fix such a simple bug:-(

    In case you’re interested, you might vote up one of my feedbacks on this in the Mobile Feedback Hub here...

    https://aka.ms/l10cl1

    or… vote up the corresponding thread in the MS-Community:

    https://answers.microsoft.com/en-us/...e-e26ccff739cf
    01-16-2017 08:51 AM
  12. johnny77777's Avatar
    I noticed this in August 2016 only and am shocked (after reading this thread) that this bug apparently exists even much longer and nobody from Microsoft cares, until today.
    What do you mean, "until today?" ... Did they finally acknowledge the problem and are fixing?
    01-27-2017 12:10 PM
  13. Sam Nome's Avatar
    What do you mean, "until today?" ... Did they finally acknowledge the problem and are fixing?
    Not to my knowledge. I still strongly believe that they still aren't aware of this problem. That's the only explanation that I have.

    And the problem on my devices persists, even after all the inumerous updates of the last weeks and months. :-(
    01-28-2017 04:31 AM
  14. wgrs's Avatar
    And they claim this is a "business phone". When clients receive emails
    From: mark2439@hotmail.com

    01-28-2017 11:16 PM
  15. EspHack's Avatar
    Not to my knowledge. I still strongly believe that they still aren't aware of this problem. That's the only explanation that I have.

    And the problem on my devices persists, even after all the inumerous updates of the last weeks and months. :-(
    oh you bet they are aware of this, they just have more urgent problems to fix, like the main OS itself being the mobile equivalent of windows ME
    wgrs likes this.
    01-28-2017 11:23 PM
  16. waeras's Avatar
    I finally got confirmation that they are investigating this: https://twitter.com/caithartMSFT/sta...04941647175681
    anon(3463402) likes this.
    02-11-2017 03:05 PM
  17. madcursor's Avatar
    Hope they will fix this soon. Feedback has been there for ages now..
    02-11-2017 09:44 PM
  18. Sam Nome's Avatar
    I finally got confirmation that they are investigating this: https://twitter.com/caithartMSFT/sta...04941647175681
    Thanks a lot for this info!!

    Now a little hope awakens in me that this issue finally is going to be resolved.

    As I’m not using Twitter I’m asking you to please keep me up to date here. Thanks in advance.
    waeras likes this.
    02-12-2017 06:22 AM
  19. Sam Nome's Avatar
    I finally got confirmation that they are investigating this: https://twitter.com/caithartMSFT/sta...04941647175681
    I just read your post on the Tech Community. As I'm not registered there, could you please add to your compilation of bug reports my post in the normal Microsoft Community on this regard as well? Here it is again:

    https://answers.microsoft.com/en-us/...e-e26ccff739cf
    waeras likes this.
    02-12-2017 06:36 AM
  20. waeras's Avatar
    I just read your post on the Tech Community. As I'm not registered there, could you please add to your compilation of bug reports my post in the normal Microsoft Community on this regard as well? Here it is again:

    https://answers.microsoft.com/en-us/...e-e26ccff739cf
    Sure thing!
    02-12-2017 05:08 PM
  21. Sam Nome's Avatar
    Sure thing!
    Thank you!

    And now let us all hope for a bug-fix.
    02-13-2017 09:08 AM
  22. waeras's Avatar
    Fix is going out to insiders soon. :-)


    Update from Microsoft:
    "The fix should be going out in a Windows update to Insiders soon, but I need to figure out which flight it will be captured in before I can give a better ETA".

    The reason for the delay is that the bug have turned out to be outside of the Mail app, so they can't just fix it with an updated app in the Store, that's why we have to wait for a new build.

    Thank you to Lynn Ayres & Caitlin Hart at Microsoft for taking the time to provide me with this information.
    anon(3463402) likes this.
    02-23-2017 09:59 AM
  23. waeras's Avatar
    Update: The fix for this is finally rolling out to insiders in the Fast Ring as of today. Slow Ring and production should be getting it soon too.


    "For the fix of from-name issue in #Win10Mail check Windows build 15042/3 flighted today" - Caitlin Hart
    anon(3463402) likes this.
    02-24-2017 01:22 PM
  24. wgrs's Avatar
    Update: The fix for this is finally rolling out to insiders in the Fast Ring as of today. Slow Ring and production should be getting it soon too.
    Confirmed, it's working in fast ring for the first time. An incredible engineering effort has become true!
    anon(3463402) likes this.
    02-25-2017 11:00 AM
  25. Sam Nome's Avatar
    Well, I can only say from my side that last week I received an update to Outlook-Mail Version 17.7920.40508.0 but here nothing changed again. The problem persisted.

    Today another one came in, now the Outlook-Mail Version 17.7922.42018.0 and again, nothing changed.

    Still no solution to our issue here, the missing sender’s name problem persists (on both of my Smartphone devices Lumia 650 and 950).

    The only change I see now in Outlook-Mail is a new childish Kindergarten view with plenty of multi-colored bubbles and wrong initials in it.

    Are the developers out of their mind? Why are they busy with implementing unnecessary stupid and childish things like this instead of fixing the bugs?!
    03-02-2017 01:53 AM
31 12

Similar Threads

  1. Camera not opening
    By shaikh samiul islam in forum Ask a Question
    Replies: 7
    Last Post: 09-25-2016, 01:26 AM
  2. Call of Duty titles and more Xbox games get price cuts in this week's Deals with Gold
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-30-2016, 05:30 AM
  3. SanDisk Extreme 64GB is yours for just 17 on Amazon
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-30-2016, 04:42 AM
  4. Why am i getting a no Internet response message
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-30-2016, 04:28 AM
  5. cannot see photo in gallery L730
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-30-2016, 04:03 AM
LINK TO POST COPIED TO CLIPBOARD