1. anon(9963266)'s Avatar
    Since W10M (I've only tried Redstone) I found bluetooth buggy on my 930 and two 1520s. Nowhere as reliable as WP 8.1. I have tried various RS1 builds and none have fixed the unreliable syncing to accessories due to a bug between the UI and radio controller. Even this latest 10.0.14393.321 build there is no improvement. I know I'm not the only one as others have reported same on MS forums. I think WC even had a story on it. It affects the Lumia 830,930,1520,etc. What I found from testing yesterday,

    - Turn on bluetooth speaker (Nokia 360) and then turn on BT in Action Centre. Successfully connects to speaker and transmits audio.

    - If BT is then toggled off (single tap) from Action Centre (AC) there is a 10 second delay before the speaker chirps as it detects signal loss. It seems there is a lag between AC and the radio state. When toggled back on in AC it will not reconnect if I have not waited 10 seconds for the radio to actually go off, and then it can take ages to recover. The trick is to wait for definite off before turning BT back on in AC. I can get by just using AC to control BT status as long as I wait during the radio off delay.

    - So the best way to ensure the lag is avoided is to turn off BT via Settings | Devices | Bluetooth (slide to the left) theaccessory (Nokia speaker). Via settings the radio is turned off without delay (my speaker chirps instantly). Note - the AC status will fail to get updated and still show BT on (coloured tile) with the embedded text "Not connected".

    - To reconnect the speaker / accessory I must toggle off/on the BT tile in AC, sometimes twice, i.e. off/on/off/on. Otherwise if BT is re-enabled via Settings (slide to the right) no bluetooth devices are found and even saved pairings are not listed. Action Centre status is also unchanged indefinitely.

    I did the same testing with Alpine car stereo and same results. So to sum up, due to the radio on/off getting out of sync with the UI.

    I found BT sync for 930/1520 works on W10M if you,

    - ONLY use Settings menu for turning BT radio off.

    - ONLY use Action Centre (toggle off/on once or twice) for turning BT radio on.


    ​This is just a workaround. I wouldn't be surprised if it takes forever for MS to fix it as they tend to give very low priority to bugs that only affect their legacy 930/1520 models. I really hope I'm wrong. In a May posting Lumia 930, 735, & 540 phones may not be able to find Bluetooth LE - Microsoft Community MS described another BT bug only affecting legacy models and stated they would not pursue it for now.
    10-13-2016 05:13 PM
  2. EspHack's Avatar
    tons of people with that problem and also tons more without it, I personally have never had any problems with it, you can bet they know about it and other bugs like this one but its probably not worth fixing for the amount of users facing it and they lack the means to conduct proper testing(actual hardware in enough quantities), this is just an example of what coding without a QA team gets you as a result, all you can do is get another phone, yes really, even the exact same model, as far as we know the issue could be related to the IMEI ending in a 3

    my bet is this kind of bug on old devices, like hotspot not working with screen off and bt toggle malfunction, wont ever be fixed, if it gets fixed for you then thank luck for it, cause it was VERY unlikely microsoft had that intention while doing whatever change ended up fixing your problem
    10-13-2016 08:52 PM

Similar Threads

  1. How do I change my Facebook name on a Windows phone
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-13-2016, 04:38 PM
  2. Enpass Portable is now officially available to take your passwords on the go
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-13-2016, 04:00 PM
  3. Replies: 1
    Last Post: 10-13-2016, 02:31 PM
  4. Does Outlook for W10M have this feature?
    By Byrese in forum Windows 10 Mobile
    Replies: 0
    Last Post: 10-13-2016, 02:14 PM
LINK TO POST COPIED TO CLIPBOARD