05-03-2017 11:40 AM
84 123 ...
tools
  1. slyronit's Avatar
    The Windows 10 Mobile's camera app's reliability is horrible on the 950XL, from day 1. I take full 20MP photos and every once in a while, the photos get corrupted.

    Exactly what happens is, after taking a photo or series of photos, the camera app either crashes or gets stuck "Saving". This is not temporary, but permanent till a soft reset (have waited overnight on one occasion, after killing the camera app). The resulting images are saved with a .jpeg.thumb extension, have poor quality and are saved at a much lower resolution.

    I have lost many good moments because of this horrible bug.

    Of course I have hard reset many times, tried release preview builds, gone back to production, slow and fast ring builds, same problem.

    Switched to phone memory for photos, no joy. Same issues. Approximately 1/10 photos gets corrupted.

    The 1520 and 930 on similar builds don't have this problem, I guess it is a problem with the 950/959XL exclusively on full 20MP photos.

    Has anyone else seen this problem?
    10-29-2016 02:58 AM
  2. mtiede's Avatar
    I have something like 14,000+ pictures on my 950 xl. Then I took a LOT of pictures on a trip to Argentina, Peru, and Ecuador/Galapagos and had no problems. About to go to Iceland and you have scared me so I think I'll take a backup camera just in case. But I think the problem is not just the 950 xl. Maybe you are running one of the early release os versions? Good luck.
    AbhiWindows10 likes this.
    10-29-2016 03:23 AM
  3. slyronit's Avatar
    Thanks for replying. I am on the latest production release, with the latest camera app (white button), so that's not it.

    I have my aspect ratio set to 4:3 which allows me to use full 19MP of the sensor, which results in larger files.

    Can you use file explorer to see if there are any files ending with .jpeg.thumb in your folders? In the photos app, they show up as regular photos.
    AbhiWindows10 likes this.
    10-29-2016 03:26 AM
  4. Zulfigar's Avatar
    I'm not the type of guy to go photo happy, but I've had my 950 XL since the day it's come out and I haven't had the issue you describe, once, and what you're describing sounds like a hardware issue more than software. I'd start with a new SD card, first.
    10-29-2016 03:29 AM
  5. slyronit's Avatar
    Can't be hardware, as my phone has been replaced once. Can't be the SD card, because as I mentioned, I have tried switching to Phone memory.

    Do you use 19MP mode for photos? I have a feeling it is because of the 19MP mode. Can you check your camera roll folder in file explorer for any files ending with .thumb?
    Captain_Eric and DohMartel like this.
    10-29-2016 03:32 AM
  6. mtiede's Avatar
    I use 16x9 16 mp
    10-29-2016 03:53 AM
  7. mikepalma's Avatar
    This problem in my experience was unique to the 950xl. I had it replaced 3 times at the local MS store and the techs openly stated that they were getting tons of returns of 950xl's. After switching to the 640xl, I am extremely pleased. Everything, including the Camera and Photos apps, works better, with no frustrating "Saving" when trying to take pictures. Plus no cheap creaky case, overheating when playing games or charging - 950xl is a poor phone and definitely no flagship.
    libra89, Sedp23, CraigCole and 2 others like this.
    10-29-2016 04:25 AM
  8. IJPI's Avatar
    Can't be hardware, as my phone has been replaced once. Can't be the SD card, because as I mentioned, I have tried switching to Phone memory.

    Do you use 19MP mode for photos? I have a feeling it is because of the 19MP mode. Can you check your camera roll folder in file explorer for any files ending with .thumb?
    Got 950 single sim and snapping every picture with 19MP mode.Saving is sometimes veeeery slow , but I dont see any .thumb files on my camera roll folder.
    10-29-2016 04:51 AM
  9. Timbre70's Avatar
    Seems like their high end camera is giving problems. I have 1520 and 535, 535 takes better pictures in day time.
    10-29-2016 04:54 AM
  10. slyronit's Avatar
    I see that the problem starts once the phone goes a few days without a reboot. I just had this happen, rebooted, snapped a 100 photos at random, no problem. It will strike when least expected.
    10-29-2016 06:40 AM
  11. daimv's Avatar
    My 950 has never had this problem. Also remember that it is normal for the phone to take a few moments after taking a pic because it is processing the image before saving. If you take a picture and immediately preview it you will see it is processing, you can preview it but it will look a bit different after processing it. And of course it also depends on your selected options (hdr, flash etc).
    If you are taking a lot of pictures it is reasonable to think it will take longer.

    Also when you left it overnight, you said"after killing the app". Killing the app while processing could have been involved in the corruption, although I haven't tested it myself.
    10-29-2016 07:03 AM
  12. slyronit's Avatar
    I understand what you're saying. Processing time with 20MP pics is normal and I understand that. The problem is, the processing never ends. I have left it up to 30 mins with "Saving", it never finishes and all pics taken during that session end up corrupted (.thumb). I cannot leave it longer than that, because if it hasn't processed 6 photos in 30 mins, it never will and because my camera is useless during that time.

    I am surprised that no one else has this problem, which means there's a specific trigged to mine.
    z8er likes this.
    10-29-2016 07:25 AM
  13. daimv's Avatar
    Are you saving to internal disk or sd card? If you are using a card, how fast is it? Class 10? U1? U3? there is a chance the problem relies within it. It could also be faulty.
    10-29-2016 07:43 AM
  14. slyronit's Avatar
    It's a 64Gb Class 10 UHS-I card with a rated write speed of 95Mbps. I tried internal memory, no difference (I mentioned this in my post). I also formatted the card on the PC using a card reader and on the phone itself, no difference.
    10-29-2016 10:48 AM
  15. Daniel Gilbert M's Avatar
    I used to have the same problem on my 640XL. But after the recent camera update, it seems to be somewhat more stable.
    HDR is a hit and miss, post processing is still not at par with Lumia Camera.
    The image before the post processing is done, looks really really good.
    So it is definitely not hardware problem.
    Windows Camera has not yet reached the level where Lumia Camera was.
    libra89 likes this.
    10-29-2016 12:08 PM
  16. EspHack's Avatar
    have you seen corrupted pictures which have green-black horizontal lines? it happens with any phone, after taxing it up with multiple shots, all you can do is wait for updates
    10-29-2016 12:19 PM
  17. slyronit's Avatar
    No, no horizontal lines. The photos all look normal, till you try to send them via Whatsapp's image picker, where the images don't show up. That is when I realize the problem has occured, I rename the files to remove the .thumb extension and they show up. But going into properties, the res is very low and the file size is only a few hundred kbs.
    10-29-2016 12:30 PM
  18. slyronit's Avatar
    I did some more troubleshooting and it's definitely the camera's processing crashing midway (happens more frequently after a burst).

    When you take a picture, too processing is completed, the images show up as low res .jpeg.thumb files. I just did 10 pics in series and they showed up in file explorer as .jpeg.thumb. Sure enjoy, slowly all of them grew up into full jpegs, expect one, which remained .jpeg.thumb. No, I didn't open the file or anything to interrupt the processing, just saw the directory in file explorer. Now to figure out what causes processing to stop. Should be something typical, as I am seemingly the only one with this issue.

    http://imgur.com/rgHnjhY
    10-29-2016 12:42 PM
  19. Hamras Hamza's Avatar
    The Windows 10 Mobile's camera app's reliability is horrible on the 950XL, from day 1. I take full 20MP photos and every once in a while, the photos get corrupted.
    Has anyone else seen this problem?
    Have the same problem...
    10-29-2016 12:51 PM
  20. slyronit's Avatar
    Originally posted by Hamras Hamza
    Originally Posted by slyronit
    The Windows 10 Mobile's camera app's reliability is horrible on the 950XL, from day 1. I take full 20MP photos and every once in a while, the photos get corrupted.
    Has anyone else seen this problem?
    Have the same problem...
    Really? Which phone/OS version and do you also get .thumb files?
    10-29-2016 12:52 PM
  21. slyronit's Avatar
    Whoever genuinely has the same problem - Camera processing stops, leaving behind low res .jpeg.thumb files, please upvote

    feedback-hub:?contextid=132&feedbackid=c64f8dce-e450-4528-bd16-ae3f7dffce5c&form=2&src=2
    10-29-2016 12:57 PM
  22. slyronit's Avatar
    Whoever has the exact same problem -Camera processing crashes, leaving behind low-res .jpeg.thumb files, please upvote below

    feedback-hub:?contextid=132&feedbackid=c64f8dce-e450-4528-bd16-ae3f7dffce5c&form=2&src=2
    10-29-2016 12:58 PM
  23. sgtdisney's Avatar
    You are not alone. I have 2 640s, and am on the windows insider program and have the one of my 640s on the Release track and the other on the fast track. The one on the release track is my original T-mobile phone and I use it as my regular phone. It is doing exactly what you describe. I can take 2-5 pictures and then it will say saving. It will say saving for days if I left it. Eventually I have to shut the phone off and turn it back on again to get saving to go away. I cannot take any other pictures when it is on saving. When I open it back up the pictures are "there" the folder but no applications (FB/Instagram) can "see" them. The pictures are saved with a .thumb extention. This happens randomly as well and sometimes pictures I take before I get the Saving... issue are also saved with the .thumb extention.

    It is infuriating. I was away this week for my anniversary, and had to reboot the phone numerous times. I ended up having to use my work iPhone 5s to take pics because the 640 was so unreliable. Now, I know, I am on a release preview, so I can't complain too much, but I wanted windows 10 and T-mobile just walked away from it. I did try the same thing on my ATT version, unlocked 640 running on the fast track and this doesn't seem to be happening. It does say saving for like 10-15 seconds or more in HDR mode, but eventually it goes away and the pictures save without the .thumb extension. I ended up having to rename a bunch of photos in the file explorer and remove the .thumb extension to be able to share them with family.

    I was so ticked off, on the way home from our trip, I ended up buying a clearance Moto G at Best Buy just to start playing with it. I am not a fan of Android, but Microsoft is making it more and more difficult to be loyal to the brand, as much as I love the Windows interface on the phone. They aren't even going to sell Microsoft band anymore. So again, Windows folks are left high and dry. .
    10-30-2016 10:08 AM
  24. abausch's Avatar
    I am having a similar problem on my Icon (Production Ring). I took several pictures that never showed up in the photo app. They were both 'regular' and HDR. I used file manager too look for them, as well as back up on One Drive, and they were nowhere to be found.
    10-30-2016 10:51 AM
  25. EspHack's Avatar
    oh I see, it has happened to me but not recently, I'm not enthusiastic to use my camera as I used to be, probably because of all this, but if it helps I've seen something similar with video recordings, after hitting stop you get a file weighting 400kb or something like that, completely useless
    10-31-2016 02:06 AM
84 123 ...

Similar Threads

  1. Band App thinks Bluetooth is disabled
    By breaker119 in forum Microsoft Band & Band 2
    Replies: 1
    Last Post: 10-29-2016, 01:06 AM
  2. windows 10 anniversary upgrade.mobile , text doesn't talk.
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-28-2016, 10:21 PM
  3. Replies: 1
    Last Post: 10-28-2016, 10:15 PM
  4. Replies: 0
    Last Post: 10-28-2016, 03:11 PM
  5. Rocket Riot blasts its way back into the Windows Store
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-28-2016, 03:11 PM
LINK TO POST COPIED TO CLIPBOARD