1. Godson Arun Kumar's Avatar
    So I wanted to try out the recently launched asphalt xtreme only to find out that the game wouldn't download on my 640XL with latest production build and would always get stuck at a particular point, at the start itself. Tried changing download locations to Phone and also on SD card after a format. Nothing worked. On a side note decided to try download of another large app and others and unsurprisingly met the same result. Stuck with a phone that can't download my fav games even if everything else works fine. Any solution people? Or is it just W10M again.
    11-11-2016 10:34 PM
  2. abhishek singh21's Avatar
    are you downloading the game over mobile data or wifi? large apps ( 200mb+) could only be downloaded over wifi and not over mobile data.
    11-11-2016 10:42 PM
  3. abbeykabir's Avatar
    Same thing happened to me, I downloaded it over wifi but get stuck at the beginning so I soft reset my phone and behold ot started downloading only to complete downloading (almost 1GB) and shows error and then restart downloading again from the beginning. It is like that for asphalt xtreme, mc5, world of tank blitz. It's so frustrating.....
    11-13-2016 02:29 AM
  4. Godson Arun Kumar's Avatar
    Of course wifi only. Any way a clear message appears when downloading apps over Mobile data that the download requires wifi. This issue has been raised in the feedback hub by me and a couple others. But seems to be restricted to a few devices only. Sucks not being able to play your fav game on ur fav phone.
    11-13-2016 02:31 AM
  5. Rosebank's Avatar
    I have had this issue to on .448, even small apps, it would get so far then stop then >>see error details but no details to see, upon soft reset the download would be off like a shot and fully download within seconds. !? Data connection DL
    Godson Arun Kumar likes this.
    11-13-2016 11:38 AM
  6. slimchap's Avatar
    I only have this issue while downloading Asphalt Xtreme, it will get stuck at 2.15MB. I deleted my Asphalt 8 and downloaded it again which completed. I will again download Dungeon Hunter 5 soon to see if its just Asphalt Xtreme that faces this issue on my 640XL
    Godson Arun Kumar likes this.
    11-13-2016 11:47 AM
  7. abhishek singh21's Avatar
    Maybe a store bug, a future app update might sort it out.
    11-13-2016 09:28 PM
  8. hoss40am's Avatar
    I have the same thing in my phone, when I need to download any large games like asphalt extreme, it's send me error when I press to show it it's begin download again and send error, restart my phone and format my storage but don't make any thing,so please i need some help
    04-03-2017 09:01 AM

Similar Threads

  1. BItLocker locked after trying to update to Fast Ring!!
    By ShlurpnOnaPeach in forum Alcatel Idol 4S
    Replies: 8
    Last Post: 11-17-2016, 12:14 PM
  2. Replies: 10
    Last Post: 11-13-2016, 01:21 AM
  3. Unable to use System Restore in Windows 10
    By Oz090252 in forum Windows 10
    Replies: 1
    Last Post: 11-11-2016, 08:23 PM
  4. is there any way to connect Huawei Honor Band Zero to lumia devices ?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-11-2016, 06:09 PM
  5. How to flush Live Tile notifications during shutdown on Windows 10
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-11-2016, 02:11 PM
LINK TO POST COPIED TO CLIPBOARD