05-31-2017 02:23 PM
48 12
tools
  1. DavidGrogan's Avatar
    I had to reset it back to 8.1, using the reset tool you run from a PC, not the built-in reset, then I upgraded it to the last release build of Windows 10, worked fine, stay away from the preview builds. Hopefully it works ok when the Creators Update is finished.
    03-05-2017 12:02 PM
  2. Stergios Tozas's Avatar
    Same problem here, Lumia 950 build 15047. Several random app fail to launch. Problem only since build 15043. But still insists... Posted a question on answers.microsoft and they suggested rollback. I don't want to.
    03-06-2017 05:13 PM
  3. LordBoBCUP's Avatar
    I also have this same issue, Lumia 930, random apps (Symantec VIP, Spotify, Even the Microsoft Extras & Info menu). I have noticed the time on my device changing, randomly without having auto-sync on as my carrier doesn't support it. Turning it on makes no difference. I feel this issue has something to do with time & certificates on https/ssl style conenctions and because the time on the device is out, the certs are invalid. Not sure if anyone on this thread has noticed their clock being out of sync (sometimes by a year sometimes by a day). Its very odd that its happened across a large range of builds and across a large timespan, mine has only occurred in the past 2 days, where as some on this thread was nearly a year ago.
    03-07-2017 04:45 PM
  4. Master Z's Avatar
    I'm having this problem on my Lumia 1520 for the past week, too. Various apps that worked fine a week ago will just endlessly load, and then quit.

    Not sure which build I'm on, as it updated automatically and I can't check the info, because now Extras and Info won't open, either...
    03-09-2017 06:41 PM
  5. LordBoBCUP's Avatar
    After doing considerable digging, ive found a way to read the eventlogs of these phones and extract the issue stopping my applications from opening. Basically its a missing file.

    ExceptionType="System.IO.FileNotFoundException"
    ExceptionMessage="Could not load file or assembly 'System.Windows.RuntimeHost, Version=2.0.6.0, Culture=neutral,
    However, I haven't been able to establish exactly what file is missing and how it became missing. After reinstalling the applications they don't seem to provide it, its a built in .net file. I've also upgraded to the latest release 10.0.15051 with no joy either. Has anyone come across this before and found the fix for it? I have managed to get myself full access to the filesystem, so if I can get the file I can put it in its place, I just need to work out what file and where to put it.
    03-09-2017 08:12 PM
  6. DavidGrogan's Avatar
    Interesting. System.Windows.RuntimeHost is part of Silverlight, which the older Windows Phone 7/8 apps were written in. Win 10 apps don't use it at all, which might be why this problem only appears with certain apps (assuming it's the same problem). I would have thought WhatsApp was using the new UWP model though, and that was one of the apps I was having the problem with. I'm don't know how you'd go about reinstalling Silverlight on the phone though. I found this recent thread about it on the MS development forums: https://social.msdn.microsoft.com/Fo...rlightwinphone
    03-10-2017 02:32 AM
  7. HoosierDaddy's Avatar
    After doing considerable digging, ive found a way to read the eventlogs of these phones
    Can you post where you found out how to do that? It would be good to have that ability.
    03-10-2017 05:47 AM
  8. Jan ER's Avatar
    I`ve been facing this issue for the last 3-4 insider builds, and was finally able to solve it today.

    I used the Windows Device Recovery Tool to reset my phone to Windows Mobile 10 1511. After that I installed one of the apps I knew haven`t been working for a long time, and it did in fact work. I then did an upgrade to the latest build (10.0.14393.693) and the problematic apps still worked fine.

    Will this tool work on phones running Insider Preview builds?
    Yes. When you use this tool on a phone that's running a preview build, it will reinstall the latest version of Windows approved for your phone by its manufacturer.
    Not sure if I`m ever going to try preview builds on my day-to-day device again :)
    03-10-2017 07:57 AM
  9. LordBoBCUP's Avatar
    There are a number of ways, this isn't the exact way I did it but a number of the steps are the same.

    https://msdn.microsoft.com/en-us/win...-windows-phone

    I have already posted on the dev hub for win10m to suggest they include something similar to desktop with scannow /sfc which will replace missing system files etc nicely.

    The apps I am experiencing issues with are ones that are not well maintained and probably just patched to work on win10m as there isn't a huge development base for it. Spotify, Nextgen Reader, Symantec VIP Access etc. It is very interesting that Extras & Info doesn't load (with the same missing file) which suggests it hasn't been upgraded. Naughty Microsoft.

    I am really trying to avoid hard resetting my phone, and for an OS this is something that should be handled without having to completely wipe the phone.
    03-10-2017 04:37 PM
  10. Stergios Tozas's Avatar
    Build 15055 still the same problem Frustrating although a preview build. Someone in MS must fix it.
    03-11-2017 03:06 AM
  11. LordBoBCUP's Avatar
    I have reported this on the Feedback Hub, perhaps upvoting it may help? I cant get a direct link using Hub on my phone, but its titled Apps broken missing system file.
    03-12-2017 10:54 PM
  12. Stergios Tozas's Avatar
    In answers.microsoft many users with the same problem. Probably someone at ms will give a solution. The truth is out there... :-)
    03-13-2017 04:13 AM
  13. Stergios Tozas's Avatar
    I have noticed that many apps built for "windows phone 8 or higher" fail to launch. But not all of them. For example Viber, messenger or instagram run ok. Apps that are described in Windows store as Windows 10 version 10240.0 or higher do not have any problem.
    03-20-2017 05:53 AM
  14. DariaPhone's Avatar
    Hello everyone! I am using a Lumia 950 XL, build 10.0.14393.953 and for a couple of days now my phone is basically useless since WhatsApp, Telegram, most Games, 6tag, photo editors and and and do not load.
    I do not know what you mean by "insider preview" or "fast/slow ring", I simply updated my phone as usual and roughly ten hours later the apps stopped working.
    Is there any solution for it that I as a non-understander of how my phone actually works can handle?
    I already tried restart, soft-reset and reinstalling all non-working apps.
    03-20-2017 10:31 AM
  15. LordBoBCUP's Avatar
    Here is the link to my feedback hub post. Please upvote it, comment on it etc. The more responses we get to it the more likely it is to be seen sooner rather than later.

    https://aka.ms/wz95eh
    03-20-2017 06:53 PM
  16. DariaPhone's Avatar
    Unfortunately I can't open/access/read/upvote/comment on your Feedback-Hub-Post since I can only see the German Feedback-Hub. I already upvoted and commented on all posts related to this problem in the German Feedback-Hub but so far nothing has happened.
    03-21-2017 08:07 AM
  17. Stergios Tozas's Avatar
    Just downloaded insider build 15063 but still not fixed. Same apps fail to open. Disappointing.
    03-22-2017 08:27 AM
  18. Stergios Tozas's Avatar
    Problem still exists. Build 15063. Nothing worked for my Lumia 950. Neither backup (truly I don't want to restore from backup) or apps and features through advanced options and reset or using third party tiles. But I have noticed that apps that fail to load don't show Advanced Options in apps and features so I can't reset them. Strange. All the other apps do show it...
    03-24-2017 11:04 AM
  19. Edski303's Avatar
    I have the same problem on my 950 XL since this morning. Before I went to sleep everything was working fine, when I woke up lots of apps won't load. I don't know what build I am on since the page where the info is on won't open either. The last update was a tuesday a few weeks ago though. I'm on production preview.
    The last update I had was Skype to 11.16.595.0 yesterday and today Groove to 10.17042.13912.0, Windows Camera to 2017.517.11.0 and Store to 11705.1000.78.0.
    I've tried a few soft resets, but that wouldn't help. Since I read that hard reset doesn't help either I'm reluctant what to do next. What have you all done since your apps stopped working? Bought an iDroid and tossed your Lumia out of the window?

    Update: I left my phone alone for a few hours and everything is working again!
    Last edited by Edski303; 05-25-2017 at 06:02 AM. Reason: update
    05-25-2017 03:58 AM
  20. J Dubbs's Avatar
    Windows phone is dying.... you guys are feeling the pain of the slow death as less and less apps are working.

    That's why I left.... I hated to but I had to :-(
    I check back here occasionally hoping to see a turnaround. I don't think that's going to be happening.
    =-O :-( :'(
    05-25-2017 06:39 AM
  21. PerfectReign's Avatar
    I had that happen

    https://aka.ms/Afxj8s

    Seems to be better.

    Sent from mTalk
    05-25-2017 11:31 PM
  22. LordBoBCUP's Avatar
    Hi J Dubbs,

    I have discovered over my time battling with this issue that Groove is the application that is causing the issue. I found that after 1 update about 1 month ago to Groove that everything worked again. I haven't updated groove since then and I dont intend on starting any time soon. Still haven't got a reply from Microsoft on my feedback hub entry but my recommendation is to stay away from Groove on ANY version of win10m
    05-27-2017 08:09 PM
  23. Beef_Pho's Avatar
    I had same problem & went back to 8.1.

    So many updates for 10 but every one seemed to make it worse and more buggy, Microsoft finally got Windows Phone right with 8.1 and then almost immediately abandoned it.

    Lack of apps have forced me back to Android but my Lumia on 8.1 is a decent back-up.
    05-31-2017 02:23 PM
48 12

Similar Threads

  1. My desktop I my laptop wont stop refreshing
    By Windows Central Question in forum Ask a Question
    Replies: 9
    Last Post: 01-02-2017, 11:07 PM
  2. Gears of War 4 drops to just $25 at Best Buy
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-30-2016, 01:39 PM
  3. How to change priority of notifications in Windows 10
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-30-2016, 06:11 AM
LINK TO POST COPIED TO CLIPBOARD