1. seVen_S's Avatar
    I have a lumia 640 that I don't use much. I used to plug it in like every 3 days. Within the last few weeks the battery hasn't lasted a full 24 hours. I give it a full charge and overnight with no use at all the battery will be down to 50%. I have reset the phone twice and tried 2 new batteries. Where the battery used to drain a little over 1% an hour it now drains about 5% or more. I turned off ever background app and that doesn't help either.

    I'm just wondering if anyone else has had this problem or knows if a phone can just start to malfunction. I have no clue how to tell if the processor is running full blast or something like that could be happening.

    Any info would be great,
    Thanks
    06-13-2017 06:21 PM
  2. Hyrokumata's Avatar
    Well, since you already did a reset and disabled the background apps, may I ask you which OS version are you running? Also, the batteries aren't fake? I don't know where did you bought them, but unfortunately there's a lot of fake batteries selling online which malfunction.
    libra89 likes this.
    06-14-2017 05:25 AM
  3. Hyrokumata's Avatar
    I have no clue how to tell if the processor is running full blast or something like that could be happening.

    Any info would be great,
    Thanks
    I am not aware of any app that shows CPU usage, but there's Device Portal. It's designed for developers but might help you diagnose your problem. It's has performance charts for CPU and GPU, and I think it lists all the processes and how much CPU time each one is consuming. Might be helpful.
    See how to enable and use in Microsoft documentation
    realwarder likes this.
    06-14-2017 05:35 AM
  4. seVen_S's Avatar
    Thank you for the information Hyrokumata. I'll be looking into the Device Portal. I just did an update and it has OS 10.0.15063.414 - I'm not sure what OS I was running before the update. I'm hoping this update might fix my problem. The batteries were bought from amazon and ebay with the windows imprint on them and look exactly like my battery that came with the phone, although I'm sure they could still be fake.

    thanks again
    06-14-2017 10:46 AM
  5. Hyrokumata's Avatar
    Hope you solve your problem :)
    06-15-2017 08:12 AM
  6. realwarder's Avatar
    It could be an OS issue, or possibly a hardware fault that has occurred (less likely), or bad batteries (e.g. fake ones).

    Remember too that it can take a few days after a reset and OS upgrade for battery usage to settle down completely.
    06-15-2017 10:34 AM
  7. seVen_S's Avatar
    Solved my problem, but it's a weird one. I noticed my phone was constantly searching for my family mobile network, because it couldn't keep a stable connection. I took it out of LTE mode and my battery life is pretty much back to normal. I'm not sure why it started happening now, because it was working fine in LTE for over a year.
    06-24-2017 11:03 AM

Similar Threads

  1. Lumia 950 random reboots - Unorthodox Solution
    By Luis Aramini in forum Microsoft Lumia 950
    Replies: 24
    Last Post: 09-14-2018, 12:30 AM
  2. Is win 10 good on lumia 640 xl?
    By Anomaly18 in forum Ask a Question
    Replies: 2
    Last Post: 06-13-2017, 08:50 PM
  3. nokia lumia 730 charge port not working
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 06-13-2017, 11:39 AM
  4. Replies: 2
    Last Post: 06-13-2017, 10:17 AM
  5. My lumia 640xl not starting up
    By Arif Banda in forum Windows 10 Mobile
    Replies: 1
    Last Post: 06-12-2017, 07:38 PM
LINK TO POST COPIED TO CLIPBOARD