1. MarianDE's Avatar
    I have recently updated my Lumia 950 Dual Sim to 15254.1. Since the update I am unable to start my edge browser. I already tried to soft reset my device (restart and forced restart).
    Any idea besides factory reset or device recovery tool?

    I also tried to reset the app edge but this option is not available.
    10-25-2017 08:02 AM
  2. charlatan1978's Avatar
    Hi, the only other suggestion I can think of is to check the store for updates. There maybe an update for Edge that fixes the app. Other than that it would be a hard reset or device recovery tool.
    10-25-2017 08:29 AM
  3. MarianDE's Avatar
    Thanks for your reply. I already checked for updates without any success. :(
    10-25-2017 08:46 AM

Similar Threads

  1. Replies: 0
    Last Post: 10-25-2017, 07:47 AM
  2. Fans of Faster Than Light need to keep an eye on Shortest Trip to Earth
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-25-2017, 07:10 AM
  3. How to allow updates over metered connections on Windows 10 Fall Creators Update
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-25-2017, 06:10 AM
  4. Man uses real Lamborghini to play Forza Motorsport 7
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-25-2017, 05:40 AM
  5. Popular MMORPG Skyforge is coming to Xbox One
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-25-2017, 05:40 AM
LINK TO POST COPIED TO CLIPBOARD