The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. anubhav756's Avatar
    I have a Sony Vaio S series (8GB RAM, i7, 2.9Ghz), with win10 tech prev.

    When I launch a game (like assassin's creed 4), the game runs very smoothly for, say, the first 50 - 60 seconds, and then the frame rate drops to almost half.

    Is it because of the Windows 10 tech prev?
    ven07 likes this.
    05-09-2015 11:21 AM
  2. ven07's Avatar
    Yupp, I can confirm that.. I changed my game to run under w7 compatibility, but haven't played yet, so not sure if that had any effect at all
    Last edited by ven07; 05-12-2015 at 05:49 AM.
    Laura Knotek likes this.
    05-09-2015 11:32 AM
  3. nmercy's Avatar
    If it ran fine on non-Win10 tech prev then it's because of the Win10 tech prev... if it did not run well before then it is not because of the Win10 tech prev.

    That being said, a lot of drivers, especially for notebooks, haven't been made/optimized for Win10 yet. Performance on games should get better as drivers are made and optimized for Win10.
    ven07 likes this.
    05-11-2015 03:59 PM
  4. David Feifer's Avatar
    This..
    That being said, a lot of drivers, especially for notebooks, haven't been made/optimized for Win10 yet. Performance on games should get better as drivers are made and optimized for Win10.
    I have a home system with name brand common components and I have encountered the opposite, though, my graphics driver tends to crash and recover right now. Of course any drivers right now ARE beta drivers.
    ven07 likes this.
    05-11-2015 06:46 PM
  5. CJ Thunder's Avatar
    It could also be the updated Xbox app that can now do gameplay recordings.
    ven07 likes this.
    05-11-2015 06:55 PM
  6. Kyle Stilkey's Avatar
    It could also be the updated Xbox app that can now do gameplay recordings.
    Possibly this, there are lots to things to consider. It could be a driver issue, software conflict or Win 10. For me and a lot of test systems on Win 10 have been way better in performance. Again its still in work so every system will be different.
    ven07 likes this.
    05-11-2015 07:00 PM
  7. ven07's Avatar
    After changing my compatibility settings to w7 for the game, my fps went up to 20-24, still not great. however this was an improvement from the 15-17 I was hitting previously :/

    (on w7 itself I had 30-35)
    05-12-2015 05:51 AM
  8. freak0's Avatar
    same thing happened to me today after updating to insider preview 10565 ... gta v starts at 35 fps stays there for a minute and then it is horrible as low as 10 fps while on final build 10240 it ran just fine close to 40 fps
    10-14-2015 01:43 PM

Similar Threads

  1. Replies: 3
    Last Post: 05-12-2015, 01:03 PM
  2. Old person having a heck of a time with this win8.1 tablet
    By birdie_in_texas in forum HP Stream 7
    Replies: 5
    Last Post: 05-11-2015, 04:17 PM
  3. Why can't I receive pictures on my Lumia 920?
    By Windows Central Question in forum Nokia Lumia 920
    Replies: 3
    Last Post: 05-09-2015, 11:47 AM
  4. Why is my PC store displaying an error code :0x80010108?
    By Windows Central Question in forum Applications
    Replies: 0
    Last Post: 05-09-2015, 10:33 AM
  5. Tiny Troopers for Windows 8.1 adds zombie levels in latest update
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-09-2015, 10:00 AM
LINK TO POST COPIED TO CLIPBOARD