1. eddieDOTexe's Avatar
    This site just does not work on Edge for me. I'll be typing in the middle of a sentence and all of a sudden my cursor will revert to the left end of the text box and type backwards. Try and fix it? TOO BAD the tab crashes and has to recover.

    IM CRYING OG MI NIAGA SEOG TI EREHT DOG YM HOhouoThen you have to type y​
    07-16-2015 05:32 PM
  2. jdballard's Avatar
    Yes, yes I do. Annoying.
    07-16-2015 07:31 PM
  3. Lumious's Avatar
    Yes i have the same exact problem. Not only that but the website is slow as hell with Edge. Along with every other site i visit seems to be slower than Internet explorer. Edge is awful with this site in particular it is so incredibly slow it is unusable, i can barely even type in the reply area. Internet Explorer is better than Edge at least and that is still slow. The only browser i found that is bearable on this site is Chrome. I find it funny that the tests claim that Edge is beating all browsers for speed but general usage from popular websites would indicate otherwise.
    07-16-2015 11:37 PM
  4. jdballard's Avatar
    Yes i have the same exact problem. Not only that but the website is slow as hell with Edge. Along with every other site i visit seems to be slower than Internet explorer.
    Interesting. Maybe it's my perception but I find Edge faster than IE (except on this site, which is ironic that it's windowscentral.com). Read something the other day that Edge is beating Chrome in several benchmark tests. Didn't read all the details, though.
    Lumious likes this.
    07-17-2015 07:46 PM
  5. Asskickulater's Avatar
    Well, the thing I've noticed with Edge, on modern/beefy systems, edge is incredibly fast, in most cases faster than chrome, on not so good systems, Edge takes a massive performance hit and becomes a sluggish mess.

    I use Edge on my main system which is a high end gaming pc, edge easily runs faster than chrome and firefox, however, I have a dinosaur of a laptop that was given to me, it came with vista, but apparently it was XP hardware (yea dell, your one of the reasons why vista has such a bad name) but Edge is completely un usable on it..
    07-18-2015 05:24 AM

Similar Threads

  1. Anyone noticed that RAW shooting has disappeared in the latest build?
    By jojoe42 in forum Windows 10 Mobile Insider Preview
    Replies: 1
    Last Post: 07-16-2015, 04:48 PM
  2. WP apps working on W10 10240 (well, one is)
    By iainberryman in forum Windows 10 Insider Preview
    Replies: 0
    Last Post: 07-16-2015, 04:09 PM
  3. I have forgotten my lumia 535 password. What should I do?
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 07-16-2015, 03:45 PM
  4. Replies: 0
    Last Post: 07-16-2015, 03:37 PM
  5. Get Windows Central headlines on your Microsoft Band with our web tile!
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-16-2015, 03:20 PM
LINK TO POST COPIED TO CLIPBOARD