1. LCGrzy's Avatar
    I have been using Insider's Previews starting with some of the early builds, and I have been using it regularly on almost all of my machines (SP3, ThinkPad 8, Yoga Tablet 2 10", and a 2nd gen ThinkPad Helix) since build 158. When 10240 came out, I decided to install it on my all-in-one Lenovo IdeaCentre B540 with a quad-core i5-3330S, 8gb of RAM, and an Nvidia GeForce 615 graphics card. I installed build 162 and then upgraded to 240. For some strange reason the performance is terrible on build 240. I can roll it back to 162 and it works great, but I can barely open apps in 240 (even with today's "security" update) and overall navigation is unbelievable slow.

    Any idea why this would be the case, aside from the fact that were still using unfinished software?
    07-20-2015 02:05 PM
  2. Ed Boland's Avatar
    Have you updated to the latest GeForce drivers?
    07-20-2015 02:20 PM
  3. LCGrzy's Avatar
    Yep, when I checked NVidia's website, it said the driver I had was the most up to date.
    07-20-2015 02:52 PM
  4. Japser's Avatar
    Sounds like one of these things that is fixed by a clean install :/
    07-20-2015 04:17 PM
  5. LCGrzy's Avatar
    I plan on doing a fresh install once I get an official release of Windows 10, but I was hoping to be able to use the latest build until then.

    The weird thing is that performance is fine under 162, but problematic under 240. I can, and have rolled back to 162 and the performance is great. I have other issues with 162 (OneDrive does not work, apps don't open, etc.), otherwise I would stay on it.
    07-20-2015 05:23 PM
  6. Japser's Avatar
    Have you tried installing 240 a second time? Perhaps the problem will be gone when you try again...
    07-20-2015 06:28 PM
  7. LCGrzy's Avatar
    Yes, that is where I am now. I started at 162, updated to 240 had performance issues, rolled-back to 162 and it worked fine performance-wise, and just today I updated it back to 240 today to see if it was still an issue and again the performance is really bad.
    07-20-2015 07:07 PM
  8. Japser's Avatar
    That's very strange, and certainly very annoying. Guess you'll have to wait till July 29 :/
    07-21-2015 04:23 AM

Similar Threads

  1. Your Experience with W10 on Tablets?
    By Muessig in forum General Desktop, Laptop & Tablet Discussion
    Replies: 104
    Last Post: 07-30-2018, 09:29 AM
  2. How can I fix Cortana not running on Windows 10 build 10240?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-21-2015, 12:43 AM
  3. Unable to login with Buckstar
    By rgv521 in forum Applications
    Replies: 5
    Last Post: 07-20-2015, 04:14 PM
  4. Record more than just games with the Windows 10 Game DVR
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-20-2015, 11:42 AM
  5. Xbox One 1TB Madden NFL 16 bundle comes with year of EA Access on Aug. 18
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-20-2015, 11:20 AM
LINK TO POST COPIED TO CLIPBOARD