1. waeras's Avatar
    I have a Push2TV adapter connected to my tv. Casting to it works from my Surface Pro with Windows 8.1 Pro, and it works from both the Lumia 930 and the Android phone I have here atm.

    The laptop (HP Pavilion 13-a087no x360) however has huge problems since updating to Windows 10 (it worked well when it was still on 8.1). I can find it, I can connect to it every third try. I've gotten one bluescreen when trying to connect, the other times it just fails and I have to try again.
    On the tries when it actually succeeds the connection is lost after approximately 60-120 seconds.

    I have the latest wireless drivers, and the latest graphics drivers. I've even tried a factory reset on the Push2TV even though it works with every non-Windows10-device I have.

    Does anyone have a solution, or should I just go and grab a Chromecast? (I mainly use it for Netflix & YouTube anyways.)
    07-30-2015 07:28 AM
  2. Patric.Z's Avatar
    I have the same problem with my SP3, which never worked since updated to W10. It works fine with another SP3 with 8.1 and Lumia 1520 with WM10.
    07-31-2015 04:49 PM
  3. Patric.Z's Avatar
    BTW, my SP3 with W10 works fine with Xbox One miracast (but it does seem lag a bit more than 8.1), so I suspect it's a firmware issue with PTV3000, if so, I doubt we will get any more firmware update from Netgear as PTV3000 is marked as end of life on their website.
    07-31-2015 04:54 PM
  4. Larry Bartz's Avatar
    Had the same problem..... down load the Intel WiDi update tool. This worked like a charm....my PTV3000 is working with Windows 10!!!!
    08-02-2015 06:59 PM
  5. Patric.Z's Avatar
    Hi Larry, that's good news to hear. I tried the Intel WiDi update tool on my SP3 with W10, but it says no compatible devices found. Do you mind if I ask what devices you are using? Thank you!
    08-03-2015 05:02 PM
  6. Larry Bartz's Avatar
    Its an Asus notebook i5 processor, Intel(R) 7 Series Chipset Family SATA AHCI Controller, Intel(R) HD Graphics 4000,Intel(R) Centrino(R) Wireless-N 2230....I am running the PTV3000 through a sony STR-DN850 surround system to a Junkie Insignia 55" tv. Have you tried to delete the PT3000 in the device manager and trying a reboot? Then re-installing? I think I got lucky on this one?
    08-03-2015 07:39 PM
  7. Patric.Z's Avatar
    Thanks for the details! I did, no luck. I even bought the MS Miracast Adapter and it didn't work neither so I think it's the W10 driver issue. I think SP3 uses a different wireless module than your notebook, it could be the problem.
    08-04-2015 01:33 PM
  8. Patric.Z's Avatar
    Update: on my SP3, I rollback my display adapter driver and it works with PTV3000 now...
    08-05-2015 11:46 AM
  9. Larry Bartz's Avatar
    Good news and good thinking!!! Enjoy!!!
    08-05-2015 07:12 PM
  10. George Hsu's Avatar
    for windows 10, widi manual is no longer available. it is thru settings, search wirless devices.
    and here is one thing i can't explain: both chrome cast and ptv don't work on HDMI 1.
    They work well on HDMI 3.
    08-13-2015 01:11 PM
  11. Larrysdime's Avatar
    I am having an issue with getting any of my Wired or wireless Display devices to fit properly on my Big Screen ever since I updated to W10. I have a Screen Beam Mini which worked well with W8.1. After the W10 Update I had display screen resolution problems. I then Purchased a Netgear PTV3000 and it made no difference.
    It definitely seems related to the W10 Update. Any suggestions on how to get my PTV3000 to project properly on my Big Screen?
    08-13-2015 09:31 PM
  12. Steven Rabinowitz's Avatar
    Update: on my SP3, I rollback my display adapter driver and it works with PTV3000 now...
    How did you rollback your display adapter driver?
    12-31-2015 04:45 PM
  13. Patric.Z's Avatar
    In device manager, there should be an option to roll back display driver - but right now PTV3000 works perfectly with surface pro 3 with latest driver (whatever the driver windows update updated to) in windows 10 for me.
    01-02-2016 03:38 AM
  14. Mic-Re B's Avatar
    Hi, this is an old thread but I have the same problem: I can't connect my Laptop (Acer Aspire Timeline X with Intel HD Graphics 3000) with an Push2 TV 3000 since the update to Windows 10, but it worked licke charm under win 8.1!


    For all of you who still hope that its a issue on the push3 TV firmware update - its not!
    You, maybe have a LapTop device with Intel HD 3000 mobile graphic card! That worked under Win 8.1!

    But take a look here: look here: System Requirements for Intel Wireless Display (Intel WiDi)


    Intel removed the HD graphics 3000 mobile cards from its WIDI compatibility list of Windows 10!
    Its not supported anymore!

    Therefor, no working drivers, no magic trick with Intel WiDi update tool.... no cure!

    THANKS INTEL!
    06-16-2016 12:40 PM
  15. Patric.Z's Avatar
    The new project to PC feature in Redstone could be your solution if you have a PC connected to the TV. It seems it works with any PC, even the receiver PC doesn't support Miracast. It works better than any Miracast receiver I have tried with much lower delay.
    07-02-2016 02:11 AM

Similar Threads

  1. Why won't Outlook 2013 send emails after the Windows 10 upgrade?
    By Windows Central Question in forum Windows 10
    Replies: 104
    Last Post: 09-11-2016, 12:17 AM
  2. Windows 10 Product Key observations
    By kingbobyjr in forum Windows 10
    Replies: 4
    Last Post: 09-01-2015, 09:19 AM
  3. Why isn't Windows 10 recognizing my BenQ HD Monitor?
    By Windows Central Question in forum Windows 10
    Replies: 2
    Last Post: 08-13-2015, 06:22 AM
  4. What happened to my games when I upgraded from Windows 7?
    By Windows Central Question in forum Games
    Replies: 1
    Last Post: 07-30-2015, 07:31 AM
  5. Roboto - a challenging platformer game for Windows and Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-30-2015, 07:20 AM
LINK TO POST COPIED TO CLIPBOARD