1. Windows Central Question's Avatar
    Pages stop after 1/2 second and show above. Chrome works fine
    07-30-2015 07:14 PM
  2. FairfaxCA's Avatar
    I'm having the same problem. I just upgraded my laptop from Windows 8.1 yesterday. Chrome worked well. I had Microsoft call me; the tech said to use IE11 and maybe Edge will fix itself. Isn't that wonderful. Maybe I'll just continue using Chrome as the default with the Bing2Google extension so I won't need to deal with Bing.
    08-01-2015 01:55 PM
  3. iryblue's Avatar
    same problem here, but the important point is how can this be fix.
    08-01-2015 10:01 PM
  4. johnson_patrickw's Avatar
    Chrome uses google by default, why would you bother with an extension?
    08-01-2015 10:08 PM
  5. FairfaxCA's Avatar
    Chrome uses google by default, why would you bother with an extension?
    If you use the search box in the task bar it will open Bing even if you have Chrome set as the default browser. I haven’t found a way to make Google the default search, there may not be one. MS wants the add money for themselves.
    08-02-2015 09:41 AM
  6. FairfaxCA's Avatar
    same problem here, but the important point is how can this be fix.
    When I contacted MS support the tech said to use IE11 and maybe Edge will fix itself. He may have meant with an upcoming update. When I had Cortana activated she(?) and the search box would time out in a couple of seconds so I couldn’t use either. Maybe that is also part of the page loading problem. I’ll try to contact MS support again. Maybe everyone with this problem should contact them, the squeaky wheel gets the grease.
    08-02-2015 09:50 AM
  7. knudarvitsen's Avatar
    If you use the search box in the task bar it will open Bing even if you have Chrome set as the default browser. I haven’t found a way to make Google the default search, there may not be one. MS wants the add money for themselves.
    Go to google.com with Edge, open settings and advanced settings, click "change search engine". you should have Google as an option there.
    But I get the "This page is having a problem loading" when using Edge's search box to search with Google as well...
    10-11-2016 12:12 PM

Similar Threads

  1. Doing a clean install of Windows 10 on a Surface 3
    By Bataar in forum Microsoft Surface 3
    Replies: 43
    Last Post: 01-20-2016, 08:52 AM
  2. Windows 10 install, where are my word and excel files?
    By Windows Central Question in forum Windows 10
    Replies: 1
    Last Post: 07-30-2015, 10:20 PM
  3. AMD GPU issues in Windows 10
    By indospot in forum Windows 10
    Replies: 2
    Last Post: 07-30-2015, 07:25 PM
  4. Why is youtube crashing after upgrading to Win10?
    By Laurel Harper in forum Windows 10
    Replies: 0
    Last Post: 07-30-2015, 07:08 PM
  5. Replies: 0
    Last Post: 07-30-2015, 06:43 PM
LINK TO POST COPIED TO CLIPBOARD