1. Windows Central Question's Avatar
    So I'm having trouble with NumLock defaulting on the Logon screen in Windows 10. I have a Dell Inspiron 15R.

    I tried the following;

    1. On the Logon screen, press the NumLock key on the keyboard to turn it on. On the bottom right corner of the Login screen I clicked the power button to reboot Windows.
    2. using Registry tweak, InitialKeyboardIndicators under HKEY_USERS\.DEFAULT\Control Panel\Keyboard using code(s) 2147483650 then tried 80000002 as well as just 2

    Before installing Win10 it worked as desired (I did #2 above using code "2"). Anyone find a solution?
    08-03-2015 06:47 PM
  2. igorhk's Avatar
    I did the registry tweak, changed the value to 80000002 and it works.
    08-03-2015 07:06 PM
  3. GermanBlackEagle's Avatar
    didnt work!
    pressing Num lock key works works every restart too, but this didnt work after windows 10 shut down!
    08-04-2015 04:12 AM
  4. Mauricio Rick's Avatar
    If you use only number 2, it should work, but only after you put your password. I'm trying to find a way to turn on to use for the password.
    08-04-2015 07:13 AM
  5. jjdeadhead's Avatar
    OK I found an old solution (Windows 8.1) but after applying, it works in Windows 10 as well, although there were "different" paths to get there. So try this (for it to take effect you will need to restart):

    1. First do #2 above - Press Win+R keys on your keyboard, the "Run" dialog will appear. Type regedit without quotes and press Enter. under HKEY_USERS\.DEFAULT\Control Panel\Keyboard select "InitialKeyboardIndicators" in "Value data" type in 2 ; then OK to close.

    2. Go To "Control Panel"
    click on "System and Security"
    click "Power Options"
    on the left panel select "Choose what the power button does"
    in the top of this screen first click " Change settings that are currently unavailable" then scroll down and under the last section "Shutdown settings" unclick "Turn on fast startup (recommended)" click "save" and the restart your computer.

    Mine works now, WAHOO!!!! (btw I posted this at Microsoft also, thanks Microsoft for the help; he said facetiously)
    08-04-2015 10:25 AM
  6. John Steel5's Avatar
    I tried all of the above, changing the HKEY_CURRENT_USER\Control Panel\Keyboard
    InitialKeyboardindicators REG_SZ registry entry to to 80000002, etc, but it did not work and the registry value was changed back to 2 every time. The num lock key light comes on twice and then goes off again as the computer boots up. It worked fine in windows 8.1.
    08-04-2015 03:57 PM

Similar Threads

  1. Replies: 86
    Last Post: 11-27-2017, 05:02 AM
  2. Replies: 1
    Last Post: 08-08-2015, 01:55 AM
  3. What's better: Clean install or upgrade to Windows 10?
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-03-2015, 06:30 PM
  4. Replies: 0
    Last Post: 08-03-2015, 06:24 PM
  5. Why can't I install Windows 10?
    By Windows Central Question in forum Windows 10
    Replies: 0
    Last Post: 08-03-2015, 05:54 PM
LINK TO POST COPIED TO CLIPBOARD