The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. Windows Central Question's Avatar
    Right click on Desktop in windows 10 is very slow, what is the solution?
    glkkggufjhjhg likes this.
    08-03-2015 11:33 PM
  2. RumoredNow's Avatar
    I had issues with that earlier...

    Reboot. Check for updates and apply any.

    Reboot seemed to solve mine. But I could not check updates before the reboot. The page never finished loading on Update Check.
    abhishek singh21 likes this.
    08-04-2015 12:56 AM
  3. sdstc's Avatar
    I have same problem. sometimes it make me angry.
    its totally updated.
    have i7 and 8gb ram and i shocked
    08-06-2015 12:47 PM
  4. aldridhl's Avatar
    I also have this problem after upgrading. There must be a fix for this.
    08-09-2015 07:12 PM
  5. aldridhl's Avatar
    Found the solution-
    Get the ShellExView program (link in video) , Options -> Filter by Extension Type -> Highlight "Context Menu" -> Disable "NVIDIA CPL Context Menu Extension" reboot/restart windows explorer, and right click on desktop works.
    The video shows it all.
    08-09-2015 07:39 PM
  6. Thrill Dawgg's Avatar
    Why make things complicated and install other software. Simply open NVIDIA Control Panel, and in the menu bar click Desktop, uncheck Add Desktop Context Menu
    TusharG likes this.
    09-21-2015 08:42 AM
  7. jahf's Avatar
    FYI ... I have both Nvidia and Intel HD 4000 graphics running on my system. It definitely wasn't the Nvidia driver. Turns out I had an Intel driver updated today. That was the culprit for me (same concept, different driver).

    A quick and easy fix, verifying it worked for me, is posted here:

    (note: I am new, only registered here to post this note as it came up as a top result in Google searches on this problem, so re-assemble the following into a link and/or someone please re-post a working link)

    www
    tenforums
    com
    /
    tutorials
    /
    6088-intel-hd-graphics-desktop-context-menu-add-remove-windows
    .
    html
    10-08-2015 12:23 AM
  8. Steve prater's Avatar
    Perfect, Thank you!
    11-13-2015 12:44 PM
  9. Gary Yanover's Avatar
    Could you tell me how to solve this problem with a ATI Mobiity Radeon HD 4200 card?
    cannot find the settings any where on my laptop.

    Thanks
    11-25-2015 09:46 AM
  10. highlandmikey's Avatar
    I solved this after quite some hours of temper. It was simple in the end.
    Try this:
    1. Download CCleaner by Piriform (free) CCleaner - Free Download - Piriform
    2. Start CCleaner
    3. Then Tools (left hand menu)
    4. Then Context Menu (top right)
    5. This will populate and give you a list of shell.dll files
    6. I then disabled the file: BTMSentToExt (Intel Corporation)

    If you don't have this file you can try disabling the ones you do have and seeing if it solves your right click issue.

    Hope this helps you.
    12-11-2015 02:45 AM
  11. RenoD2010's Avatar
    This is not an issue with the Nvidia driver. If you go into Device Manager and disable the Intel display adapter you will see it solves the problem BUT (and this is a big BUT) it sets the crappy MS display VGA adapter as your default completely messing up your main display and graphics performance.

    I tried installing the latest Intel drivers for my integrated HD graphics and it did not solve the problem. There does not seem to be a simple way to disable the context menu for the Intel Graphics like you can do with the Nvidia. My word but Windows 10 is a mess. I thought it was supposed to be this all new stream lined version of Windows 8.
    01-11-2016 07:41 PM
  12. RenoD2010's Avatar
    4. Then Context Menu (top right)
    I do not see this in my version of CCleaner. Been using this program for years. Are you using the Pro version?
    01-11-2016 07:43 PM
  13. mppk19851003's Avatar
    Right click on Desktop in windows 10 is very slow, what is the solution?
    02-05-2016 07:40 PM
  14. RumoredNow's Avatar
    what is the solution?
    Have you tried all of the above methods? Still no results?
    02-05-2016 09:00 PM
  15. amadeus829's Avatar
    Best solution I've found is remove all the shortcut items that link to an invalid resource.
    RumoredNow and ven07 like this.
    02-19-2016 02:12 AM
  16. guyguyguyguyguy's Avatar
    1/ Click the windows symbol bottom left of home screen.
    2/In search bar 'web and windows' type 'configure system' and the app of that name appears in blue above everything else that pops up.
    3/Click on it and then click on the tab called 'services'.
    4/Scroll down the list to 'NVIDIA' and uncheck the adjacent box.
    5/Now click 'OK' and restart your PC or whatever .
    That worked for me. simples!
    05-14-2016 03:16 PM
  17. TheFeet's Avatar
    Holy cow! I have been fighting with this ALL DAY! I fixed it by installing the latest NVidia driver for my graphics card!

    SYMPTONS:
    -Windows 10 did it's anniversary update while I was asleep. (thx Microsoft... NOT!)
    -alluvasudden I couldn't right-click anything and get a context menu (but only for about 30 seconds after boot)
    -explorer.exe was running like a slug! And File Explorer would hang saying "Working on it..." endlessly while simply trying to view folders/contents
    -even doing a simple task such as "Right-click/New/Text Document" was unbelievably SLOOOOOW! Every click took forever!
    -eye sockets bleeding from stabbing pencils into them

    HOW I FIXED IT:
    I grabbed the latest NVidia driver and checked the box "Perform a Clean Install" and BAMM! All fixed!

    What did NOT fix it:
    -these people saying to run regedit, and delete keys for "...directory/background/contextmenu blah blah".. nope! didn't work (for me at least)
    -changing virtual memory(page file size) DID NOT FIX IT!

    Hope this helps---> The Nvidia driver I downloaded and did a CLEAN INSTALL with was version 21.21.13.7290 (shown in device manager) and was dated 9/16/2016. The version Nvidia says it is on their website was :

    GeForce Game Ready Driver - WHQL
    Version: 372.90 - Release Date: Wed Sep 21, 2016
    I have windows 10 64bit running on a 6-core AMD Phenom II, 3.9Ghz with 20GB RAM, an SSD for C: Drive and an Nvidia GTX 650 Ti.

    HOPE THIS HELPS OTHERS!!!

    I would like to point out that this problem of SLOW windows 10 and unresponsive right-click ONLY APPEARED AFTER the latest windows 10 update. My PC updated itself just last night on Sept. 28/2016.
    Last edited by TheFeet; 09-28-2016 at 07:33 PM.
    09-28-2016 07:23 PM
  18. BenIsCool's Avatar
    Have a friend who has this problem as well. Thank you for your answers
    09-29-2016 11:28 PM
  19. Markp48's Avatar
    Created a New User. The new user does not have the slow right click issue.

    The issue for me was only in the user profile.
    I assume there were some broken link(s), shortcut(s) etc, which it was trying to resolve.

    Microsoft, Why the long time out on broken links?
    10-20-2016 03:57 PM
  20. abhishek singh21's Avatar
    this might happen when some process is consuming high CPU and your usage is 100%. check under task manager in this scenario and report back which process is eating up the CPU.
    10-22-2016 05:56 AM

Similar Threads

  1. Windows 10 on a Dell XPS 27
    By someoneinwa in forum Windows 10
    Replies: 7
    Last Post: 01-09-2016, 11:12 PM
  2. Flashlight won't turn on when plugged to USB
    By TechAbstract in forum Microsoft Lumia 640
    Replies: 8
    Last Post: 08-07-2015, 09:44 PM
  3. Replies: 1
    Last Post: 08-03-2015, 11:07 PM
  4. Replies: 0
    Last Post: 08-03-2015, 11:01 PM
  5. Why isn't my Outlook 2013 not responding after the Windows 10 upgrade?
    By Windows Central Question in forum Windows 10
    Replies: 0
    Last Post: 08-03-2015, 10:57 PM
LINK TO POST COPIED TO CLIPBOARD