The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. mj0's Avatar
    Windows 10 has left me a bit flabbergasted after I first tried to go online via my laptop's builtin UMTS modem. In Windows 8.1 it was quite simple and straightforward:

    1. Click the network icon in the taskbar
    2. Click mobile broadband
    3. Click "Unlock"
    4. Enter SIM-PIN and hit Enter

    Whereas this is what I have to do in Windows 10:

    1. Click the network icon in the taskbar
    2. Click Mobile broadband
    3. Wait for settings window to open
    4. Locate settings window placed randomly somewhere
    5. Click mobile broadband in the newly opened window
    6. Click connect
    7. Click into the SIM-PIN entry field (otherwise the cursor is still in the search bar atop)
    8. Enter SIM-PIN and hit Enter

    Also, as long as the SIM card is locked there's no cellular toggle in neither the action center nor the network popup, and my provider's app (Telekom) doesn't detect a cellular modem until I actively unlock the SIM card.

    This seems a bit cumbersome if you ask me. Surely there must be a way to connect directly via the action center or the network popup directly. The only sort of easy way I found was to disable the PIN on my SIM card and select "Connect automatically", in which case I can trigger the connection by enabling the cellular modem via action center, however I would prefer to enter a SIM PIN first.
    Last edited by mj0; 08-04-2015 at 09:11 AM.
    08-04-2015 08:52 AM

Similar Threads

  1. How do I wipe all of the data from my phone before selling it?
    By Paolo Ferrazza in forum Windows Phone 8.1
    Replies: 17
    Last Post: 10-16-2017, 10:35 PM
  2. Windows 10 is now pre-installed when you buy Surface 3 and Surface Pro 3 tablets
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-04-2015, 08:50 AM
  3. Why don't I have the option to make a guest account?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 08-04-2015, 08:35 AM
  4. Why does my Nokia Lumia 730 report an error when the auto backup is invoked?
    By Surendra Choudhary1 in forum Windows Phone 8.1
    Replies: 0
    Last Post: 08-04-2015, 08:33 AM
LINK TO POST COPIED TO CLIPBOARD