1. Deepak's Avatar
    Hello. I had recently clean installed Windows 10 on my laptop. Before doing that, all my drivers were working well except for WiFi - a problem since build 10158. Currently I am on build 10240.

    When I plug usb sticks into the USB 3.0 ports on my laptop, they don't connect. It's not like the 'not recognised' problem. It simply shows no sign of connection like blinking its LED or any response from the OS. On the other hand, when I connect my Lumia phone in the same ports, it warns me of Slow Charging. And when I plug it into the 2.0 port, it gets connected. Why is this happening? All of my device drivers are up to date. I believe its not a hardware issue because my laptop has two such ports and both of them have the same problem. Not a coincidence, is it? Any ideas or anyone facing the same issue?
    08-20-2015 12:50 PM
  2. rhapdog's Avatar
    I had to "uninstall" then download and reinstall USB 3 drivers from my manufacturer website in order to fix the problem on mine.

    USB 3 takes very specific drivers. While your system may seem to have USB drivers installed, they may not be correct for USB 3. For USB 3 to work, you also have to make sure you have updated chipset drivers as well.

    Try reinstalling drivers to see if it fixes the issue.
    08-20-2015 04:23 PM

Similar Threads

  1. How to send an email with Cortana on Windows 10
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-20-2015, 12:50 PM
  2. How to downgrade from Windows 10 to Windows 8.1
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-20-2015, 12:50 PM
  3. How can I get my Kodak ESP Office 6150 Printer to work with Windows 10?
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 08-20-2015, 12:44 PM
  4. VLC for Windows 8.1 and Windows 10 gets updated with lots of improvements
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-20-2015, 12:30 PM
  5. something wrong with the cirtificate wi-fi windows lumina 630
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 08-20-2015, 12:29 PM
LINK TO POST COPIED TO CLIPBOARD