The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. Scott Bradley's Avatar
    Some of you may be experiencing a similar problem and others may have a better solution, so I thought I would post it here.

    I run a Plex server on my Windows 10 machine and I noticed when streaming through it my CPU was pegged at 100%. From time to time this would cause interruptions in the stream. Funny thing was, when streaming remotely from my friends Linux based Plex service it, the stream was rock solid.

    I did some research and found that the CPU hog was the Network Realtime Inspection Service running against the stream. I put the PLEX executables in the Windows Defender Exclusions list (Settings->Update & Security->Windows Defender->Exclusions) and my CPU usage went down averaging about 10%.

    Any thoughts or recommendations from the group?
    10-08-2015 02:19 PM
  2. _Emi_'s Avatar
    disable defender? or get other antivirus? one of those free you an disable and they will not enable back after sometime.
    it's like many hours for defender to enable again itself but still.

    Defender likes checking things, sometimes too much, I haven't tested plex but someone posted how PhoenixFD improved drastically once defender was disabled. because it would try to check every file PhoenixFD creates so it slows it down.

    I use Universal Media Center and never had problems, so maybe maybe it's plex causing it for something they use it on their server when streaming.
    Last edited by _Emi_; 10-08-2015 at 03:21 PM.
    10-08-2015 02:52 PM
  3. Scott Bradley's Avatar
    Yes, I disabled defender explicitly for Plex.

    I hate all of the third party anti-virus tools with nag screens and up-selling. I use a combination of Windows Defender and MalwareBytes Anti-Exploit. Anti-Exploit is great for those zero day attacks. This combination is rock solid, doesn't (generally) weigh down my system and provides good protection.

    This is the odd exception to that rule for me at least.
    10-08-2015 03:04 PM
  4. An0mander's Avatar
    Thanks Scott for the tip. I just recently installed flex server on my Win 10 PC and an streaming to my Xbox one. I'll check my defender settings and see how it looks.

    I was getting issues with streaming in the first 5 seconds, but if I fast forward the rewound it worked just fine.

    Sent from my SM-N910V using Tapatalk
    10-08-2015 03:17 PM
  5. _Emi_'s Avatar
    Well looking at the process, I don't see it going above 0.1% so I don't know whyit happens on your side.
    but there is always ways to disable it completely if needed.

    REGEDIT:
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows Defender

    create a DWORD value = DisableAntiSpyware
    and
    0 is on and 1 is off
    then you can save the .reg with on and off so you enable it whenever you want and disable it just by double clicking on the regfile, which is easy to do.

    I didn't see anything strange on that service, but installing plex server is not going to happen. but I hope if necessary like you will be streaming for long hours, disabling Defender would help without it having to turn back on.
    This tip should be helpful for anyone anyway, if someone needs Defender to be off and not turning back on.
    10-08-2015 03:21 PM

Similar Threads

  1. Replies: 1
    Last Post: 11-03-2015, 03:51 PM
  2. Replies: 1
    Last Post: 10-08-2015, 02:33 PM
  3. Replies: 0
    Last Post: 10-08-2015, 02:05 PM
  4. Why won't apps download from the Windows store?
    By Windows Central Question in forum Applications
    Replies: 1
    Last Post: 10-08-2015, 02:02 PM
  5. How do I fix error code 0x800704cf in Windows 10?
    By Windows Central Question in forum Windows 10
    Replies: 0
    Last Post: 10-08-2015, 01:55 PM
LINK TO POST COPIED TO CLIPBOARD