1. Hutzi's Avatar
    I am experiencing significant boot time drops since updating a few days ago. I couldn't wait for Windows update so I upgraded through the media creation tool. Excluding the BIOS time my PC with a 840 Evo installed takes 40s instead of the former 20-22s!!!! What has your experience on boot time performance been since the November update guys?
    Cheers
    11-17-2015 03:25 AM
  2. Hutzi's Avatar
    Issue got fixed on latest cumulative update! Boot times are now faster than ever!
  3. jefbeard911's Avatar
    Same here. Freakin slow!
    11-17-2015 08:39 AM
  4. pankaj981's Avatar
    Well upgrades usually slow most devices, and this is not applicable to Microsoft devices only. It may be due to various reasons but the culprit is always the software and lack of proper drivers. It could also be some startup process not working as intended. Usually a hard reset should fix it.
    RumoredNow and jefbeard911 like this.
    11-17-2015 09:07 AM
  5. Hutzi's Avatar
    Well, I'm definitely not doing a hard reset on my gaming rig. It's so weird because of maybe 10 boots, 1 boot is normal. I've tried everything possible to find out what is different in these special boots but no chance... The thing is in the whole boot process the only thing that is different is the "welcome" screen. It used to be that I didn't even see that screen. Now it at least takes 15s or so.... Ahhhh. Annoying.
    11-17-2015 10:33 AM
  6. pankaj981's Avatar
    Ehh I would hate to do that on my gaming machine too but it helps in the long run. Besides I can't afford to lose any performance on my aging GTX670M.
    RumoredNow likes this.
    11-17-2015 12:21 PM
  7. Hutzi's Avatar
    Issue got fixed on latest cumulative update! Boot times are now faster than ever!
    pankaj981 and RumoredNow like this.
    11-18-2015 06:07 PM
  8. JDHamilton6's Avatar
    Issue got fixed on latest cumulative update! Boot times are now faster than ever!
    I just installed the cumulative update and it boots even slower for me. Maybe I need to give it a few cycles and it will get better.
    11-19-2015 09:47 AM

Similar Threads

  1. Bluetooth Mouse & November Update
    By cipher7 in forum Windows 10
    Replies: 9
    Last Post: 12-31-2015, 03:27 AM
  2. Lumia 950 now available in the US from AT&T
    By darkpgr in forum Microsoft Lumia 950
    Replies: 20
    Last Post: 11-18-2015, 08:35 AM
  3. [Fixed] build 10581 makes 1320 brick. Help me
    By RkNguyen in forum Windows 10 Mobile Insider Preview
    Replies: 2
    Last Post: 11-17-2015, 12:02 AM
  4. HotelTonight drops support for Windows Phone in wake of layoffs
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-16-2015, 11:42 PM
  5. Live tiles not updating
    By sguy156 in forum Windows 10 Mobile
    Replies: 0
    Last Post: 11-16-2015, 09:14 PM
LINK TO POST COPIED TO CLIPBOARD