The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. bokyab's Avatar
    Hey All.

    I bought my Razer Blade around November last year, and I automatically upgraded it to Windows 10. Since then, I've encountered the occasional glitch wherein I would run a game (usually either Heroes VI, but it does this with other games as well) and I would end up with a blank black screen. The keyboard is lit, and sometimes, not always, there is no audio playing. Ctrl+Alt+Del doesn't work and I have to spend 5-15 minutes hard restarting my computer because when it restarts, it puts me back in the same state.

    This went on maybe 2-3 times per week, until today where it happened to me again, but it took me around an hour to get it started up again. At first, I figured that it might have been my fault, and proceeded to download all the new drivers and uninstall, then reinstall all programs such as Nvidia, Intel and C++, but the problem persisted, throughout each mandatory restart. I tried looking online for someone with the same problem as me, but it seems either my computer is a lemon, or that my google-searching skills are extremely weak. (Yes, I have seen the black screen on start up error, and it's not related to mine. I see no mouse. One thing to note is that my keyboard lights up when I turn the computer on, blacks out for a second, then lights back up again during the times that it does NOT display the Razer symbol upon opening.)

    I'll attach my dxdiag. Has anyone encountered this problem, or know how to fix it? I'm pretty close on giving up on this laptop and just using my old one at this point. Hope to hear from you guys soon.

    EDIT:
    I got it to work finally.

    What I did was go to Geforce control panel, went to 3d settings then manually routed everything to use the Nvidia, instead of using the generic setting. It fixed itself after doing that.
    Last edited by bokyab; 03-07-2016 at 09:14 PM.
    02-29-2016 09:04 AM
  2. anon(9838634)'s Avatar
    Happens to me too. I'm running an Asus UX31LA ultra-book. You?
    02-29-2016 04:57 PM
  3. excalibur1814's Avatar
    Maybe try a 'Reset this PC' after backing up your files? That would then present you with a nice, clean, Win 10 install to work from. What you've suggested hans't happened to any of the computers here but they've all been reset after the upgrade.
    03-01-2016 04:53 AM
  4. anon(9838634)'s Avatar
    Yeah, I'm going to try the reset this summer when I don't NEED my computer...
    03-03-2016 04:41 PM
  5. bokyab's Avatar
    Updated with the fix I found.
    03-07-2016 09:14 PM

Similar Threads

  1. Replies: 6
    Last Post: 04-02-2016, 06:22 AM
  2. How can I install Windows 10 on an 'old' PC?
    By Windows Central Question in forum Windows 10
    Replies: 2
    Last Post: 03-03-2016, 10:25 AM
  3. When will I get the official Windows 10 mobile?
    By Windows Central Question in forum Windows 10 Mobile
    Replies: 7
    Last Post: 02-29-2016, 11:49 AM
  4. Enabling Equalizer / Dolby surround when in Bluetooth h'set.
    By Glmer Badua in forum Windows 10 Mobile
    Replies: 0
    Last Post: 02-29-2016, 07:47 AM
LINK TO POST COPIED TO CLIPBOARD