1. Ariel Takom's Avatar
    Hello guys! I've just updated my laptop to Windows 10 about a few weeks ago, and all has been a smooth sailing except for this one bug.

    The WiFi connection in my student apartment is pretty weird, in a sense that the speed may drop after being connected to the WiFi for a long time. Disconnecting from this WiFi, and immediately reconnecting often fixes this problem (something like refreshing my connection to the WiFi, I think).

    The first time this bug happened to me was when I was playing DotA 2. As I was playing, I noticed the lag and sudden drop in ping, and did the dis/re-connecting of the WiFi. After the first attempt, the WiFi speed did not 'refresh', so I kept on dis/re-connecting the WiFi, until at one point, after clicking the Disconnect button, the WiFi window was loading infinitely (waited for 2 minutes, no response).

    So I closed the WiFi window by merely clicking on my desktop, and when I re-open the WiFi by clicking the logo on the taskbar, the WiFi window that appeared seems to be stuck. So the first thing I thought was maybe there is some unresponsive task going in the background, and so I opened the Task Manager.

    Now the Task Manager did appear, along with the list of all the apps/software/services etc. running on the background, but the window seem... static? Under the process tab, the numbers on the Memory/CPU/Disk usage did not fluctuate (it usually does fluctuates by a few %, and I can click on all these services, but that's it. I can't seem to do anything. I can't end process and whatnot.

    Moving to the Performance tab, everything is static. The graphs did not show any fluctuation at all. And in the end, I can't even close the Task Manager. I tried opening all my other software/apps like Word, Notepad, Groove. The funny thing is, my pc is able to launch all of them, but I can't use them. I can't type anything on Notepad, I can't even begin a new word document in Word, I can't listen to my musics and whatnot. This problem happened a few times by now, and what I also observed is that:

    1) This problem goes away only by properly shutting down the PC (Yes, I can shut down or restart), and turning on my laptop.

    2) This problem persists even when I properly "Restart" my laptop, forced Restart my laptop (by holding the laptop's power button for a certain time until the laptop turns off, then turning it back on again), or even when I sign-out -> relog into my laptop.

    3) It happens randomly, but it has a higher chance of happening after waking the laptop from sleep mode.

    4) Problem occurs even when dis/re-connecting while NOT gaming/programming/using other softwares that Engineering student uses.

    I'm pretty sure all of my drivers are up to date, and since my copy of W10 is not the Pro version, I'm forced to download and install all the updates available for my laptop. If you want my laptop's specs, they are:
    - Dell Vostro 2420 Model
    - i5-3230M CPU @ 2.60GHz
    - 6.00GB RAM
    - 64-bit Win 10 Home Single Language
    - 500GB HDD
    - Nvidia GeForce 620M
    05-04-2016 04:12 AM
  2. realwarder's Avatar
    Sounds like a driver issue to me.

    I believe you can still tell the non-Pro to not update Drivers even though it will update Windows.

    System/Advanced/Hardware/Device Installation/No.

    You could check the latest drivers: Product Support | Dell US

    The Dell drivers may be more specific or newer than ones delivered through Windows Update... compare in Device Manager.
  3. realwarder's Avatar
    Sounds like a driver issue to me.

    I believe you can still tell the non-Pro to not update Drivers even though it will update Windows.

    System/Advanced/Hardware/Device Installation/No.

    You could check the latest drivers: Product Support | Dell US

    The Dell drivers may be more specific or newer than ones delivered through Windows Update... compare in Device Manager.
    05-04-2016 07:11 AM
  4. slooksterpsv's Avatar
    On my xps I had to go to device manager -> the device properties -> advanced I think and enable 20/40mhz for the bands. Plus to use b/g 20/40. It helped a lot. Maybe that could help?
    05-04-2016 07:35 AM
  5. Ariel Takom's Avatar
    Sounds like a driver issue to me.

    I believe you can still tell the non-Pro to not update Drivers even though it will update Windows.

    System/Advanced/Hardware/Device Installation/No.

    You could check the latest drivers: Product Support | Dell US

    The Dell drivers may be more specific or newer than ones delivered through Windows Update... compare in Device Manager.
    I checked the System/Advanced/Hardware/Device Installation path, and it has been set to Yes. So no issue there I guess.

    Now am checking out Product Support, thanks for the links!

    The last one however, what do you mean by "compare in Device Manager"?
    05-05-2016 12:13 AM
  6. Ariel Takom's Avatar
    On my xps I had to go to device manager -> the device properties -> advanced I think and enable 20/40mhz for the bands. Plus to use b/g 20/40. It helped a lot. Maybe that could help?
    Ok this is way more technical. I see a few 20/40MHz here, but which one are you talking about?

    P/S: some of them has been set to Auto, so I guess that's okay... I think?
    05-05-2016 12:15 AM
  7. slooksterpsv's Avatar
    I changed all of them for the pure fact auto may just select 20 b/g only.
    05-05-2016 01:13 PM

Similar Threads

  1. Windows 10 Unnamed/Undeletable Icons in desktop?
    By skiddow in forum Windows 10
    Replies: 2
    Last Post: 05-04-2016, 12:02 PM
  2. No new Windows 10 PC or Mobile preview builds expected this week for Fast ring Insiders
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-03-2016, 08:50 PM
  3. Multiple MSN Sport Profiles
    By This-Guy in forum Windows 10 Mobile
    Replies: 0
    Last Post: 05-03-2016, 07:30 PM
  4. Shadow Complex Remastered now available for Windows 10 in the Store!
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-03-2016, 07:30 PM
  5. Replies: 1
    Last Post: 05-03-2016, 06:49 PM
LINK TO POST COPIED TO CLIPBOARD