The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. QuentinJ's Avatar
    Hi,
    I tried installing the anniversary update on a PC I upgraded from windows 7 that worked well with TH2 (10586.545).
    The first attempt failed and restored TH2. I cleared windows update and tried again but it failed again, however this time after restoring TH2, everything was fine at first and after a few minutes when I tried to open the start menu, windows explorer crashed and relaunched and all apps and programs pinned to the taskbar except windows explorer got unpinned.

    What's worse is that my start menu is virtually empty, I cannot launch settings and all apps only shows 3D builder, OneNote, Photos and Xbox.

    Cortana/search cannot launch any apps or programs but will launch edge to perform a search however the icon does not show in the taskbar.

    What I find strange is this problem only affects one user and another admin test account has no problem.

    I ran DISM restorehealth however I do not see any difference.
    I tried rolling back to a previous windows 10 build that was saved on my disk (windows.old) but this failed...

    Anyone know how I can restore the start menu and all apps list for this user?

    Thanks in advance for the help
    Last edited by QuentinJ; 08-21-2016 at 06:20 AM.
    08-21-2016 05:22 AM
  2. Chintan Gohel's Avatar
    creating the user account again? Or is that not an option?
    08-21-2016 06:20 AM
  3. Chintan Gohel's Avatar
    08-21-2016 06:20 AM
  4. QuentinJ's Avatar
    It's a Microsoft account user, i could copy the appdata temporarily to another user and then creating it again as there are games saved there and a bunch of settings as well.
    That's what i was going to try however if there's a faster and easier solution that'd be better!
    thanks for the help

    EDIT: i'll try the troubleshooter now
    08-21-2016 06:21 AM
  5. Bobvfr's Avatar
    I assume you have switched the computer off, had a cup of tea and then restarted.
    Last edited by Bobvfr; 08-21-2016 at 07:20 AM.
    08-21-2016 06:27 AM
  6. gwinegarden's Avatar
    My wife had a similar issue, virtually nothing on the desktop, most things missing from the Start screen. A reboot fixed most of it, but the start screen still had things missing (mail, calendar, etc.). When I right clicked on them, in the apps list, one option was to unpin from Start! For some reason, it thought they were there. So, I did an unpin and pin and they were back.
    Chintan Gohel likes this.
    08-21-2016 06:42 AM
  7. Bobvfr's Avatar
    Sometimes I forget things

    When you do a large upgrade, chances are there are a lot of app upgrades to go through, and this could be why a lot of apps appear missing in action, again time and a restart are the plan.

    When ever I do an upgrade when it appears finished I then check the store for upgrades, then when I am finally happy all is settled down I do another reboot.
    Chintan Gohel likes this.
    08-21-2016 07:36 AM
  8. QuentinJ's Avatar
    I waited overnight in case apps were still reinstalling/migrating and restarted a few times but it didn't help

    the problem is nothing shows under all apps in the start menu for the main user, the other user is unaffected.
    i cannot launch the store easily, i need to use the "run" tool or click a link that will launch it. but even then it doesnt show on the taskbar and the taskview doesn't show it either

    i'm trying the anniversary upgrade again from the other functioning user to see what happens, but i think i may have to delete and recreate the user :(

    thanks all for the help
    Chintan Gohel likes this.
    08-21-2016 08:12 AM
  9. QuentinJ's Avatar
    UPDATE - i tried the 1607 update from the working account and it failed again at 88% (it freezes and at some point shuts down and restores the previous version).
    Now the programs are appearing again in the start menu and i am seeing the settings app, however the store and most of its app still do not show up... (they don't show up through search either)
    08-21-2016 11:24 AM
  10. QuentinJ's Avatar
    UPDATE 2 - managed to get everything working!!!
    found some PowerShell scripts online that did the trick. In case you are in a similar situation, here are the two scripts I required in admin PowerShell:
    Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
    and that one:
    $manifest = (Get-AppxPackage Microsoft.WindowsStore).InstallLocation + '\AppxManifest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manifest
    I need to repin everything but at least it is working! Maybe only the second script will work, however i encountered an error until i ran the first one.
    Fingers crossed now that it keeps working!
    Chintan Gohel likes this.
    08-21-2016 11:47 AM

Similar Threads

  1. photo app not showing my photos of sd card
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 08-21-2016, 03:33 PM
  2. Lack of settings app
    By hasibb hridoyy in forum Microsoft Lumia 535
    Replies: 4
    Last Post: 08-21-2016, 01:34 PM
  3. Server 2012 Essentials and Windows 10 Pro and Hello for Business
    By gestep48 in forum Microsoft Surface Pro 4
    Replies: 1
    Last Post: 08-21-2016, 11:08 AM
  4. Replies: 1
    Last Post: 08-21-2016, 06:18 AM
  5. Realarm adds voice commands and more in latest update
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-21-2016, 04:30 AM
LINK TO POST COPIED TO CLIPBOARD