1. slooksterpsv's Avatar
    Dell XPS 8700:
    8GB RAM
    3.6GHz Core i7-4790 CPU
    nVidia GTX 720
    256GB Toshiba SSD
    1TB HDD

    All the animations are slow. It just did an update today and now everything is crawling, bad. My CPU isn't under high usage or anything. Drivers are up to date. Everything is just extremely slow. Anyone else experiencing issues? This is a release build not a preview or insider ring build.
    09-16-2016 07:58 PM
  2. slooksterpsv's Avatar
    It was the update 3189866 that caused the issue. Uninstalled it and everythings working just fine.
    09-16-2016 09:06 PM

Similar Threads

  1. 100% disk usage on SSD reak slow
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-24-2016, 11:51 AM
  2. HP SMB order of Elite X3 and Lap Dock
    By Random Parsley in forum HP Elite x3
    Replies: 8
    Last Post: 09-21-2016, 11:47 AM
  3. Office and Windows Insider members can check out new features in Office Mobile apps
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-16-2016, 02:11 PM
  4. Huawei Matebook makes the iPad Pro upset and uncomfortable in latest ad
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-16-2016, 01:00 PM
  5. Win NFL game tickets and more prizes during free Madden NFL 17 tournaments at Microsoft Stores
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-16-2016, 10:42 AM
LINK TO POST COPIED TO CLIPBOARD