1. wolfpack219's Avatar
    I have a Surface Go 8GB version, got it on product release. This device has done this since day one.

    Problem: At random while connected to my home Comcast wifi network, the signal will completely drop. The wifi signal symbol will go away and it turns into a globe looking symbol with lines all across it. Then after about 15-20 seconds the signal pops back up. Its not consistent either as far as time elapsed between drops. It could happen within several minutes of each other or be hours.

    Things I've tried:
    - Reset my router
    - Rolled back Qualcomm driver/ updated driver to most recent

    Any other suggestions and please be detailed as will attempt to follow your instructions. Thanks again for your help.
    09-02-2019 11:01 PM
  2. Gayle Lynn's Avatar
    Update firmware on router, when was last firmware update?

    Change wifi channel. Look for interference.
    Use wifi extenfer to offer better coverage.
    Turn airplane mode on/off.
    09-03-2019 09:23 AM
  3. wolfpack219's Avatar
    I know the router did a firmware update recently. maybe changing the channel might be a good option. My other devices in the same areas of the home don't drop so I don't think it's a weak signal. I will try the channel and report back.
    09-03-2019 05:21 PM
  4. wolfpack219's Avatar
    So Xfinity changed the format of the admin in the router and I can't for the life of me find the channel select option anymore for the "Go". According to Netgear analyzer it says both my networks 2.4ghz and 5 ghz are on channel 6 and 157. Both Channels have max strength at 100%. However nowhere can I find to change the specific channel for single device.
    09-03-2019 07:20 PM
  5. spicypadthai's Avatar
    Do other devices disconnect or only the Surface? If it's only the Surface, then this is worth trying: go to the power management tab in the properties of the adapter and disable "Allow the computer to turn off this device to save power" if it's enabled.
    09-04-2019 10:55 AM
  6. wolfpack219's Avatar
    Yes it's only the Surface. I changed the only setting I could find under the wireless adapter which was turn off: Never, manual, let windows manage. It was on never, I changed it to let windows manage to,see what happens.
    09-04-2019 12:49 PM
  7. wolfpack219's Avatar
    I found an option to reset all network adapters to default and reinstall the drivers. I decided to try this and we'll see. Might have been a glitch from when it was updated at some point or from the factory. Either way its working now and I haven't noticed a drop. Ill keep you informed. Thanks for the help to those that replied.
    expobill likes this.
    09-04-2019 01:03 PM
  8. spicypadthai's Avatar
    Ok, and the setting I'm referring to is this: Open Network & Internet Settings > Change Adapter Options > right-click the Wi-Fi adapter > Properties > click Configure > go to Power Management tab > disable the option below

    wireless-adapter-properties.jpg
    09-04-2019 01:41 PM
  9. wolfpack219's Avatar
    That tab "power management" does not exist on the Surface Go.
    09-08-2019 03:33 PM
  10. wolfpack219's Avatar
    09-08-2019 03:36 PM
  11. spicypadthai's Avatar
    Interesting, the GO must be considered an AOAC platform. Anyway, maybe try a few things in this link.
    09-09-2019 08:10 AM
  12. wolfpack219's Avatar
    Tried the ones listed that I haven't already tried, no luck. I'm thinking the power management one would help but I don't have that option on this device. Unfortunately I think its either a windows error or a bad driver for the Qualcomm Atheros adapter. It says it using the 2018 update but there is a 2019 driver update. However my driver update option says its already running the best driver for this device.
    09-10-2019 12:27 AM
  13. wolfpack219's Avatar
    So in my latest attempt to correct the issue, I downloaded a driver update tool. The tool identified some 27 outdated drivers on my Go and updated them to the most current versions. The Qualcomm Atheros was one of the outdated drivers. So far so good I'll update if any drops occur in the same manner.
    09-10-2019 01:18 AM
  14. wolfpack219's Avatar
    program used was driver booster 6.
    09-10-2019 01:35 AM
  15. wolfpack219's Avatar
    It would appear the driver update has corrected this issue. Its unfortunate that windows itself does not recognize the new drivers that are available.
    09-10-2019 05:31 PM

Similar Threads

  1. Which Surface Book should I buy?
    By Windows Central Question in forum Ask a Question
    Replies: 8
    Last Post: 09-09-2019, 08:53 AM
  2. How to attach office document in Web Whatsapp using Microsoft Surface Go
    By Windows Central Question in forum Ask a Question
    Replies: 6
    Last Post: 09-09-2019, 08:52 AM
  3. The HyperX Alloy Elite RGB mechanical keyboard has dropped $40
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-02-2019, 07:50 PM
  4. Surface Pro 4 not logging onto secured Wifi SSiDs!
    By PReed2000 in forum Microsoft Surface Pro 4
    Replies: 0
    Last Post: 09-02-2019, 06:45 AM
  5. The House of Marley's Get Together Bluetooth speaker has dropped to $80
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-01-2019, 08:00 AM
LINK TO POST COPIED TO CLIPBOARD