The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
02-08-2013 03:17 PM
32 12
  1. MDak280's Avatar
    Hi there!

    I decided to go ahead and purchase Windows 8 Pro to upgrade my laptop. Got it for $15.96 :)

    But I've run into a problem. When I got to the download for Windows 8 Pro, after a short while I get this message:

    "Download did not complete successfully

    The download task did not complete.

    The specific service does not exist as an installed service."

    At first I just thought it was because there was a lot of people who were downloading Windows 8 because the deal ended yesterday. However, it's been a while and I still get this error. I went and deleted the WebSetup folder (after reading this would fix the problem) and tried the download again, but it still gives me the same error. Does anyone know what's wrong? This is the laptop I'm using: Toshiba Satellite A665-S6086, Windows 7 Home Premium installed.

    Thanks! If you need any more info let me know.
    02-01-2013 02:33 PM
  2. Bearach's Avatar
    Last edited by Bearach; 07-08-2013 at 05:12 PM.
    MDak280 likes this.
    02-01-2013 03:20 PM
  3. MDak280's Avatar
    Thanks for the reply!

    I ran the troubleshooter and it said that it fixed the problems. However, when I go to the Control Panel > System and Security > Windows Update and I click "Check for updates" it tells me:

    "Windows Update cannot currently check for updates, because the service is not running. You may need to restart your computer."

    I restarted and it said the same thing.

    I uninstalled my security services before I tried downloading Windows 8. I had Microsoft Security Essentials and McAfee (McAfee I got with an update for Adobe Flash, but I never used it).

    Also, something interesting is that now when I try to download Windows 8, instead of saying "The specific service does not exist as an installed service," it says "unspecified error."
    02-01-2013 06:59 PM
  4. Bearach's Avatar
    Last edited by Bearach; 07-08-2013 at 05:13 PM.
    MDak280 likes this.
    02-01-2013 07:36 PM
  5. MDak280's Avatar

    The "fix it" should have helped with this issue. As you're still having the issue, you may want to make sure the service is started. Go to your control panel type services in the text box at the top right. Then click services. Going through the list, check for the Windows Update service, and see if it's running. Also make sure Background Intelligent Transfer is started.

    Hopefully this helps.

    Get back again, if it doesn't :)


    These services need to be set to:

    Background Intelligent Transfer Service (BITS) : Manual
    Cryptographic Services : Automatic
    Remote Procedure Call (RPC) : Automatic
    System Restore Service : Automatic
    Windows Update : Automatic

    You can also try this "Fix" too.

    How do I reset Windows Update components?

    This will reset the Windows Update components.
    I went to control panel and searched services, and then I clicked "view local services." Windows Update Service, BITS, and System Restore Service were not on my list of services. I double checked to make sure, I can't find them. Could that be the problem? The other services were already set correctly.

    I ran the fix it tool, and it said that the issue "Repair Windows Update components" was "Not fixed."

    It seems that my problem is that I have some services are missing... is there a way to get these services back?
    02-02-2013 12:04 AM
  6. Bearach's Avatar
    Last edited by Bearach; 07-08-2013 at 05:13 PM.
    MDak280 likes this.
    02-02-2013 08:46 AM
  7. MDak280's Avatar
    Sorry for late reply, but yes that is the problem here. We have 3 options.

    1. Try running system file checker. (To do so, open command prompt as admin, then type: sfc /scannow - and let it finish)

    2. We can re-register all the services - May take a while, I'll write the list of files to register as soon as I can.

    3. Do a backup of your system, and do a reinstall of your OS.

    Hope the first option helps, while I work on the list of things to be re-registered.


    To get BITS back under services:

    Go to command prompt - Run as admin.

    Type: sc create BITS binpath= "C:\Windows\System32\svchost.exe -k netsvcs" start= delayed-auto

    Then restart.

    To get Windows Update back under services:

    Go to command prompt - Run as admin.

    Type: sc create wuauserv binpath= "C:\Windows\System32\svchost.exe -k netsvcs" start= auto

    Then restart.

    Try running setup now. If still no go, we'll register system restore and try again. If it doesn't after that though, we'll need to re-register all the files for each service, or run the above "fix its".
    Hey, thanks so much! I didn't get the Windows 8 download working yet but after following those steps, I went to control panel > System and Security > Windows Update and it's showing updates for my computer (there are 37 important updates I'm missing). I hope after I install them that it will work. I'll let you know what happens.
    Bearach likes this.
    02-02-2013 03:07 PM
  8. MDak280's Avatar
    Alright, so I just tried to install the updates. It said the updates failed to install. "Windows Update encountered an unknown error." I clicked get help with this error and the first suggestion was to update my drivers. Any ideas? Thanks for all your help so far!
    02-03-2013 07:14 PM
  9. Bearach's Avatar
    Last edited by Bearach; 07-08-2013 at 05:14 PM.
    02-03-2013 07:33 PM
  10. MDak280's Avatar
    I ran the fix it and it said that "Repair Windows Update Components" was not fixed. There was nothing else listed. I tried to update again to see what would happen, and the same error showed up.

    I'm missing:
    Application Management
    Base Filtering Engine
    IP Helper
    Offline files
    Security Center
    Windows Defender
    Windows Firewall
    Windows Modules Installer.

    BITS is shown but it's listed as "BITS" and there's no description; how do I know it's working?
    02-04-2013 08:48 PM
  11. Bearach's Avatar
    Last edited by Bearach; 07-08-2013 at 05:14 PM.
    02-04-2013 09:22 PM
  12. MDak280's Avatar
    I would love to backup and reinstall, but I don't have a Windows 7 disc... My laptop came preloaded with Win7. Is there a way to reinstall without a disc?
    02-04-2013 10:22 PM
  13. Bearach's Avatar
    Last edited by Bearach; 07-08-2013 at 05:14 PM.
    MDak280 likes this.
    02-04-2013 10:38 PM
  14. MDak280's Avatar
    You should have a recovery partition. Make sure you backed your data up. Restart the laptop, then press and hold F8. This should bring up "Advanced Boot Options" menu. Use your arrow keys to select "Repair your computer". Select your language and keyboard settings. Now select your Windows username and click ok to begin the "System Recovery Options" menu. Select the Toshiba Recovery Wizard and follow the instructions.
    Thank you, I'll try that. I'm backing up my files right now, I'll let you know how it goes!
    Bearach likes this.
    02-04-2013 10:58 PM
  15. MDak280's Avatar
    Sighhh... alright, so I successfully reinstalled the OS, and I made sure I installed all the important updates (Windows Update worked!). However, when I tried to download and install Windows 8, it gave me another error. I entered my product key and clicked next, then it told me:

    "We can't connect right now

    Check your internet connection and try again."

    I'm pretty sure my internet connection is fine... could it be a firewall or security service? Norton is on my laptop but I didn't activate it.
    02-05-2013 04:03 PM
  16. Bearach's Avatar
    Last edited by Bearach; 07-08-2013 at 05:15 PM.
    MDak280 likes this.
    02-05-2013 04:10 PM
  17. MDak280's Avatar
    I completely uninstalled Norton (turns out it was 2011) and turned off the Windows Firewall from the control panel. I ran the Windows 8 set up again and got the same error.

    This is really puzzling, I have no idea what could be wrong this time.
    02-05-2013 08:15 PM
  18. Bearach's Avatar
    Last edited by Bearach; 07-08-2013 at 05:15 PM.
    MDak280 likes this.
    02-05-2013 08:46 PM
  19. MDak280's Avatar
    That's the program that I have installed that's giving me the errors. I could try deleteing it and redownloading it.

    Also, I think I do. I'll try connecting to a different network.
    02-05-2013 09:05 PM
  20. Bearach's Avatar
    Last edited by Bearach; 07-08-2013 at 05:16 PM.
    MDak280 likes this.
    02-05-2013 09:12 PM
  21. MDak280's Avatar
    Connecting to another network didn't work.

    But if you meant try using a different laptop... that might work. I can try downloading the set up program on my dad's laptop and burning the ISO to a disk. I'll try that.
    02-05-2013 11:43 PM
  22. Bearach's Avatar
    Last edited by Bearach; 07-08-2013 at 05:23 PM.
    MDak280 likes this.
    02-06-2013 12:06 AM
  23. MDak280's Avatar
    I have no idea if it was a different ISP. I looked at some of the Microsoft topics, most of them said to contact Microsoft which I might do. I have 30 days to get a refund so the worst that could happen is that the download doesn't work but I get my money back.
    02-06-2013 12:35 AM
  24. Bearach's Avatar
    Last edited by Bearach; 07-08-2013 at 05:16 PM.
    02-06-2013 05:18 PM
  25. MDak280's Avatar
    No, I haven't contacted Microsoft yet. I want to try this on my dad's laptop before I contact Microsoft, I just haven't had the chance to do so because I've been busy. If it doesn't work on my dad's laptop then I'm thinking there's a problem with the product code and then I'll contact Microsoft.

    I was also thinking it might be a problem with my drivers. I might have to update them but I don't know which ones need to be updated.
    02-07-2013 10:24 PM
32 12

Similar Threads

  1. Windows Live Messenger Profile Picture Not Updating on Phone
    By pickled_lemur in forum Nokia Lumia 800
    Replies: 6
    Last Post: 06-08-2012, 08:23 AM
  2. (Official) Who's Lumia 900 did not ship?
    By Dave Blake in forum Nokia Lumia 900
    Replies: 5
    Last Post: 04-06-2012, 12:40 PM
  3. Windows Phone 7 Connector does not have 8107 update
    By Silverdogz in forum Windows Phone 7
    Replies: 1
    Last Post: 02-12-2012, 06:33 AM
  4. Class 10 sdhc Card did not work
    By evilrobot in forum Samsung Focus
    Replies: 15
    Last Post: 09-26-2011, 08:54 PM
  5. They did not take Facebook integration far enough
    By Pete C in forum Windows Phone 7
    Replies: 9
    Last Post: 03-02-2011, 08:39 PM