1. surfacedude's Avatar
    i'm having connectivity issues. my surface pro will say i have limited connectivity, but no other device in the house is having connectivity issues. this is only happening on my surface pro, not my rt. just got the pro so i'm in part wondering if this is hardware related.


    anyone got any insights?
    06-30-2013 06:44 PM
  2. surfacedude's Avatar
    i'm going to try resetting the surface pro and just start over. i'll post a follow-up re: the results.
    06-30-2013 07:08 PM
  3. surfacedude's Avatar
    looks like this is a common issue:

    Windows 8.1 preview - No WIFI
    06-30-2013 07:14 PM
  4. surfacedude's Avatar
    reset my surface pro so now i'm back to just windows 8 and everything seems to be working fine. i'll hold off moving to 8.1 on the pro until another round of updates or maybe even wait until the full release. other bugs i can deal w/, but i need wifi to work. no connectivity problems at all on t he 8.1 rt, though. interesting.
    06-30-2013 07:27 PM
  5. stephen_az's Avatar
    looks like this is a common issue:

    Windows 8.1 preview - No WIFI
    That thread has nothing to do with limited connectivity. It is about driver errors in a variety of laptops. Yes, limited connectivity is an issue with Surface Pro and 8.1 in some settings. I experienced it on my tablet as well. Since I disabled selective suspend, I have had a stable connection. Actually I also switched my router to use a single channel for each band instead of auto channels since that seemed to be an issue with another device.
    07-01-2013 04:21 PM
  6. Tanner Rohnke's Avatar
    This is exactly what I was looking for, can't thank you enough.
    07-01-2013 09:33 PM
  7. Fitzgerald King Xuffi's Avatar
    Hi there, im so sorry for being such a noob but i have to ask how and where did you change this settings because im having the same problema i can still download anything by torrent or jdownloader but when i try to open any browser i cant but when i log in to another wifi everything Works perfectly i have try this in many other wi fi like where i work where my gf lives my neighbor and everything Works perfectly i know its not my router because we have another 3 cpus and the wifi Works just fine in all of them please if you know how to fix this your help will be much apreciated thanks so much.
    07-08-2013 10:49 AM
  8. ttsoldier's Avatar
    Hi there, im so sorry for being such a noob but i have to ask how and where did you change this settings because im having the same problema i can still download anything by torrent or jdownloader but when i try to open any browser i cant but when i log in to another wifi everything Works perfectly i have try this in many other wi fi like where i work where my gf lives my neighbor and everything Works perfectly i know its not my router because we have another 3 cpus and the wifi Works just fine in all of them please if you know how to fix this your help will be much apreciated thanks so much.
    To disable selective suspend you need to open advanced power settings for your selected power plan. Expand usb settings and isb selective suspend setting, set the drop down menu setting to disabled, and click on ok.

    To switch your router to use a single channel, will depend on the model router you have.
    07-08-2013 11:16 AM
  9. Scorpio5x0's Avatar
    I was also having the connectivity issues after upgrading to 8.1 preview on my Surface RT. I can say that the updates that went out last week did seem to correct the issue for me. May want to check for updates and install any that have not installed yet.
    07-08-2013 03:03 PM
  10. Watcher Ter's Avatar
    Same here after upgrade to windows 8.1 wifi gets limited connectivity all the time....
    10-18-2013 01:52 PM
  11. brownalan's Avatar
    Yep, I updated two laptops from 8 to 8.1. One Sony Vaio, the other Asus, both with Atheros 9285 wireless. Neither will stay connected to the internet today. I've updated drivers several times and nothing seems to help. Funny thing is that the wireless connection indicates that it is connected with internet access, but after a few minutes it won't load a page in IE. Disconnect, reconnect and it works for a few minutes before it fails to load pages again.

    Frustrating.
    10-18-2013 08:13 PM
  12. sashlon's Avatar
    I am having this same issue on my Surface Pro
    10-19-2013 04:26 AM

Similar Threads

  1. O2 Wifi app possibly coming to windows phone
    By TechFreak1 in forum Applications
    Replies: 3
    Last Post: 11-11-2015, 09:16 PM
  2. Nokia Lumia 928 will not connect to home wifi
    By joesantucci1981 in forum Nokia Lumia 928
    Replies: 11
    Last Post: 08-09-2015, 05:03 PM
  3. Replies: 2
    Last Post: 07-02-2013, 08:55 AM
  4. 8.1 Preview: Can't check for app updates in Windows Store?
    By martinblank64 in forum Microsoft Surface for Windows RT
    Replies: 5
    Last Post: 07-01-2013, 05:34 AM
  5. connectivity problems
    By AndreStudart in forum Nokia Lumia 920
    Replies: 1
    Last Post: 06-30-2013, 04:28 PM
LINK TO POST COPIED TO CLIPBOARD