1. Kyorin's Avatar
    Hi, I'm not sure how long it has been doing this as I normally use the app when I'm in range of WiFi (at home)... Today I found that if I browse an article about an app, and then swipe right to get to the link to download the app, I get the usual links to the forums etc. but if I try to download the app from the link in this list, I get the following error:

    We can't connect to the Store at the moment. Check your data connection or try again later.

    The problem is, that after this error, I can no longer send/recieve any data, if I start Internet Explorer, I get a message saying that tethering is not included in my plan and I should turn my phone off for a short time and then turn it on again.

    This does resolve the problem, but it is obviously a pain.

    This problem is totally reproduceable, as soon as I try and download an app from the right-swipe-link in the WPCentral app, I lose all data connectivity, until I switch off for a couple of minutes and then restart.

    My guess would be that something within the WPCentral app is trying to download something in a way that makes it look like tethering has been enabled on the handset.

    Please advise.
    09-25-2013 09:56 AM
  2. Corepc's Avatar
    What phone do you have and what carrier, are you tethering at all to any other devices.
    I think it would be related more to your data connection than the app itself.
    Have you tried uninstalling wpcentral app and reinstalling it.

    I am always tethering to pc from my phone and have never run into a problem like what you stated when I download app from WPCentral via it links.
    09-25-2013 02:08 PM
  3. cooldudefred's Avatar
    Same thing happens to me on my 520. Are you on Three as well?
    09-25-2013 02:28 PM
  4. Kyorin's Avatar
    Yes, I am on Three UK, and my plan doesn't include tethering. Though tethering does actually work... I don't actually use it though, just tried it some months ago.

    Any ideas what could be causing this? It would seem to be specific to this app. My phone is an HTC 8x running GDR2.
    09-26-2013 02:29 AM
  5. Jay Bennett's Avatar
    Hi guys.

    I had this exact same problem as I'm on Three UK as well. The beauty for me is that as I wrote the app it was easy for me to tell Three UK that there was absolutely nothing that the app is doing which should be considered tethering. It is a fault with Three UK's anti-tethering system.

    Call up their technical support (dial 333 from your phone) and complain, then as and when it happens again, complain some more. I complained a few times over 2 days and got through to a technical bod who fixed something on my account to stop this bug. If you can give them an exact time as to when it happened that usually helps them isolate the issue and resolve it for you.
    09-26-2013 04:37 AM
  6. Kyorin's Avatar
    Thanks Jay, you're a star.

    Great app by the way.
    09-26-2013 07:03 AM
  7. Kyorin's Avatar
    Hi Jay,

    No joy with Three, they just say that there is no blocks of any kind on my account and that the issue must lie with the app. I believe you over them, but is there anything else I can do to help resolve this issue?

    Any help would be much appreciated. I'm getting nowhere with Three :(
    10-03-2013 11:22 AM
  8. Jay Bennett's Avatar
    You could try telling them that the developer of the app reported this problem and had it fixed on his account with them? Should shut them up pretty quickly ;)
    10-03-2013 01:48 PM
  9. Kyorin's Avatar
    I did say that already, but until I can convince the nice Indian lady to put me through to someone that isn't just following a flowchart to answer my questions, I'm a bit stuck :(
    10-04-2013 11:23 AM
  10. Jay Bennett's Avatar
    Hmmm, well in the meantime, because I think I know which part is causing it, could you try deleting your forum credentials (under settings) and then restarting the app. Try using it for a while and see if it happens
    10-06-2013 04:17 AM
  11. Kyorin's Avatar
    Hi Jay,

    I don't have any forum credentials entered...

    I don't have much data allowance left until later this week when it rolls over, I'll experiment a bit more then, and probably call Three again to see if I can get somewhere with them.
    10-14-2013 10:58 AM
  12. deepthought2471's Avatar
    Hi folks,
    I just move to an unlimited sim contract with Three UK and have started getting the same issue with the WPCentral app. My plan doesn't allow tethering so it seems like Three's tethering detection is kicking in everytime I use the app. I uninstalled it and reinstalled but got the same problem immediately.
    I haven't phoned Three yet, that's the next port of call .
    11-14-2013 01:01 AM
  13. Jay Bennett's Avatar
    Yeah try calling them in the first instance. If that doesn't work then I'll look to see if I can work out exactly what network call is upsetting them so much, and maybe include a "Three UK" mode into the app where I disable whatever functionality causes this...
    11-15-2013 04:59 AM
  14. jedibeckett1's Avatar
    Hi Jay,

    No joy with Three, they just say that there is no blocks of any kind on my account and that the issue must lie with the app. I believe you over them, but is there anything else I can do to help resolve this issue?

    Any help would be much appreciated. I'm getting nowhere with Three :(
    I am having the same problem, three have said that there is no block on my account and they want me to call nokia see if its a fault with them
    12-05-2013 02:39 PM
  15. jedibeckett1's Avatar
    Hi, I'm not sure how long it has been doing this as I normally use the app when I'm in range of WiFi (at home)... Today I found that if I browse an article about an app, and then swipe right to get to the link to download the app, I get the usual links to the forums etc. but if I try to download the app from the link in this list, I get the following error:

    We can't connect to the Store at the moment. Check your data connection or try again later.

    The problem is, that after this error, I can no longer send/recieve any data, if I start Internet Explorer, I get a message saying that tethering is not included in my plan and I should turn my phone off for a short time and then turn it on again.

    This does resolve the problem, but it is obviously a pain.

    This problem is totally reproduceable, as soon as I try and download an app from the right-swipe-link in the WPCentral app, I lose all data connectivity, until I switch off for a couple of minutes and then restart.

    My guess would be that something within the WPCentral app is trying to download something in a way that makes it look like tethering has been enabled on the handset.

    Please advise.
    I have been trying to get this error and it happens at the same time i swipe right.
    12-10-2013 04:53 PM
  16. daniel_sherlock's Avatar
    This happens to me, phoned three no help! Tweeted them they say its a know issue and hopefully resolved soon, that was about two months ago.


    Sent from my Nexus 7 using WPCentral Forums mobile app
    12-10-2013 05:17 PM
  17. Jay Bennett's Avatar
    Ok guys can a few of you send me your live id's via Direct Message here and I'll sort out a beta version to see if we can enable a special "Three UK" mode to work around their ridiculous tethering bug
    jedibeckett1 and cooldudefred like this.
    12-11-2013 06:29 AM
  18. daniel_sherlock's Avatar
    Done, thank you
    12-11-2013 09:49 AM
  19. daniel_sherlock's Avatar
    Hi I installed the update today and enabled three mode see how we get on
    12-14-2013 02:55 PM
  20. Jay Bennett's Avatar
    Hi I installed the update today and enabled three mode see how we get on
    Daniel, are you able to tell me if my fix worked correctly?
    12-16-2013 03:23 PM
  21. daniel_sherlock's Avatar
    Hi, so far no teathering message has come up used mobile with no WiFi for a few days !!

    Sent from my Nexus 7 using WPCentral Forums mobile app
    jedibeckett1 likes this.
    12-16-2013 06:27 PM
  22. Jay Bennett's Avatar
    Good stuff, this unfortunately means that you won't see the names of apps when you go to download them (we normally present a list when there are lots of apps mentioned in the same article), but I've isolated the call which was causing this issue, I'll push the fix out publicly soon
    stnnetindia and jedibeckett1 like this.
    12-17-2013 02:01 AM
  23. daniel_sherlock's Avatar
    Thank you for taking the time too deal with this issue!

    Sent from my Nexus 7 using WPCentral Forums mobile app
    12-17-2013 05:21 AM
  24. jedibeckett1's Avatar
    Great work Jay. Thanks for fixing this.
    12-17-2013 06:27 AM

Similar Threads

  1. My new app!! Please try and review!! Thank!!!!
    By dvd_nasa in forum App Spotlight
    Replies: 10
    Last Post: 10-28-2014, 09:16 PM
  2. Give clue of code for making photo collection apps
    By eugie in forum Developers Corner
    Replies: 3
    Last Post: 09-28-2013, 12:40 PM
  3. Nokia Panorama app - fixing via buil-in mechanism
    By josipogo in forum Applications
    Replies: 2
    Last Post: 09-25-2013, 11:46 PM
  4. TOUCHDEVELOP create apps just on your phone
    By eugie in forum Microsoft News & Rumors
    Replies: 1
    Last Post: 09-25-2013, 01:49 AM
LINK TO POST COPIED TO CLIPBOARD